Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

GENERATEUR BF et AUDIO

- SCHEMAS et doc -


Accueil

Accueil CHM


Vu dans ... https://www.zorgeffects.com/index.php/blogfr/34-tremoloo-ooo-ooo-ooo-ooo-2

Introduction

J'ai travaillé sur un tremolo pendant quelques jours, et je me suis dit qu'il serait intéressant de discuter de cet effet simple, mais pas si facile à construire. Si vous cherchez à vous monter une pédale de tremolo, j'espère que ce document pourra vous apporter quelques idées, des liens utiles, et vous éviter quelques impasses. De plus, pour les futurs utilisateurs du tremolo Zorglonde, ce papier dévoile dévoile certains de ses mystères et aide à mieux l'utiliser.

Le tremolo est un effet très simple: il change automatiquement le volume de votre signal. Votre volume augmente et diminue, selon une forme d'onde périodique. Mais son son est profondément affecté suivant la vitesse (ou la fréquence), la profondeur et la forme de cette forme d'onde. Vous pouvez écouter différents paramètres de la forme d'onde, de vitesse et de profondeur d'un tremolo sur ce premier enregistrement de test de la Zorglonde:

Le plan pour ce LONG article, c'est d'abord d'exposer mes envies et mes choix de conception, puis nous discuterons de toutes les possibilités techniques pour concevoir un tremolo et, à la fin, nous verrons les problèmes que j'ai rencontrés avec les choix que j'ai faits et comment je les ai résolus

Je dois ajouter que ce papier est en quelque sort complémentaire du papier de Coda Effects sur son tremolo:
http://www.coda-effects.com/2016/05/tap-tempo-tremolo-diy-complex-project.html
Ce qui est intéressant dans l'article de Coda Effects c'est qu'il décrit une philosophie totalement à l'opposée de celle que j'ai choisie...

Mes exigences et choix

Quand Dorian du groupe Høst m'a demandé si je pouvais lui construire un tremolo, je pensais que ce serait un travail intéressant, simple et rapide. Et j'ai eu tort. Le design d'un bon oscillateur m'a pris une semaine de recherche ...
Mais d'abord, je me suis donné les contraintes suivantes:
  • Il devait contenir dans une petite boite 6x11cm.
  • La fréquence du trémolo devait pouvoir être modifiée avec une pédale d'expression
  • La fréquence du trémolo devait pouvoir aller de 1Hz à 16Hz
  • L'oscillateur devait permettre de choisir entre une onde carrée ou une onde sinusoïdale

Ensuite, compte tenu de ces contraintes, il m'a fallu choisir parmi toutes les possibilités techniques permettant de construire une telle pédale. Certains savent que je ne cherche pas à faire un «dispositif transparent» et je recherche surtout la solution qui ajoutera un petit (ou grand) quelque chose au son. Au final mes choix on été très inspirés par cet article de Strymon:
http://www.strymon.net/amplifier-tremolo-technology-white-paper/

Au début, j'ai donc choisi de faire un montage JFET à variation de polarisation et un oscillateur à décalage de phase (Phase shift oscillator) . Il s'agit d'un montage classique et vintage pour un tremolo, donc ça correspondait à mon souhait de son coloré. Nous verrons dans les chapitres suivant ce que donne ces choix, et que finalement, j'ai dû modifier un peu mes choix pour répondre à toutes mes exigences...

Discutons des possibles!

Donc, si vous considérez l'électronique d'un tremolo, vous pouvez diviser la conception en deux: un contrôle automatique du volume, pour faire varier le volume du signal de haut en bas et un oscillateur basse fréquence, qui créera un signal périodique qui contrôlera automatiquement le volume.

Pour le contrôle automatique de volume, ces possibilités s'offrent à vous:
  • Avec un DSP.
  • Utiliser un amplificateur à transconductance.
  • Contrôler le volume à l'aide d'un optocoupleur.
  • Contrôler le volume à l'aide d'un transistor JFET.
  • Utiliser la polarisation d'un transistor pour en changer le gain.

Et pour l'oscillateur basse fréquence(LFO):
  • Créer un LFO numérique.
  • Utiliser des circuits intégrés dédiés.
  • Montage à Pont de Wien.
  • L'oscillateur à décalage de phase.
  • l'oscillateur à Quadrature.
  • Le filtre passe bande oscillant

En définitive il est assez difficile de réaliser un oscillateur sinusoïdal de bonne qualité. A ce sujet, TI a écrit un bon papier :
http://www.ti.com/lit/an/sloa060/sloa060.pdf
Le site suivant discute aussi de ce problème et donne de nombreuses solutions qui aident pas mal:
http://sound.whsites.net/articles/sinewave.htm

Le contrôle automatique du volume

Avec un DSP.

Avec un microprocesseur de traitement du signal donc, c'est un peu un canon pour tuer une mouche... C'est ce que Strymon fait avec sa pédale Flint. C'est un choix pertinent si vous êtes un gourou du DSP, et si vous prévoyez de générer des formes d'ondes complexes pour le LFO, ou si vous voulez avoir des presets et un tap tempo. Ça peut être intéressant aussi, si vous prévoyez d'utiliser votre plate-forme DSP plus tard pour d'autres projets. Mais la réalisation à partir de zéro sera assez longue!

Amplificateurs à transconductance.

Cela me semble être la manière la plus parfaite pour réaliser un tremolo. En utilisant, par exemple, un LM13700, il permettrait de construire un tremolo avec une très faible distorsion, propre et précis. De plus, il répondra très bien aux oscillateurs dans la gamme de fréquences audio (de 20Hz à 20kHz), en fabriquant un oscillateur ad-hoc, vous pourrez donc également utiliser votre tremolo comme modulateur en anneau (Ring mod - modulateur AM)! Mais ce choix était trop propre pour moi ...
Utilisation typique d'un LM13700 pour contrôle automatique de gain
Figure 1: Utilisation typique d'un LM13700 pour contrôle automatique de gain

Contrôle via un opotocoupleur

Le contrôle du volume peut être réalisé à l'aide d'une photo-résistance ou optocoupleur tels qu'un VTL5Cx ou NSL-32. IIs peuvent être utilisés soit dans un diviseur de tension, soit en contrôlant un gain d'ampli op:
Diviseur de tension
Figure 2: Diviseur de tension
La figure 2 montre un diviseur de tension qui donnera:

Donc si R1=0 il n'y aura pas d'audio en sortie, et si R1 est infinie, R2 devient négligeable et Audio Out= Audio In.

Le schéma suivant montre un optocoupleur NSL-32 utilisé pour contrôler le volume audio en sortie:
NSL32 contrôlant un diviseur de tension
Figure 3: NSL32 contrôlant un diviseur de tension
Compte tenu de la fiche technique du NSL-32: Lorsque sa led est allumée, Ron = 500Ω, et lorsque la led est éteinte Roff = 500kΩ, nous voyons que si nous prenons R2 = 10kΩ, nous obtiendrons: Lorsque la led NSL-32 est allumée: Sortie Audio = 0.047 x Entrée audio Lorsque la led NSL-32 est éteinte: Sortie Audio = 0,98 x Entrée audio Et nous pouvons voir que la réalisation d'une sortie 0V parfaite ne sera pas possible ...
Maintenant, si nous utilisons un ampli op:
NSL-32 contrôlant le gain d'un ampli op
Figure 4: NSL-32 contrôlant le gain d'un ampli op

Dans ce cas le gain de l'ampli op est donné par:

Si nous prenons R1 = 500Ω, nous obtiendrons: Lorsque la led NSL-32 est allumée: Sortie audio = - Entrée audio Lorsque la led NSL-32 est éteinte: Sortie audio = - 0,001 Entrée audio x Ce qui est un peu mieux! Même si vous obtiendrez de meilleurs résultats avec un VTL5C3 qui donne les valeurs suivantes: Ron = 1,5Ω, Roff = 10MΩ ...
Mais au final les optocoupleurs ont des inconvénients assez rédhibitoires:
  • Ils sont chers! (Jusqu'à 10€ pour un VTL)
  • Ils ne respectent pas la norme ROHS.
  • Il faut les sélectionner, surtout les NSL-32 qui ont des courbes de réponses assez disparates
  • Ils ne sont pas linéaires…
  • Ils sont lents. Oubliez la modulation en anneau avec. La forme d'onde carrée sera légèrement filtrées aussi, mais rien de dramatique.
L'avantage c'est qu'ils sont faciles à utiliser et qu'ils simplifient beaucoup la conception!
Cependant si vous ne cherchez à faire qu'une forme d'onde carrée, vous pouvez également regarder du coté des optocoupleurs BJT. Il s'agit d'une led contrôlant un transistor. Mais c'est quelque chose que je n'ai pas creusé, donc je ne le développerai pas dans ce papier.

Utiliser un JFET comme résistance variable.

Un JFET utilisé comme résistance variable peut être substitué au contrôle du volume optique: soit dans un diviseur de tension, soit pour contrôler le gain d'un ampli op:
Transistor FET dans un diviseur de tension
Figure 5:Transistor FET dans un diviseur de tension
Figure 6: Transistor FET sur montage ampli op

Si nous utilisons un J107, les mêmes calculs que pour les optocoupleurs s'appliquent ici, mais avec Rds = 8Ω (Vgs = 0V) et Rds Off> 2MΩ (avec Vgs> -2,5V), il est en fait plus efficace qu'avec un NSL et similaire à VTL mais 15-20 fois moins cher!
(Notez que les valeurs d'un JFET sont sujettes à de très grandes tolérances et donc peuvent varier énormément, mais elles sont toujours très bonnes!)

Sur certains aspects, ils sont meilleurs que les optocoupleurs: ils sont bon marché, rapides, plus petits, compatibles Rohs et vous pouvez ou non les sélectionner suivant la précision que vous souhaitez...
Mais ils ont aussi des inconvénients:
  • Pour un J107, le signal de l'instrument sur le drain ne doit pas être supérieur à 2Vcc ou il le fera clipper. Et des humbuckers à très haut niveau peuvent générer des signaux de 2Vcc.
  • Sur un n-fet comme le J107, vous devrez appliquer une tension négative entre la grille et la source pour la faire fonctionner comme une résistance variable.
  • Ils ne sont pas linéaires.
Distorsion d'un FET sur une signal 2Vcc 400Hz
Figure 7: Distorsion d'un FET sur une signal 2Vcc 400Hz

Contrôler le volume en ajustant la polarisation d'un transistor.

Cette technique fonctionne également avec un tube. Mais si vous faites varier la polarisation d'un préampli FET en intervenant directement sur sa tension de sa source, cela modifiera le gain de votre préampli. L'avantage de cette méthode est qu'elle est rapide, linéaire et bon marché. L'inconvénient est que, à faible gain, une distorsion se produira. Mais dans mon cas c'est cette distorsion que je voulais en exigeant un tremolo coloré! Parce que plus votre volume diminue à cause du LFO qui change la polarisation, plus de la distorsion se produit ... Donc, comme elle se produit pendant la phase de faible volume du tremolo, donc à un moment où elle devient peu perceptible, il y a un quelque chose de psychoacoustique qui se passe dans votre cerveau. C'est de là que vient la magie! Il a également un autre inconvénient: il ne fonctionnera pas bien avec les formes d'onde carrées. Mais nous verrons cela à la fin de ce papier.
Schéma pour faire varier le bias d'un FET.
Figure 8: Schéma pour faire varier le bias d'un FET.
L'illustration ci-dessous montre la distorsion produite sur une forme d'onde sinusoïdale de 200Hz lorsqu'un LFO de 4Hz de 4Vcc est appliqué à la source du FET. Comme vous pouvez le voir, c'est plutôt méchant (YOUPI!!!):
Distorsion causée par variation de polarisation du jFET
Figure 9: Distorsion causée par variation de polarisation du jFET

Parlons oscillateurs basse fréquence (LFO)...

Faire un LFO à forme d'onde carrée est facile et il existe de nombreuses possibilités de conception pour un bon LFO carré avec une large gamme comme de 1Hz à 1Mhz ... Idem pour une forme d'onde triangulaire LFO ou une dent de scie, qui sont un peu plus délicat que le carré, mais toujours faciles à monter.
Par contre, faire un bon LFO sinusoïdal sur une large gamme de fréquences peut être un cauchemar. Un bon LFO sinusoïdal a la capacité de générer une forme d'onde parfaite sur une large gamme de fréquences. Et en terme de sinus, «grand» peut être simplement de 1Hz à 15Hz!

LFO numérique.

Il existe plusieurs manières de créer un LFO numérique, soit avec un DSP, soit avec des PWM filtrés sur un microcontrôleur 8/16 bits, ou avec des compteurs en circuits imprimés discrets puis filtrés... Dans tous les cas c'est une manière qui permet une très large gamme de fréquences avec le moins de distorsion possible. De plus, il permet de faire toutes sortes de formes d'onde sans limites: sinus, triangle, carré, dents de scie, aléatoire, demi-sinus, sinus progressif, etc. Jetez un oeil au papier de Coda Effets mentionné ci-dessus, il y a quelques exemples de formes d'ondes générées par son microprocesseur.
C'est aussi le seul moyen d'obtenir un contrôle de fréquence via tap-tempo.
Ma principale préoccupation à propos de cette possibilité était qu'elle pourrait prendre trop d'espace sur la carte, même si un petit ATtiny pouvait faire l'affaire avec un LFO filtré par PWM ... Le développement du code à partir de zéro pour un tel LFO prendrait beaucoup de temps, même si vous pouvez trouver des tutoriels sur Internet pour réduire le temps de codage.
Et puis surtout vous pouvez trouver des CI déjà programmés pour un prix de vente correct. Chez Electric druid par exemple:
http://electricdruid.net/product/taplfo-tap-tempo-lfo/

Circuits intégrés dédiés.

Je parle des circuits intégrés tels que le Maxim's MAX038 ou XR2206 d'Exar. Ces circuits sont un peu chers (le MAX038 coûte 25 €!), mais sont simples à utiliser, donnent des formes d'onde de distorsion faible sur une très large gamme de fréquences (De 2Hz à 4kHz pour le XR et de 2Hz à 700Hz pour le MAX).
Regardez les fiches techniques pour un aperçu de ce qu'ils peuvent faire:
https://www.sparkfun.com/datasheets/Kits/XR2206_104_020808.pdf
Dans mon cas ils était beaucoup trop chers et facilement battus par le processeur d'Electric Druid…

Le pont de Wien.

En ce qui concerne les oscillateurs analogiques de forme sinusoïdale, le pont de Wien est la première idée qui vient à l'esprit. Vous pouvez obtenir une excellente forme sinusoïdale... Jusqu'à ce que vous souhaitiez balayer sa fréquence, là ça deviendra une autre paire de manches. Mais le pont de Wien est simple à comprendre et utilise peu de composants:
Schéma de base d'un pont de Wien oscillateur.
Figure 10: Schéma de base d'un pont de Wien oscillateur.
Avec le schéma ci-dessus, si vous voulez que l'oscillation se produise, il faut R1 = R2 = R, C1 = C2 = C et R3> R4.
Ensuite, la fréquence d'oscillation sera:

Il y a une bonne explication de son fonctionnement sur Wikipedia (version anglaise):
https://en.wikipedia.org/wiki/Wien_bridge_oscillator

La partie la plus importante étant:
"L'oscillateur peut être considéré comme un amplificateur à gain positif combiné avec un filtre passe-bande qui fournit une boucle de rétroaction positive. [...] En pratique, le gain de la boucle est un peu plus grand que l'unité. Comme du bruit aléatoire est présent dans tous les circuits et certains de ces bruits seront proches de la fréquence désirée. Un gain en boucle supérieur à l'unité permet à l'amplitude de la fréquence d'augmenter exponentiellement à chaque tour de boucle. Avec un gain de boucle supérieur à un, l'oscillateur démarrera.

Idéalement, le gain en boucle doit être un peu plus grand que l'unité, mais en pratique, il est souvent significativement supérieur à un. Un gain de boucle plus large permet à l'oscillateur de démarrer plus rapidement. Un grand gain de boucle compense également les variations de gain avec la température et la fréquence désirée d'un oscillateur variable. Pour que l'oscillateur démarre, le gain de boucle doit être supérieur à un dans toutes les conditions possibles.

Un gain de boucle supérieur à un pose cependant cependant un souci. En théorie, l'amplitude de l'oscillateur augmentera sans limite. En pratique, l'amplitude augmentera jusqu'à ce que la sortie atteigne un facteur limitant tel que la tension d'alimentation (la sortie de l'amplificateur sature au niveau des rails d'alimentation) ou aux limites de courant de sortie de l'amplificateur. La limitation réduit le gain effectif de l'amplificateur (l'effet est appelé compression de gain). Dans un oscillateur stable, le gain de la boucle moyenne sera donc de un. "

Enfin, vous pouvez changer la fréquence du pont de Wien en utilisant un seul potentiomètre sur R1. Mais pour une plus grande gamme de fréquence, vous devrez contrôler R1 et R2 avec un double potentiomètre. Et malgré cela, il va rapidement entrer en distorsion sur une extrémité, ou en atténuation à l'autre extrémité. Une gamme de fréquences de x4 (2Hz à 8Hz) est ce que vous pourrez obtenir de mieux avec un potentiomètre double, avec en prime beaucoup de problèmes de distorsion et d'amplitude.

Certains suggèrent d'utiliser une ampoule spéciale à la place de R3 pour améliorer la stabilité ou d'utiliser un condensateur variable double pour C1 et C2. Si vous êtes assez chanceux pour avoir un de ces appareils exotiques, vous pouvez vous lancer.

Mais, plus important encore, vous pouvez améliorer la conception du pont Wien avec un contrôle de gain automatique pour obtenir une meilleure qualité sur toute la gamme de fréquences. Je n'ai pas eu l'envie ni le temps de l'essayer, mais ça pourrait valoir un test:
Pont de Wien avec contrôle automatique du gain
Figure 11: Pont de Wien avec contrôle automatique du gain
Mais au final le pont de Wien a été rejeté par l'exigence de la pédale d'expression: il n'y a pas de double potentiomètre dans une pédale d'expression.

LFO à décalage de phase.

L'oscillateur à décalage de phase est un design classique qui est utilisé dans de nombreux tremolos, spécialement dans des amplis à tube vintage. Ce qui est bien avec cette conception est qu'elle nécessite très peu de composants qui sont peu coûteux, il peut fonctionner soit avec un transistor ou un AOP, mais sa compréhension peut être un peu complexe:
Oscillateur à décalage de phase avec un AOP
Figure 12: Oscillateur à décalage de phase avec un AOP
Oscillateur à décalage de phase avec un transistor.
Figure 13: Oscillateur à décalage de phase avec un transistor.
Prenons le cas de la version transistor, un moyen de comprendre simplement ce qui se passe est que si le transistor est fermé, le courant circulera dans les cellules RC dans lesquelles il sera retardé, jusqu'à ce qu'il atteigne la base du transistor. Comme les cellules RC se chargent lentement, la base ouvrira lentement le transistor et le courant disparaîtra lentement dans les cellules RC, ce qui les poussera à se décharger. Lors de la décharge, le transistor se fermera, et le courant passera à nouveau à travers les cellules et etc.
Il est nécessaire d'avoir un gain de 30 avec l'ampli op (R4 = 30xR) ou le transistor. Avec le transistor, vous devrez ajouter un buffer en sortie si vous souhaitez attaquer un étage suivant à faible impédance .
Vous pouvez également ajouter d'autres cellules RC pour améliorer la stabilité et la distorsion. Mais si vous prenez R1 = R2 = R3 = R et C1 = C2 = C3 = C, la version à 3 cellules oscillera à:
Mais cette conception a le même inconvénient que le pont de Wien: la gamme de fréquences est très limitée et il y a pas mal de distorsion. Vous pouvez atteindre une gamme x4 avec un potentiomètre standard simple, un potentiomètre stéréo vous permettra d'atteindre une gamme de x5 ou x6 et plus encore avec un triple potentiomètre. Cependant il reste beaucoup de distorsion et la forme d'onde est loin d'être parfaite.
Regardez la page suivante pour plus d'informations, elle montre également à la fin comment le sinus est déformé en sortie:
http://home.earthlink.net/~doncox/wec/Oscillators.html

Je pensais que cette conception remplierait mes exigences et j'ai passé beaucoup de temps à la peaufiner. Mais au final elle s'est révélée inutile, la gamme de fréquences était toujours trop petite!

Sachez que de meilleurs résultats peuvent être obtenus avec un design à buffers ou Bubba, mais ils utilisent plus de composants et d'espace. Consultez-les sur cette page:
http://sound.whsites.net/articles/sinewave.htm

Oscillateur de quadrature.

Bon pour celui ci il fallait un potentiomètre triple, donc passons rapidement.

Oscillateur à filtre passe bande.

C'est mon choix final. C'est un design simple, avec peu de composants bon marché. Il utilise un potentiomètre mono qui répond aux exigences. La forme d'onde sinus générée a une distorsion très faible et la gamme de fréquence fait juste ce qu'il faut: x15. Mon design peut ainsi aller de 1Hz à 15Hz, mais il y a un peu de perte de signal à l'extrémité supérieure (l'amplitude du sinus de 15 Hz est la moitié du sinus de 8 Hz). Et en dessous de 1Hz c'est trop lent pour un tremolo.
Oscillateur à filtre passe bande final
Figure 14: Oscillateur à filtre passe bande final
Le schéma ci-dessus montre la conception finale avec les valeurs de composants permettant d'obtenir l'implémentation de plage de fréquences de 1Hz à 15 Hz et d'une pédale d'expression (potentiomètre 10k) entre exp_ring et exp_tip. Ce schéma est aussi simple que le pont Wien: l'AOP de droite forme un filtre passe-bande dont la fréquence centrale est fonction de la position du potentiomètre RATE. L'AOP de gauche fournit une boucle de retour avec gain unitaire pour maintenir l'oscillation à la fréquence centrale. Les Diodes D3 et D4 sont utilisées pour limiter l'amplitude d'oscillation à 2Vcc.

Attention avec ce design, si cette conception fonctionne très bien comme un LFO, il semble que ce ne soit pas un très bon générateur de formes sinusoïdales dans la gamme audio et au dessus si une large plage est nécessaire.

Conception de la Zorglonde.

Donc les choix de conception étaient faits: un LFO à filtre passe bande et un JFET dont on fait varier la polarisation.

Pour obtenir un LFO avec une forme d'onde carrée, j'ai simplement utilisé un transistor saturé pour obtenir la forme d'onde carrée depuis la forme sinusoïdale. La forme d'onde carrée n'est pas parfaite mais ça suffira. Vous pouvez ajouter un autre transistor saturé pour l'améliorer si vous en avez envie. Bonus: mettre la led sur le collecteur du transistor vous donnera un voyant clignotant à la fréquence du LFO:
Du sinus au carré
Figure 15: Du sinus au carré
Mais il y a un problème avec la conception utilisant la polarisation du JFET: lorsque le LFO se rapproche des fréquences audibles (12Hz, 16Hz), et plus votre LFO est déformé, plus on entend l'oscillateur ajouté au signal. Ceci est normal, car la polarisation du FET est modifiée par le LFO, la fréquence du LFO est directement introduite dans la sortie de drain du FET:
Sortie du Fet lors de changement du bias sur le drain 15Hz: en rouge la sortie LFO, bleu le son d'entrée modulé où le LFO est présent.
Figure 16: Sortie du Fet lors de changement du bias sur le drain 15Hz: en rouge la sortie LFO, bleu le son d'entrée modulé où le LFO est présent.
Donc, vous aurez besoin d'un filtrage important en basse fréquence pour minimiser ce bruit. Mais si le LFO du sinus a une certaine distorsion, il sera difficile d'éliminer les harmoniques supérieures restantes qui apparaîtront dans la plage audio. Dans mon cas, j'ai ajouté 3 cellules RC passe-haut coupant environ 80 Hz. Cela donne le résultat suivant:
Sortie du Tremolo lors de changement du bias sur le drain à 15Hz: en rouge la sortie LFO, bleu le son d'entrée modulé où le LFO est présent. Pas parfait mais bien mieux!
Figure 17: Sortie du Tremolo lors de changement du bias sur le drain à 15Hz: en rouge la sortie LFO, bleu le son d'entrée modulé où le LFO est présent. Pas parfait mais bien mieux!
Sortie du Tremolo lors de changement du bias sur le drain à 8Hz: en rouge la sortie LFO, bleu le son d'entrée modulé où le LFO est présent. Quasiment parfait à cette fréquence!
Figure 18: Sortie du Tremolo lors de changement du bias sur le drain à 8Hz: en rouge la sortie LFO, bleu le son d'entrée modulé où le LFO est présent. Quasiment parfait à cette fréquence!
Mais ce problème s'aggrave lorsque vous passez sur le LFO carré, car il introduit des harmoniques de haute fréquence en passant de l'état bas à l'état haut, et ceci même à des fréquences du LFO faibles (comme 1 Hz). Et ces glitches ne peuvent pas être supprimées, à moins de de filtrer tout votre son de guitare en essayant de l'enlever!
Donc, la conception par polarisation du JFET est mauvaise avec une forme d'onde carrée! Afin d'utiliser la forme d'onde carrée, j'ai ajouté un JFET comme une résistance variable, en construisant un diviseur de tension avant le JFET:
Design final du contrôle automatique de volume
Figure19: Design final du contrôle automatique de volume
Dans cette conception, les valeurs du diviseur de tension sont choisies pour minimiser l'écrêtage dans le JFET utilisé comme résistance variable et essayer de réduire le signal d'un humbucker puissant en dessous de 2Vcc. Notez que si vous changez les valeurs de résistance avec un commutateur, vous pouvez adapter le tremolo à vos micros et gagner de la dynamique si vous avez micros simples bobinages vintage ou obtenir un peu de saturation si vous avez des micros à niveau de sortie élevés. Les valeurs du diviseur de tension ont également été choisies pour minimiser le bruit de glitch. Avec cette conception les défauts de la forme d'onde carrée sont fortement diminués, mais si les valeurs de résistance sont trop élevées, vous les entendrez encore un peu si votre tremolo est avant une distorsion au gain élevé.

Ensuite, j'ai laissé la forme de l'onde sinusoïdale comme contrôle du bias du jFET, parce que si vous vous demandez ce qui se passe si vous branchez le LFO sinusoïdal au JFET utilisé dans le diviseur de tension, voici ce que vous obtenez: une linéarité pourrie.
sinus à 400Hz déformé par un sinus de 6Hz appliqué sur le diviseur de tension
Figure 20: sinus à 400Hz déformé par un sinus de 6Hz appliqué sur le diviseur de tension
L'inconvénient de cette conception est que j'ai dû utiliser un circuit à pompe de charge pour créer -9v à partir des 9v en entrée. Et puis l'oscillateur ne fonctionne pas en 0-9v, et j'ai besoin d'une tension négative sur le JFET utilisé comme résistance variable.

Conclusion.

En conclusion, regardons simplement la sortie de ce tremolo. Le réglage de profondeur est le même pour toutes les courbes, à l'exception de la courbe d'impulsions où il est un peu plus profond.

Pour l'onde sinusoïdale du LFO.
Sinus de 400Hz modulé par un sinus de 1Hz
Sinus de 400Hz modulé par un sinus de 1Hz
Sinus de 400Hz modulé par un sinus de 7etquelquesHz
Sinus de 400Hz modulé par un sinus de 14Hz
Sinus de 400Hz modulé par un sinus de 14Hz
Sinus de 400Hz modulé par un sinus de 1Hz
Sinus de 400Hz modulé par un sinus de 1Hz. En tournant un peu plus loin la profondeur on obtient des pulses charmantes.

Pour l'onde carrée du LFO.
Sinus de 400Hz modulé par un carré de 1Hz
Sinus de 400Hz modulé par un carré de 1Hz
Sinus de 400Hz modulé par un carré de 7etquelquesHz
"Sinus de 400Hz modulé par un carré de 7etquelquesHz
Sinus de 400Hz modulé par un carré de 14Hz
Sinus de 400Hz modulé par un carré de 14Hz


Oscillateurs et filtres

Circuit d'oscillation et de filtration

  • 1. Les filtres
  • 2. Les oscillateurs

1. Les filtres :

  • Il existe deux grandes familles de filtres : les filtres passifs et les filtres actifs.

  • Un filtre est un ensemble, de composants électriques ou électroniques, qui laisse passer le signal à certaines fréquences et l’atténue à d’autres.

  • On utilise des filtres en asservissements (problèmes de stabilité) et en communications (accord sur certaines fréquences (filtres IF), détection (élimination de la porteuse)). En téléphonie, on les utilise dans les systèmes Touch-Tone et pour détecter certaines fréquences servant à la commutation de lignes.

  • On dit couramment que l’on filtre ou laisse passer certaines fréquences et que l’on bloque ou atténue les autres.

  • On distingue quatre grandes catégories de filtres, à savoir :

  • 1. Les filtres passe-bas
  • 2. Les filtres passe-haut
  • 3. Les filtres coupe-bande
  • 4. Les filtres passe-bande
  • 5. Rappel sur le décibel
  • 6. Décade et octave
  • 7. Les filtres passifs
  • 8. Les filtres actifs
  • 9. Les niveaux de référence

- Les filtres passe-bas

Leur diagramme gain-fréquence de réponse idéale est semblable à celui de la figure suivante.

Jusqu’à la fréquence Fc dite fréquence de coupure, le signal passe à travers le filtre. À cette fréquence, il y a coupure et aucun signal de fréquence supérieure à Fc ne traverse le filtre.

- Les filtres passe-haut

Dans ce cas, le signal de fréquence inférieure à Fc est coupé et celui de fréquence supérieure à Fc n’est pas atténué.

- Les filtres coupe-bande ou éliminateurs de bande

Ces filtres sont des combinaisons (parallèles) de filtres passe-bas et de filtres passe-haut. Tout signal de bande de fréquence comprise entre Fb (fréquence de coupure basse) et Fh (fréquence de coupure haute) est éliminé tandis que tout signal d’une autre fréquence est transmis.

- Les filtres passe-bande ou à bande passante

Ces filtres sont des combinaisons (séries) de filtres passe-haut et de filtres passe-bas. Dans ce cas, seule la bande de fréquence comprise entre Fb (fréquence de coupure basse) et Fh (fréquence de coupure haute) est transmise. Les autres fréquences sont rejetées.

  • Ces diagrammes sont des diagrammes idéaux impossibles à obtenir en pratique. On ne peut obtenir la partie rectiligne horizontale car l’amplitude du signal transmis peut onduler en fonction de la fréquence. On ne peut non plus obtenir la coupure franche. En pratique, la coupure est définie à demi puissance (-3 dB) et la pente du diagramme est de -20 dB par décade ou de -6 dB par octave.

1.1. Rappel sur le décibel

L’amplification est définie comme étant le rapport d’une grandeur de sortie sur une grandeur d’entrée.

Amplification en puissance AP = POUT/PIN

Amplification en tension AV = VOUT/VIN

Amplification en courant AI = IOUT/IIN

Il est plus commode de prendre une échelle logarithmique, ce qui rétrécit l’étendue de la variation : ainsi, si un rapport varie de 1 à 1000 000, son logarithme décimal varie de 0 à 6.

Le Bel (symbole B) est par définition le logarithme décimal de l’amplification en puissance.

AP (Bels) = Log AP

1 Bel = Log 10 alors si le gain AP = 10 è AP (B) = 1

Exemples :

AP = 10 000 è AP (B) = Log 10 000 = 4 B

AP = 20 000 è AP (B) = Log 20 000 = 4.3 B

Afin de réduire l’emploi des nombres décimaux, le gain en puissance est exprimé le plus souvent en décibels (dB).

1 Bel = 10 décibels, donc AP (dB) = 10 Log AP

Exemples :

AP = 10 000 è AP (dB) = 10 Log 10 000 = 40 dB

AP = 20 000 è AP (dB) = 10 Log 20 000 = 43 dB

Gain en tension exprimé en décibels :

P = V2 / R è POUT = V2OUT/R, PIN = V2IN/R

AP = POUT/PIN = V2OUT/V2IN = (VOUT/VIN)2

Le gain sera cette fois calculé en fonction des tensions, on le notera alors :

AV (dB) = 10 Log (VOUT/VIN)2 . Comme Log X2 = 2 Log X alors :

AV (dB) = 10 x 2 Log VOUT/VIN = 20 log VOUT/VIN

Gain en courant exprimé en décibels :

De la même façon que précédemment, P=RI2 è POUT =RI2OUT, PIN=RI2IN

Comme AI = IOUT/IIN, alors AI (dB) = 20 Log IOUT/IIN

Décibels négatifs :

Si la grandeur de sortie est plus petite que la grandeur d’entrée, il y a atténuation ou affaiblissement et le gain en décibels est alors négatif.

Exemple : PIN = 3 W, POUT = 1.5 W

POUT/PIN = 1.5/3 = 0.5 è AP (dB) = 10 Log 0.5 = -3 dB

L’exemple suivant montre la commodité de l’échelle logarithmique :

On parle devant un microphone qui fournit un signal de 30 mV. Ce signal passe dans un préamplificateur qui fournit un signal ligne de 1 à 2 volts. Ce signal attaque un amplificateur de puissance (1000W/4W). À sa sortie, on pourra mesurer environ 63 volts, ce qui suffira à faire bouger la membrane d’un haut-parleur pour déranger tout le voisinage.

En calculant le facteur d’amplification "Av" de cette chaîne, on obtient :

Av = VOUT / VIN = 63 / 0.03 = 2100

On peut pousser encore plus loin. Un amplificateur de 2000 Watts sous 8 ohms délivre 126 volts au haut-parleur. En partant d’un très faible signal de l’ordre de 10 mV capté par un microphone électrostatique, l’amplification "Av" est de :

Av = VOUT / VIN = 126 / 0.01 = 12600

Exprimés en décibels, ces gains sont de :

Av = 2100 è Av (dB) = 20 log 2100 = 66.4 dB

Av= 12600 è Av (dB) = 20 log 12600 = 82 dB

En résumé, le DÉCIBEL rétrécit l’étendue de la variation : ainsi, si un rapport varie de 1 à 1000 000, son logarithme décimal varie de 0 à 6, l’amplification en tension quant à elle varie de 0 à 120 dB. Ceci est le premier avantage de l’utilisation du décibel.

Le deuxième avantage est que l’on peut facilement additionner les facteurs d’amplification d’une chaîne audio ou vidéo. Ceci découle de la propriété des logarithmes : Log (A1 x A2) = Log A1 + Log A2

Exemple

On peut de la même manière exprimer en décibel aussi bien le gain en puissance que le gain en courant.

AP (dB) = 10 Log (POUT / PIN)

AI (dB) = 20 Log (IOUT / IIN)

Les amplificateurs de sonorisation et les amplificateurs d’antennes ont généralement un gain de 26 dB à 32 dB ce qui signifie qu’ils augmentent la valeur de la tension de 20 à 40 fois respectivement.

Puissance versus tension :

La puissance P = V2 / R, ce qui signifie que :

§ Si R = 50W, VIN = 1V, VOUT = 1V è Av = 1, POUT = 20mW

On amplifie le signal de 1.414 = 21/2, la tension VOUT est alors de 1.414 è AV = 1.414, POUT = 40mW. On constate que la puissance a doublé. Noter que 1.414 = 1/0.707

Le gain AV exprimé en décibel est alors de AV (dB) 20 Log 1.414 = +3dB.

§ Si la tension double soit VOUT = 2V, AV = 2 è POUT = (2)2 / 50 = 80mW, AV (dB) = 20 Log 2 = +6 dB, la puissance quadruple.

Oreille humaine :

Le volume du son (pression acoustique) est lui aussi converti de façon logarithmique et chiffré en décibels.

Physiquement la pression acoustique est mesurée en Pascal ou Newton/m2. L’étendue du son du plus faible au plus fort va d’environ 0.00002 Pa ou N/m2 à 1500 Pa ou N/m2. Pour éviter des chiffres trop compliqués, on a converti ces nombres en dB, la référence ou le 0 dB étant le 0.00002 Pa.

Aux alentours de 130 à 140 dB, l’oreille commence à rendre l’âme.

Un bruit de fond correspond à : 40 à 50 dB

Une conversation normale : 60 à 80 dB

Les sons médiums (1Khz à 4Khz) sont perçus plus forts que les aigus et les graves. Moins le volume est fort, plus se creusera cette différence de perception. Sur certains systèmes de son haute fidélité, on retrouve un réglage LOUDNESS, qui justement relève le niveau des aigus et des basses pour parer à ce déséquilibre à bas niveau.

Décade et octave :

Une décade est l’espace entre deux fréquences dont le rapport est de 10 alors qu’une octave est l’intervalle entre deux fréquences dont l’une est le double de l’autre.

Exemple :

Dans la suite des fréquences suivantes : 10Hz, 100Hz, 1Khz, 10Khz, 100 Khz, l’espace entre deux fréquences successives est d’une décade.

Dans la suite des fréquences suivantes : 10Hz, 20Hz, 40Hz, 80Hz, 160Hz, l’espace entre deux fréquences successives est d’une octave.

Le terme – 20 dB / décade signifie que le gain en tension diminue de 10 fois sa valeur lorsque la fréquence augmente de 10 fois sa valeur.

20 log (VOUT/VIN) = -20 è log (VOUT/VIN) = -1 è (VOUT/VIN) = shift log (-1) = 10-1 = 0.1 ou VOUT = VIN / 10

Le terme – 6 dB / octave signifie que le gain en tension diminue de 2 fois sa valeur lorsque la fréquence augmente de 2 fois sa valeur.

20 log (VOUT/VIN) = -6 è log (VOUT/VIN) = -0.3 è (VOUT/VIN) = shift log (-0.3) = 10-0.3 = 0.5 ou VOUT = VIN / 2

1.2. Les filtres passifs

Ils sont construits avec des résistances, des bobines et des condensateurs et n’ont pas besoin de polarisation. Pour se familiariser avec le filtrage et la réponse en fréquence des filtres, nous allons étudier les différents types de filtres passifs.

a) Filtre passe-bas

Pour VIN =20 et R2 prenant successivement les valeurs 10K, 5K, 1K, 500W, 100W, 50W, 25W et 15W, Calculons VOUT

R2 | VOUT
10K | 19.98V
5K | 19.96V
1K | 19.8V
500W | 19.6V
100 W | 18.2V
50 W | 16.67V
25 W | 14.3V
15 W | 12V

On remarque que la tension de sortie diminue au fur et à mesure que la résistance diminue. En alternatif, si on remplace la résistance R2 par un composant dont la réactance diminue avec l’augmentation de la fréquence, on obtient un filtre RC. Le condensateur est le composant qui présente cette caractéristique.

La réactance du condensateur est inversement proportionnelle à la fréquence :

1

XC = ---------

2 p F C

Voyons les différentes valeurs que prend la réactance d’un condensateur de 16 mF en fonction de la fréquence du signal qui lui est appliqué (voir tableau ci-après).

Avec une tension d’entrée de 20 volts et une résistance de 10 W en série avec le condensateur, les tensions aux bornes du condensateur C sont les suivantes :

F (Hz)

XC (W)

Z (W)

VC (V)

VC / V

VC / V (dB)

1

9947

9947

20

1

0

10

994.7

994.7

20

1

0

100

99.5

100

19.9

0.995

- 0.04

200

49.74

50.74

19.6

0.98

- 0.175

400

24.87

26.8

18.56

0.928

- 0.65

994.7

10

14.14

14.14

0.707

- 3

10K

0.99

10.05

1.97

0.0985

- 20

20K

0.497

10.01

0.99

0.049

- 26

100K

0.099

10

0.2

0.01

- 40

Supposons qu’on applique cette tension Vc à une résistance pure de 10 W et calculons les puissances dissipées dans celle-ci à la fréquence de 10 Hz puis à la fréquence de résonance 994.7 Hz :

À 10 Hz V1 = Vc = 20 volts

À 994.7 Hz, V2 = 0.707 x Vc = 14.14 volts

P1 = V12/R = 202/10 = 40 W

P2 = V22/R = 14.142/10 = 20 W

P2 / P1 = 20 / 40 = 0.5 soit 50 %

Le signal a perdu 50% de sa puissance. La fréquence de coupure de ce filtre est bien de 994.7 Hz.

On remarque que ce filtre coupe les fréquences hautes et laisse passer les fréquences basses. La coupure se produit lorsque R = XC

R = XC è R = 1 / 2pFC è FC = 1 / 2pRC = 1 / 2p x 10 x 16 x 10-6 = 994.7 Hz

L’atténuation de ce filtre est de :

- 6 dB par octave

Exemple : prenons l’octave 10 Khz – 20 Khz du tableau précédent :

À 10 Khz, Vc / E = -20 dB

À 20 Khz, Vc / E = -26 dB

La différence entre les deux est de : -26–(-20)=-26+20=-6 dB

- 20 dB par décade

Exemple : prenons la décade 10 Khz – 100 Khz du tableau précédent :

À 10 Khz, Vc / E = -20 dB

À 100 Khz, Vc / E = -40 dB

La différence entre les deux est de : -40–(-20)=-40+20=-20 dB

Filtre passe-bas RL : la réactance de la bobine varie également en fonction de la fréquence. On peut donc aussi concevoir un filtre passe-bas construit avec une bobine et une résistance.

Le circuit d’un tel filtre est le suivant :

XL = 2 p F L

Voyons les différentes valeurs que prend la réactance d’une bobine de 10 mH en fonction de la fréquence du signal qui lui est appliqué (voir tableau ci-après).

Avec une tension d’entrée de 20 volts et une résistance de 1 KW en série avec le condensateur, les tensions aux bornes de la résistance R sont les suivantes :

F (Hz) | XL (W) | VR (V)
1 | 0.06 | 20
1K | 63 | 19.96
2K | 125.7 | 19.84
3K | 188.5 | 19.65
4K | 251.3 | 19.4
6.6K | 414.7 | 18.47
15.92K | 1000.3 | 14.14
100K | 6283 | 3.14

Supposons qu’on applique cette tension VR à une résistance pure de 1000 W et calculons les puissances dissipées dans celle-ci à la fréquence de 1 Hz puis à la fréquence de résonance 15.92 Khz :

À 1 Hz V1 = VR = 20 volts

À 15.92 Khz, V2 = 0.707 x VR = 14.14 volts

P1 = V12/R = 202/1000 = 400 mW

P2 = V22/R = 14.142/10000 = 200 mW

P2 / P1 = 200 mW / 400 mW = 0.5 soit 50 %

Le signal a perdu 50% de sa puissance. La fréquence de coupure de ce filtre est bien de 15.92Khz.

On remarque que ce filtre comme le filtre précédent coupe les fréquences hautes et laisse passer les fréquences basses. La coupure se produit lorsque R = XL

R = XL è R = 2pFL è FC = R / 2pL = 1000 / 2p x 10 x 10-3 = 15.92 Khz

b) Filtre passe-haut

Avec une tension d’entrée de 20 volts et une résistance de 10 W en série avec le condensateur, les tensions aux bornes de la résistance R sont les suivantes :

F (Hz) | Xc (W) | VR (V)
1 | 9947 | 0.02
400 | 24.87 | 7.46
994.7 | 10 | 14.14
2K | 4.97 | 17.9
2.4K | 4.14 | 18.98
7K | 2.49 | 19.4
10K | 0.99 | 19.9
100K | 0.099 | 20

On remarque que ce filtre coupe les fréquences basses et laisse passer les fréquences hautes. La fréquence de coupure est ici de 994.7 Hz.

XL = 2 p F L

Avec une tension d’entrée de 20 volts et une résistance de 1 KW en série avec le condensateur, les tensions aux bornes de la bobine L sont les suivantes :

F (Hz) | XL (W) | VL (V)
1 | 0.06 | 0.001
1K | 63 | 1.26
10K | 628 | 10.64
14K | 879.6 | 13.2
15.92K | 1000.3 | 14.14
40K | 2513.3 | 18.58
50K | 3141.6 | 19.1
100K | 6283 | 19.75

Comme le filtre RC précédent, ce filtre coupe les fréquences basses et laisse passer les fréquences hautes. La fréquence de coupure est ici de 15.92 Khz.

c) Filtre passe-bande

Dans plusieurs circuits électroniques, il est parfois nécessaire de ne laisser passer que certains signaux à des fréquences bien précises et d’en éliminer les autres. Une des applications du circuit « RLC série » à la résonance est un filtre passe-bande.

Étant donné que le courant est partout le même dans un circuit série et que les réactances sont égales à la résonance (XL = XC), les tensions aux bornes des composants L et C sont égales et s'annulent. Par conséquent la tension appliquée au circuit est égale à la tension aux bornes de la résistance.

Comme le courant est maximal à la résonance, la tension aux bornes de la résistance sera aussi maximale comme le montre la figure ci-dessus.

Si on s’arrange pour que XL soit plus grand que R, ce qui est facile en prenant du fil assez gros, le rapport (XL/R) qui est le coefficient de qualité peut être égal à 10, 50, 100, 200, 400 et même plus. Avec un grand coefficient de qualité, la tension descend abruptement de part et d’autre de la fréquence de résonance.

Ce circuit peut être utilisé comme un filtre passe-bande, dans lequel la bande passante est limitée par les fréquences où la tension tombe à 70,7 % de sa valeur maximale.

d) Filtre coupe bande ou éliminateur de bande (Band Stop ou Notch filter)

Une des applications du circuit résonant parallèle (la résonance est obtenue lorsque XL = XC) est le filtre éliminateur de bande montré à la figure suivante :

La fonction de ce type de filtre est d'éliminer les signaux à la fréquence de résonance. En effet, à cette fréquence, l'impédance équivalente du circuit composé de L et C est à son maximum, de sorte que le maximum de tension se retrouve aux bornes de l’ensemble « L et C ». La tension aux bornes de R est alors minimale. Lorsque la fréquence du circuit s'éloigne de sa valeur de résonance, l'impédance équivalente du circuit composé de L et C diminue, ce qui a pour effet d’augmenter la tension aux bornes de la résistance. La largeur de bande ou "Wide Band" (LB ou WB) de ce filtre éliminateur de bande est limitée par les fréquences où la tension tombe à 70,7 % de sa valeur maximale.

1.3. Les filtres actifs

(a) Aux basses fréquences, les bobines sont volumineuses et coûteuses. De plus L varie en fonction de la fréquence en raison des pertes dans le fer. On construit, à l’aide d’amplificateurs opérationnels des filtres actifs à caractéristique décroissante abrupte semblable à celle des filtres LC passifs. Il existe un grand nombre de filtres actifs différents (Butterworth, Chebyshev, Bessel). Le plus répandu est le filtre de Butterworth.

Ce circuit est composé d’un filtre passe bas RC suivi d’un amplificateur opérationnel dont le gain en boucle fermée (CL= Close Loop) est :

Rf

ACL = --------- + 1

Ri

Ce filtre laisse passer toutes les fréquences jusqu’à la fréquence de coupure FC ; au-dessus de cette fréquence, la caractéristique de réponse en fréquence descend de 20 dB par décade. On appelle un tel filtre "filtre passe bas" ou LPF.

(b) Pôles ou ordres : on utilise souvent le mot "Pôle" ou "Ordre" dans l’étude des filtres. On parle d’un filtre passe bas à un pôle, deux pôles, trois pôles etc.

Pour obtenir le nombre de pôles, on compte le nombre de réseaux de retard. Le circuit précédent est un filtre à un pôle.

(c) Filtre passe bas à deux pôles

Ce filtre comporte deux réseaux de retard. Le calcul mathématique montre que pour le gain en boucle fermée ACL= 1.586, on obtient la caractéristique de réponse la plus horizontale dans la bande médiane de fréquence.

Rf

ACL = --------- + 1 = 1.586 è Rf = 0.586 x Ri

Ri

Si Ri = 1KW alors Rf = 0.586 x 1K = 586 W (560 W normalisée)

Si le gain est inférieur à 1.586, la caractéristique du filtre tend vers un déphasage linéaire en fonction de la fréquence (filtre de Bessel) ; pour un gain supérieur à 1.586, on obtient des ondulations dans la bande médiane (caractéristique de réponse de Chebyshev).

À la fréquence de coupure, le gain total en tension a diminué de 3 dB. Au-dessus de la fréquence de coupure, le gain en tension diminue de 40 dB par décade (ce qui équivaut à –12 dB par octave).

Le terme – 40 dB / décade signifie que le gain en tension diminue de 100 fois sa valeur lorsque la fréquence augmente de 10 fois sa valeur.

20 log (VOUT/VIN) = -40 è log (VOUT/VIN) = -2 è (VOUT/VIN) = shift log (-2) = 0.01 ou VOUT = VIN / 100

Ceci équivaut à –12 dB par octave qui signifie que le gain en tension diminue de 4 fois lorsque la fréquence double sa valeur.

20 log (VOUT/VIN) = -12 è log (VOUT/VIN) = -0.6 è (VOUT/VIN) = shift log (-0.6) = 0.25 ou VOUT = VIN / 4

(d) Filtre passe haut actif à un pôle

La courbe de réponse de ce filtre est la suivante :

(e) Filtre passe haut actif à deux pôles

Ce filtre possède une atténuation de 40 dB par décade au-dessous de FC.

(f) Filtre passe-bande (combinaison d’un filtre passe-haut et d’un filtre passe-bas).

La courbe de réponse de ce filtre est la suivante :

Ce filtre possède une atténuation de 40 dB par décade au-dessous de FC1 et au-dessus de FC2.

(g) Avantage des filtres actifs :

  • Permettent des isolations beaucoup plus élevées grâce à leurs impédances d’entrée élevées.

  • Peuvent être réalisés sans bobine. Ceci diminue grandement le coût, le poids, la dimension, les effets inductifs (élimine la nécessité d’avoir des blindages magnétiques).

  • Permettent d’amplifier le signal en plus de le filtrer.

  • Peuvent avoir des fréquences centrales ajustables.

  • Leur réponse peut se rapprocher de la réponse idéale.

(h) inconvénients :

  • Nécessitent une alimentation.

  • Les amplitudes des signaux à filtrer sont limitées par la tension d’alimentation.

1.4. Les niveaux de référence

Le décibel n'est pas une valeur absolue ; c'est un moyen pour préciser le ratio d'un niveau par rapport à un certain niveau de référence. Habituellement quand le niveau de référence est donné, c'est sous cette forme : 775mV dans une impédance de 600 ohms par exemple. Cependant le niveau de référence n'est pas spécifié mais sous-entendu lorsque la valeur du niveau est exprimée en décibels.

Les niveaux de référence les plus utilisés sont les suivants :

dBj è Référence=1mV

dBmV è Référence=1mV

dBµV è Référence=1µV

dBk è Référence=1KW

dBm è Référence=1mW dans une impédance de 600W (775mV)

ou 1mW dans une impédance de 50W (224mV)

dBs è Référence=Désignation Japonaise pour le système dBm

dBu è Référence Européenne pour le système dBm

dBv è Référence=1V

dBw è Référence=1W

dBrap è Référence=10-16W (utilisée comme une référence acoustique)

dB è Référence=10-12W (acoustique)

2. Les oscillateurs

  • 1. Introduction
  • 2. Classification
  • 3. Relaxateur
  • 4. Oscillateur simple
  • 5. Oscillateur à réaction
  • 6. Oscillateur à déphasage
  • 7. Oscillateur à pont de Wien
  • 8. Oscillateur LC
  • 9. Oscillateur Colpitts
  • 10. Oscillateur Hartley
  • 11. Oscillateur à cristal
  • 12. PLL et synthétiseur de fréquence

2.1. Introduction

Partout où vous regarder dans le domaine de l'électronique, vous trouverez des oscillateurs. Il y en a dans votre montre, votre téléviseur, vos radios, votre voiture, votre ordinateur. Ils font tous appel au même principe et bien que conçus pour des applications très différentes, répondent aux mêmes critères.

À partir de seulement une alimentation DC à l’entrée du circuit, on obtient une onde alternative répétitive à la sortie. Un oscillateur est donc un circuit qui convertit l’énergie électrique DC en énergie électrique AC.

2.2. Classification

Il existe une grande variété d'oscillateurs comme le montre le tableau ci-dessous.

Sinusoïdaux ou harmoniques

Fixes : RC, LC et quartz

Variables : LC, VCO (diodes varicaps)

Non sinusoïdaux ou de relaxation

À relaxation : multivibrateurs trapézoïdaux, rampes, dents de scie

2.3. Oscillateur non sinusoïdal ou de relaxation

Un multivibrateur astable est une horloge qui rythme le fonctionnement des circuits numériques. Son principe est basé sur la charge et la décharge du condensateur C.

2.3.1 Multivibrateur astable à minuterie NE555

Le 555 est un circuit électronique miniaturisé qui est utilisé comme temporisateur. Il est basé sur la stabilité des circuits “RC” pour lesquels on peut prévoir le temps dont ils ont besoin pour atteindre une tension donnée. Les étapes qui suivent vont vous faire découvrir les fonctions des broches de ce circuit intégré très courant.

L'alimentation positive est assurée par la broche 8 ; la tension négative de la source doit être branchée à la broche 1. Les broches sont numérotées selon le schéma ci-dessous ; il y a au moins un marqueur dessiné sur le circuit intégré, soit un point creusé dans le plastique dans un coin du C.I., soit une encoche au centre du C.I. ; la broche 1 se trouve alors immédiatement à gauche de cette encoche ou de ce point selon le cas. Les autres broches sont numérotées dans le sens anti-horaire.

2.3.2. Schéma fonctionnel du 555

La figure ci-dessous représente un schéma fonctionnel d'une minuterie 555, une minuterie intégrée à 8 broches. Le comparateur du haut a une entrée de seuil (broche 6) et une entrée de commande (broche 5). Si l'entrée de commande n'est pas utilisée alors la tension de commande est égale à 2 x (VCC / 3) et lorsque la tension de seuil dépasse la tension de commande, la sortie du comparateur du haut met la bascule au niveau haut.

Le comparateur du bas a son entrée inverseuse, appelée entrée de basculement, reliée à la broche 2. L'entrée non inverseuse a une tension fixe de VCC / 3. Lorsque la tension d'entrée de basculement est légèrement inférieure à VCC / 3, la sortie de l'amplificateur opérationnel passe au niveau haut et remet la bascule au niveau bas.

Le collecteur du transistor à décharge est relié à la broche 7. Lorsque cette broche est raccordée à un condensateur externe de minutage, la sortie Q de niveau de la bascule sature le transistor et décharge le condensateur. Lorsque Q est au niveau bas, le transistor s'ouvre et le condensateur se charge. Le signal complémentaire de la bascule passe à la broche 3.

Et enfin si la sortie externe de remise à niveau bas (broche 4) est mise à la masse, le dispositif est inhibé (ne peut fonctionner).

2.3.3. Fonctionnement en Oscillateur

Comme le condensateur ne se charge ni ne se décharge complètement, la fréquence d'oscillation est d'environ F = 1 / 2.2 x R1 x C1

Dans le cas de ce montage C se charge à travers de deux résistances en série (20K) et se décharge à travers une résistance de 10K par l’intermédiaire du transistor interne du 555. Les temps hauts et les temps bas du signal sont dans un rapport de 2. La sortie est donc un signal rectangulaire et non carré comme dans le circuit précédent.

W = largeur de l’impulsion, D = coefficient d’utilisation ou Duty cycle

Rappel 1 : la charge d’un condensateur suit une loi exponentielle. La tension aux bornes d’un condensateur à un moment donné durant sa charge est donnée par la relation suivante :

E = (E final – E initial) (1 – e– W/RC)

Exemple: La tension d’alimentation est de 15 volts et on veut connaître la valeur de la tension après 1t et après 5t, le condensateur étant initialement déchargé

1t = RC è W = RC è W/RC = RC/RC = 1

donc E = (15 – 0) (1 – e-1) = 15 – 15 x e-1 = 15 – 15 x 0.3679 =15 – 5.52 = 9.48 volts soit en % : 9.48 x 100 /15 = 63.2 %

5t = 5RC è W = 5RC è W/RC = 5RC/RC = 5

donc E = (15 – 0) (1 – e-5) = 15 – 15 x e-5 = 15 – 15 x 0.0067 =15 – 0.1 = 14.9 volts soit en % : 14.9 x 100 /15 = 99.3 %

Rappel 2 : On charge un condensateur aux 2/3 de la valeur de la tension d’alimentation et on veut connaître le temps que durera cette charge soit W.

La relation précédente s’écrit :

(2/3) Vcc = Vcc (1 – e- W/RC) = Vcc – Vcc x e- W/RC è e- W/RC = 1/3

è W = -RC x ln (1/3) = -RC x (-1.1) = 1.1x RC

Si le coefficient d’utilisation est de 50 %, la fréquence est alors définie par la relation suivante:

Rappel 3 : Dans le cas de l’oscillateur à minuterie 555, la charge du condensateur commence à VCC / 3 et se termine à 2 x VCC / 3 avec une tension cible (tension d’alimentation) de Vcc.

2 x Vcc Vcc Vcc

-------- = -------- + ( Vcc - -------)(1 – e- W/RC)

3 3 3

Vcc 2 x Vcc 2 x Vcc

-------- = ( ---------) – ---------- e- W/RC)

3 3 3

Vcc 2 x Vcc

- -------- = – ---------- e- W/RC)

3 3

e- W/RC= 0.5 è W/RC = - ln 0.5 = 0.693

Temps de charge : W = 0.693 (R1 + R2) x C1

Temps de décharge T – W = 0.693 x R2

Période : T = 0.693 (R1 + R2) x C1 + 0.693 R2 x C1

2.3.4. Oscillateur à fréquence réglée par variation de tension

La figure ci-dessus représente un oscillateur à fréquence réglée par variation de tension, une application d’une minuterie 555. On appelle parfois ce dispositif un convertisseur tension-fréquence parce que la tension d’entrée fait varier la fréquence de sortie.

La broche 5 (commande) est raccordée à l’entrée inverseuse du comparateur du haut. Normalement la tension de commande est égale à 2Vcc/3 en raison du diviseur interne de tension. La tension provenant de l’extérieur (potentiomètre) a préséance sur la tension interne, autrement dit, on fait varier la tension de commande en ajustant le potentiomètre. Les temps de charge et de décharge varient en fonction de cette tension de commande et par conséquent la fréquence de sortie varie aussi.

Lorsque la tension de commande augmente, la fréquence diminue et vice versa.

2.4. Oscillateur simple

Un oscillateur est un montage capable d’engendrer des vibrations périodiques en fonction du temps. Un pendule, par exemple, est un oscillateur mécanique. Lorsqu’on le déplace de sa position d’équilibre, il décrit un mouvement, de va et vient, répété. Un pendule oscillant que l’on abandonne à lui-même effectue un certain nombre d’oscillations d’amplitude décroissante puis s’arrête. À ce moment, toute l’énergie mécanique de départ a été absorbée par les frottements.

Si l’on veut entretenir le mouvement à amplitude constante, il faut apporter à chaque cycle une quantité d’énergie juste égale à celle qui a été absorbée. C’est ce que l’on fait dans les horloges à balancier par l’intermédiaire d’un ressort tendu.

Une cloche, une corde de guitare ou de violon sont des oscillateurs mécaniques qui ont la propriété d’émettre des sons audibles à l’oreille humaine. L’atome lui-même constitue un oscillateur miniature dans lequel les électrons sont en "résonance" autour du noyau. Le LASER est tout simplement un oscillateur lumineux.

Le plus simple des oscillateurs électroniques est le circuit résonant pur formé d’une inductance pure et d’un condensateur pur (sans résistance). Lorsque la capacité initialement chargée est reliée à l’inductance, l’énergie électrique se met à osciller entre la self et la capacité avec une fréquence égale à :

Dans un circuit LC réel, nous retrouvons une situation semblable à celle du pendule. Les oscillations sont amorties, cette fois à cause de la résistance électrique du circuit. L’énergie électrique initialement emmagasinée dans le condensateur est dissipée cycle après cycle, sous forme de chaleur. Pour maintenir l’amplitude des oscillations constante, il faudrait communiquer au circuit LC des impulsions suffisamment énergiques pour compenser les pertes par effet Joule (chaleur).

La figure suivante donne un montage possible avec transistor. Les impulsions que reçoit la base sont amplifiées et transmises au circuit LC qui oscille au rythme des impulsions d’entrée.

Cette solution n’est pas satisfaisante puisque pour faire fonctionner un oscillateur, on a besoin d’un autre oscillateur.

2.5. Oscillateur à réaction

Au lieu de faire appel à un oscillateur auxiliaire, on prélève une fraction du signal amplifié et on le retourne dans le circuit d’entrée. Cette opération est appelée réaction positive ou rétroaction

Un oscillateur est composé d'un amplificateur duquel on prélève une partie du signal de sortie que l'on réinjecte vers l'entrée.

Nous avons déjà fait cela mais dans le but de stabiliser l'amplificateur, d'augmenter sa bande passante et surtout de ne pas le transformer en oscillateur.

Dans le cas de l’oscillateur, le signal prélevé de la sortie sera réinjecté en phase. C’est ce qu’on appelle la réaction positive.

La réaction positive consiste à prélever une fraction du signal amplifié et de la retourner dans le circuit d’entrée avec un déphasage de 0 degré.

Le report d’énergie est effectué par un circuit RC, LC ou un cristal (quartz). Si le sens des connexions est convenable, le courant de base tend à renforcer le courant de collecteur qui lui a donné naissance et le système tombe en régime d’auto entretien. Ce phénomène est appelé oscillation.

Si nous appelons A le gain et l'amplificateur et b le gain du système de réaction, le critère de BARKHAUSEN définit la condition pour que le système entre en oscillation.

Considérons séparément chacun des deux éléments constitutifs d’un oscillateur

Nous supposerons que l’amplificateur fonctionne en régime linéaire : à tout signal sinusoïdal appliqué à son entrée, correspond un autre signal, lui aussi sinusoïdal, recueilli sur sa sortie. Si V1 et V2 sont les amplitudes respectives de ces tensions, on appelle gain de l’amplificateur, le rapport :

V2

A = -------

V1

Généralement, l’amplificateur introduit non seulement un gain, mais aussi un déphasage entre les deux sinusoïdes, que nous noterons f1.

Ces mêmes notions s’appliquent au réseau de rétroaction, bien que ce réseau soit passif. Quelle soit la structure de ce réseau, on peut définir son gain, rapport des amplitudes V4 et V3.

V4

b = ----------

V3

Généralement, le réseau de rétroaction atténue le signal qu’on lui applique, de sorte que b est inférieur à l’unité. Pour sa part, ce réseau introduit un déphasage que nous noterons f2.

Relions maintenant les deux éléments en série (voir figure ci-dessus). La sortie de l’amplificateur attaquant l’entrée du réseau passif, nous aurons à la fois

V4 = A x b x V1

f = f1 + f2

(A x b) est appelé gain en boucle ouverte

f est le déphasage total

Si V4 est supérieur à V1 et que le déphasage total est soit nul soit égal à un multiple de 360o, on obtient l’auto entretien des oscillations en refermons le montage sur lui-même.

A x b ≥ 1

f1 + f2 = 0o ± 360o x K

En boucle fermée, le produit b x VOUT s’additionne à VIN, de sorte que :

VOUT = A VIN + A b VOUT è VOUT – A b VOUT = A VIN è VOUT (1 – A b) = A x VIN

D’où :

VOUT A

------ = -----------

VIN 1 – A b

Pour différentier ce gain du gain en boucle ouverte, on le notera ACL (CL est mis pour close loop).

VOUT A

ACL = ------ = ------------

VIN 1 – A b

Une fois amorcée, l'oscillation se maintient pour A x b = 1

Si A x b < 1 l'oscillation cesse.

Si A x b > 1, l’amplitude des oscillations augmente jusqu’à la saturation de l’amplificateur. Le signal de sortie ressemblera plus à un signal carré qu’à une sinusoïde.

Dans le cas d’un amplificateur émetteur commun, c’est la contre réaction introduite par la résistance d’émetteur RE qui joue le rôle de limiteur de sorte que l’amplificateur ne sature jamais.

Le réseau de rétroaction ou de réaction positive devra prendre en compte le montage utilisé, déphaser ou pas le signal et appliquer le taux qui convient à l'entrée.

Comment réinjecter la sortie vers l'entrée ?

Il existe plusieurs méthodes, celles-ci sont d'ailleurs constitutives et descriptives du montage. Tel que les classiques : Colpitts, Pierce, Hartley (du nom des inventeurs), voyons quels sont les procédés de couplages les plus fréquemment utilisés.

En fonction du type de montage utilisé, (souvenez-vous, il y a trois montages fondamentaux pour le transistor) nous appliquerons ou pas un déphasage au signal prélevé.

Émetteur commun : déphase de 180°

Collecteur commun : ne déphasage pas

Base commune : ne déphasage pas

Un dernier point à vérifier : l’oscillateur démarre-t-il tout seul dès la mise sous tension ? Oui. En effet, pour que les oscillations prennent naissance dans un circuit LC, il faut que son état de repos soit perturbé. Or, le simple fait de fermer l’interrupteur qui alimente l’oscillateur provoque une “secousse” électrique capable de déclencher l’état oscillatoire. Il y a aussi les dérives thermiques, les tensions de bruit, qui pourraient jouer le même rôle.

2.6. Le réseau RC ou oscillateur à déphasage :

l'amplificateur est un amplificateur émetteur commun, c-à-d que le signal de sortie est déphasé de 180° par rapport à l'entrée.

Cet amplificateur est polarisé en classe A de manière à offrir un signal le plus pur possible. Nous verrons dans cette section que ce n'est pas une exigence systématique.

Le réseau de déphasage et d'injection comporte 3 cellules RC identiques, d'une part pour déphaser le signal de 180° (60° par cellule) et d'autre part pour atténuer le signal à injecter vers l'entrée car nous n'avons pas besoin d'injecter un signal énorme si nous tenons à conserver en sortie un signal sans distorsion.

Ce type d'oscillateur est sélectif, la fréquence d'oscillation est dictée par les valeurs du réseau RC.

Remarque : certaines alimentations nécessitent un condensateur de découplage C5. Ce condensateur met la borne supérieure de la source d’alimentation à la masse en alternatif pour empêcher son impédance de modifier la fréquence d’oscillation et l’amplitude du signal généré.

2.7. Oscillateur à pont de Wien

L’oscillateur à pont de Wien est très couramment utilisé pour réaliser des oscillateurs dont la fréquence peut varier de 1 Hz à 1 Mhz. Les raisons de ce succès sont les suivantes :

a) La valeur de la fréquence dépend d’une résistance et d’une capacité, composants qu’il est plus facile d’obtenir que les bobines avec un haut degré de qualité;

b) Le circuit est très stable et le signal très peu distordu;

c) La fréquence peut être réglée de façon continue.

La partie fondamentale d’un oscillateur à pont de Wien est un réseau, passe-bas passe-haut, tel que celui de la figure suivante :

R1 et C1 forment la portion “passe-bas” du circuit, tandis que R2 et C2 forment la portion “passe-haut”.

Le principe de fonctionnement est simple : à des fréquences basses, le circuit “passe-haut” est dominant dû à la réactance élevée de C2. Au fur et à mesure que la fréquence augmente, XC2 diminue permettant à la tension de sortie d’augmenter. À une certaine fréquence spécifiée, le circuit “passe-bas” prend la relève et Xc1 diminue.

XC1 diminuant avec l’augmentation de la fréquence, la tension de sortie est alors décroissante comme le montre la courbe de réponse suivante :

Cas particulier R1 =R2 et C1 = C2 et sachant qu’à la résonance R = XC, alors VOUT = VIN / 3

Vin = (Z1 + Z2 ) x I; Vout = Z2 x I

Le gain A = Vout / Vin = Z2 x I / [(Z1 + Z2) x I] = Z2/(Z1+Z2)

La fréquence de résonance quant à elle est Fr = 1 / 2pRC

Le circuit, passe-haut passe-bas, est utilisé dans la boucle de rétroaction positive de l’amplificateur opérationnel et un diviseur de tension est utilisé dans la boucle de rétroaction négative.

La condition de déphasage de 0 degré est établie lorsque la fréquence est égale à Fr puisque le déphasage autour du circuit réseau RC est 0 degré et que l’amplificateur est non-inverseur.

La condition de gain égal à 1 est établie lorsque le gain en boucle fermée de l’AOP est égal à 3 ce qui annule l’atténuation de 1/3 du réseau RC.

Au départ, le gain en boucle fermée de l’AOP doit être supérieur à 3 jusqu’à ce que le signal de sortie se développe jusqu’à un niveau désiré. Le gain doit ensuite diminuer à 3 pour que le signal de sortie reste à ce niveau.

Le circuit de la figure suivante illustre une méthode de base pour obtenir la condition d’oscillation décrite.

R3 sert à ajuster l’amplitude du signal de sortie. Les diodes 1N4148 vont limiter le gain en boucle fermée de l’AOP à 3. Lorsque le signal est assez fort, les diodes conduisent alternativement et mettent R3 en parallèle avec R1, ce qui diminue le gain en boucle fermée de l’AOP.

La diode Led permet de signaler le fonctionnement de l’oscillateur. Et la diode 1N4148 à ses bornes permet de la protéger lors de sa polarisation inverse pour ne pas la détruire (se rappeler que sa tension maximale en inverse est de 3 volts).

2.8. Oscillateur LC : le schéma fondamental est le suivant :

Le principe est la rétroaction du signal de sortie vers l'entrée. Il est composé d'une self et d'un condensateur. L'un ou les deux éléments peuvent être variables pour faire varier la fréquence d'oscillation.

La fréquence d'oscillation sera déterminée majoritairement par la valeur de L et de C et accessoirement par les capacités parasites du montage (elles existent toujours).

On évaluera approximativement la fréquence d'oscillation par la classique formule de Thomson tirée du non moins célèbre :

LCw2 = 1 (XL = XC)

Le report d’énergie est effectué par couplage électromagnétique entre la bobine L associée au condensateur C et la bobine L2 de réaction. Si le sens des connexions est convenable, le courant de base tend à renforcer le courant de collecteur qui lui a donné naissance et le système tombe en régime d’auto entretien.

Un dernier point à vérifier : l’oscillateur démarre-t-il tout seul dès la mise sous tension ? Oui. En effet, pour que les oscillations prennent naissance dans un circuit LC, il faut que son état de repos soit perturbé. Or, le simple fait de fermer l’interrupteur qui alimente l’oscillateur provoque une "secousse" électrique capable de déclencher l’état oscillatoire. Il y a aussi les dérives thermiques, les tensions de bruit, qui pourraient jouer le même rôle.

2.9. Oscillateur Colpitts

Un type d’oscillateur à résonance est le Colpitts, appelé ainsi en l’honneur de son inventeur.

Cet oscillateur utilise un circuit LC dans la boucle de rétroaction pour fournir le déphasage nécessaire et agir comme un filtre pour ne laisser passer que la fréquence spécifiée d’oscillation. La fréquence approximative d’oscillation est établie par les valeurs de C1, C2 et L selon la formule :

CT étant la capacité équivalente de C1 et C2 en série car les deux condensateurs apparaissent en série dans le circuit résonant.

CT = C1 x C2 / (C1 +C2)

2.10. Oscillateur Hartley

Un autre type d’oscillateur à résonance est le Hartley, qui est semblable à l’oscillateur Colpitts à l’exception que le circuit de rétroaction est constitué de deux bobines et d’un condensateur.

Sa fréquence d’oscillation est donnée par :

LT est la combinaison série de L1 et L2

2.11. Oscillateur à cristal

Un oscillateur à cristal est essentiellement un oscillateur à circuit accordé qui utilise un quartz comme circuit résonant. D’autres types de cristaux peuvent être utilisés mais le quartz est le plus couramment utilisé. Il offre une plus grande stabilité de la fréquence.

Le quartz est composé de silice SiO2, qui est une matière minérale extrêmement répandue dans la nature.

Il se présente soit sous la forme de grands cristaux incolores, colorés ou fumés, soit sous la forme de cristaux microscopiques d'aspect translucide.

Le quartz présente la particularité d'être piézo-électrique, en d'autres termes cela signifie que si nous lui appliquons une force de compression sur ses faces, nous constatons l'apparition de charges électriques.

Si maintenant nous inversons l'effort que nous appliquons sur la lamelle de quartz et qu'au lieu de compresser celui-ci nous exercions une traction, nous constatons que le signe des charges s'inverse. Plus l'effort mécanique est important, plus il y a de charges qui apparaissent.

Mais l'effet piézo-électrique ne s'arrête pas là, il est réversible, càd qu'en appliquant une tension électrique sur la lamelle de quartz, on observe une déformation mécanique. Le quartz est un matériau élastique (toutes choses égales par ailleurs) et il retrouve sa forme originelle dès que cesse la tension.

Ceci est important puisque cela dicte la fréquence propre de résonance qui est liée, entres autres, aux dimensions physiques de la lamelle de quartz.

Sur le plan électrique :

Voici le symbole du quartz :

La lamelle de quartz est reliée grâce à deux électrodes de connexion. Observez le dessin, on devine facilement que les connexions notées A et B vont constituer une magnifique capacité et cette capacité sera la capacité de connexion.

Schéma électrique équivalent d'un quartz :

On remarque immédiatement qu'il s'agit d'un circuit série shunté par une capacité, cette capacité est la capacité due aux connexions. Les valeurs de L, R et C1 sont dictées par la nature et les caractéristiques du quartz.

Comportement électrique du quartz :

Appliquons à un quartz une tension alternative sinusoïdale, faisons la varier et mesurons l'impédance du quartz pour chaque fréquence. Nous obtenons ceci :

Attention, la courbe est beaucoup plus arrondie que cela, seule l'allure générale est restituée par ce dessin. Hormis ceci, il n'y a pas de réelle surprise pour nous, nous reconnaissons typiquement la réaction d'un circuit série. Quand on approche de la résonance, notée Fs, l'impédance passe par un minimum équivalant sensiblement à R, puis remonte rapidement vers un maximum à la fréquence notée Fp simulant ainsi un circuit parallèle.

Donc tout se passe comme si nous étions en présence d'un circuit série pour une fréquence donnée et d'un circuit parallèle pour une fréquence légèrement supérieure. Ces deux fréquences Fs et Fp sont les fréquences de résonance du quartz.

Comme tout circuit, le quartz a un coefficient de qualité, noté "Q" mais son "Q" est très élevé. On se souvient qu'un Q élevé est gage d'une grande sélectivité et de forts coefficients de surtension, on le calcule par Lw/R. L'ordre de grandeur est compris entre 104 et 106.

La taille mécanique du quartz influe fortement sur ses caractéristiques électriques.

Un quartz dissipe de la puissance, et il convient de ne pas dépasser le maximum tolérable dans un montage oscillateur sous peine de dommages irréversibles.

Son utilité dans les oscillateurs :

Du fait de son Q très élevé et de sa stabilité, le quartz va permettre de contrôler très précisément la fréquence d'oscillation. Dès que l'on aura besoin d'une fréquence stable, on aura recours au quartz.

Exemples d’oscillateurs à cristal :

La figure suivante montre un oscillateur Colpitts modifié qui utilise un cristal en mode de résonance parallèle.

La figure ci-dessous montre quant à elle un oscillateur utilisant un cristal comme un circuit résonant série. L’impédance du cristal est minimale lors de la résonance série, ce qui fournit une rétroaction maximale.

Le condensateur CC sert d’accord pour le cristal afin d’ajuster la fréquence avec précision.

2.12. PLL et synthétiseur de fréquence

Le circuit "PLL" (Phase-Locked Loop) ou boucle à verrouillage de phase en Français est très employé en électronique. On le retrouve dans beaucoup d’applications :

  • télévision,
  • radio,
  • instruments de mesure,
  • générateurs etc.

On peut utiliser une boucle à verrouillage de phase pour ses qualités de sélectivité et de filtrage obtenues sans utilisations de bobines ou de selfs.

a) Schéma bloc

La figure suivante représente le schéma fonctionnel d’une boucle à verrouillage de phase dans sa forme la plus simple.

Le fonctionnement et le principe peuvent être brièvement résumés de la manière suivante : sans signal d’entrée, le système délivre une tension d’erreur nulle, le VCO oscille à une fréquence donnée Fo qui est appelée fréquence centrale ou fréquence libre. Si, à l’entrée du système on applique un signal, le comparateur phase/fréquence compare la phase et la fréquence du signal d’entrée et du signal de sortie du VCO et génère une tension d’erreur qui est fonction de la différence de phase ou de fréquence entre les deux signaux. Cette tension d’erreur est alors filtrée et appliquée à l’entrée de commande du VCO. Si la fréquence d’entrée du VCO est suffisamment proche de Fo, la contre réaction de la boucle force le VCO à se synchroniser sur la fréquence d’entrée ; on dit alors que le système est verrouillé. Deux des paramètres d’une boucle sont : la plage de capture et la plage de verrouillage.

Plage de verrouillage :

Elle définit l’étendue de la fréquence au voisinage de Fo dans laquelle le PLL peut maintenir le verrouillage avec le signal d’entrée. Cette plage est aussi appelée plage de maintien et elle augmente en même temps que le gain de boucle.

Gamme de capture :

Cette gamme définit l’étendue de fréquences au voisinage de Fo pour lesquelles le système peut établir ou acquérir le verrouillage avec le signal d’entrée. Elle est aussi appelée plage d’acquisition, elle est toujours plus petite que la gamme de verrouillage et est en étroite relation avec la bande passante du filtre de boucle. Elle décroît en même temps que la bande passante du filtre diminue.

La plage de verrouillage et de capture peut être illustrée par les courbes de la figure ci-après :

Pour la courbe "aller" la fréquence augmente progressivement, la courbe ne répond au signal d’entrée que lorsque la fréquence est supérieure à la limite inférieure F1 correspondant à la limite inférieure de la plage de capture. La boucle se verrouille alors sur le signal d’entrée en créant une tension d’erreur négative. Puis la tension d’erreur varie avec la fréquence qui passe par Fo. La poursuite fonctionne jusqu’à ce que la fréquence atteigne F2 correspondant à la limite maximale de la plage de verrouillage. Le PLL est hors verrouillage et la tension d’erreur s’annule.

Pour la courbe "retour" la fréquence d’entrée diminue au même rythme que précédemment, le cycle est modifié et devient le suivant : la boucle est asservie à partir de F3 et la poursuite fonctionne jusqu’à F4.

Les bandes délimitées par F1 et F3 et F2 et F4 correspondent aux plages de capture et de verrouillage du système.

Le PLL est donc composé d’un comparateur de phase, d’un filtre passe bas (LPF) et d’un oscillateur dont la fréquence est commandée ou asservie par une tension DC (VCO = Voltage Controlled Oscillator). On dit aussi que c’est un convertisseur tension-fréquence.

En radio et en télévision, la sortie verrouillée est appliquée au mélangeur (Mix) pour utilisation (production de la fréquence intermédiaire).

IF = Fo - Fc (Fo = fréquence de l’oscillateur local, Fc = fréquence de la station syntonisée).

IF1 = 10.7 Mhz, IF2 = 455 Khz en radio AM et 10.7 Mhz en radio FM, 41.25 Mhz pour le son en télévision, 45.75 Mhz pour l’image en télévision.

b) La commande par synthèse de fréquence et microprocesseur

Lorsque le système PLL est programmable c’est à dire que sa fréquence de sortie est variable en fonction de la demande, on l’appellera "synthétiseur de fréquence".

Principe de la synthèse de fréquence

Le principe consiste à contrôler la fréquence de l'oscillateur local des sélecteurs de syntonisation. Afin d'obtenir une grande stabilité de l'oscillateur local, on le compare à un oscillateur à quartz par l'intermédiaire d'un diviseur programmable.

En changeant le rapport diviseur, on modifie la fréquence de l'oscillateur donc la fréquence de l'accord RF du récepteur.

Le taux de division correspondant à chaque canal est contenu dans une mémoire morte R.O.M. du microprocesseur. Le transfert d'un taux de division appelé par l'utilisateur vers le diviseur programmable permet le réglage de l'appareil sur la station désirée.

Pour opérer la sélection des canaux, il suffit donc de modifier le rapport de division N conformément au canal désiré.

Exemple de la synthèse de fréquence en radio mobile CNR-136 (40 canaux)

26.965 Mhz à 27.405 Mhz, IF1 = 10.7 Mhz

Fréquence de l'oscillateur local = Fréquence reçue - I F = 16.27 Mhz Mhz à 16.71 Mhz

Les nombres N = 1627 à 1671 correspondent aux 40 canaux autorisés. 1627 correspond au canal 1, 1671 au canal 40, 1628 au canal 2 etc. (voir tableau correspondant ci-dessous).

1e canal: 16.27 Mhz / 1627 = 10000 Hz

2e canal: (16.27 Mhz + 10 Khz) / 1628 = 10000 Hz

3e canal: (16.27 Mhz + 10 Khz + 10 Khz) / 1629 = 10000 Hz

etc.

Exemple de comparateur de phase : Le OU exclusif

Le signal alternatif de sortie est converti en une tension continue, par un filtre actif passe-bas, qui sera appliquée au VCO.

Le VCO (Voltage Controlled Oscillator) contrôle les variations de cette tension en provenance du filtre et les convertit en variation de fréquence.

c) Caractéristiques du tuner à PLL

  • Très haute précision de la fréquence d'accord ;

  • Grande stabilité de fonctionnement aux conditions de température et d'humidité. Pas de contact mécanique ;

  • Opération très rapide ;

  • Aucun préréglage du canal reçu ;

  • Accord direct avec 10 touches de 0 à 9 ;

  • Affichage du canal indiqué soit à l'écran soit sur LEDS ;

  • Exploration des canaux disponibles (auto programmation).

    •
  • Retour au début
  • Sommaire
  • Accueil


[DIY] Oscillateur à NPN

Vu dans ... https://www.firediy.fr/article/oscillateur-a-npn

Introduction

Tout d'abord, un petit mot sur cet oscillateur : il s'agit d'un montage simple mais peu précis, mais de large bande passante (Hz→MHz), mais qui décroît avec la simplicité des composants ^^
Cet oscillateur délivre un signal carré. On peu récupérer sur le circuit deux courbes complémentaires et déphasées.
Voici donc le schéma général du circuit avec la formule de la fréquence de l'ensemble :

F=1R3×C2×ln(2)+R2×C1×ln(2)F=1 R 3×C 2×ln(2)+R 2×C 1×ln(2)

Ici on calculera donc la fréquence : F=1220000×4.7×10−6×2ln(2)=0.69HzF=1 220000×4.7×10−6×2 ln(2)=0.69 Hz soit une période d'environ 1.44 sec (1 impulsion toute les 1.44 sec).

On peu donc avoir des fréquences basses en augmentant C1, C2, R2 et R3 : facile me direz-vous ? Eh bien oui et non. Nous sommes limités par R2 et R3 qui ne peuvent pas trop monter dans des supers valeurs (étant nécessaire pour la base du transistor opposé). Il faut donc utiliser de grosses capacités chimiques(de l'ordre du µF).

Liste du matériel

Voici ce que nous utiliseront dans ce petit chapitre. Il va sans dire que je donne les valeurs des composants que j'utilise, mais ça reste TRES libre...
-2x Transistors NPN : 2N2222
-2x Résistances R1, R4 : ¼W, utilisez la formule pour vos valeurs
-2x Résistances R2, R3 : ¼W, idem
-2x Condensateurs C1, C2 : chimique, LCC, céramique, tout est bon !
-1x BreadBoard : vraiment utile
-Du fil à strap

Théorie

Voilà la théorie, à ce que j'ai compris. J'essaye d'être clair autant que je peux ! Si je me plante, veuillez me le signaler ;)
Nous commencerons par décrire le "régime de croisière". Nous partons donc d'un des états et expliquerons le phénomène d'oscillation.

Dans l'état A : C1 = 0, C2 = Vcc
-C1 se charge par le biais de R1 et de la base de T2, celui-ci étant saturé par la résistance R2. C1 se charge plus vite que ne ce décharge car R1 << R2 : la fuite est donc inférieur à la charge.
-C2 est à Vcc et ne se charge plus du fait que T2 est ouvert. Il applique donc sur T1 -Vcc ce qui le bloque. C2 se décharge lentement par R3.
=> Dans ces conditions, nous avons un courant principal Vcc→R4→T2→GRN et un courant de base Vcc→R1→C1→T2→GRN

-C2 se déchargeant il finira par arriver au seuil de 0V et n'appliquera plus de valeur négative sur T1 qui saturera.

Dans l'état B :

-T1 sature et donc l'effet inverse se produit ! Ouvert, T1 permet à C1 d'appliquer -Vcc sur T2 qui se bloque et C2 se charge par R4.

-Le cycle étant inversé, C1 se décharge à son tour jusqu'à ce que le phénomène bascule encore une fois.

Bon, après, en expérimental tout est différents ! La décharge opère en partie comme citée, en partie du collecteur vers la base, en partie par l'alimentation : ainsi quand dans le doute j'ai voulu éliminer les voies de retour je me suis retrouvé avec de nombreuses fréquences adjacentes en fonction de la où je posais des diodes, pour finir à 2 LEDs statiques lorsque toutes les voies étaient bloquées. Bref, je pense que je me plante un peu, mais dans mon explication ça semble plausible et on dira que la théorie reste de la théorie.

Pour ceux qui, comme moi se pose la question du comment ça démarre, je dirais qu'il doit y avoir une asymétrie (aléatoire ou faute aux composants) qui provoque le blocage d'un des transistors des le début.

Application

Vous pouvez d'ores et déjà ajouter une LED entre R1 et T1 et entre R4 et T2 : vous pourrez voir clignotez les LEDs de manière alternée. Mais le principe étant un oscillateur, nous pouvons aussi récupérer un signal !

Voici les deux sources de signal : A et B. Et tout comme les LEDs ils sont antagonistes : quand A = 1, B = 0.

Nous récupérerons le signal de cette manière :

Nous noterons qu'il s'agit d'un PNP! Le PNP, à la différence du NPN, utilise un courant du collecteur vers la base plutôt que de la base vers l'émetteur, le signal en A et B est en faite un -1 et 0. On a donc un signal 1 et 0 sur le collecteur et l'émetteur du PNP : branchez donc une LED (protégée comme il faut) ou bien un Haut Parleur : vous obtiendrez un signal correspondant à votre fréquence (attention, signal carré = bruit particulier)

T1 et T2 peuvent et doivent être de petits NPNs, cependant, le PNP T3 DOIT être adapté à la charge qu'il subit ! Pensez à prévoir des TO220s si vous voulez 10W.


Clignotant (multivibrateur à transistor)

Vu dans ... http://jurastick.chez.com/tip/clignotant/

CLIGNOTANT

PRESENTATION

C’est un multivibrateur astable dans lequel deux transistors sont couplés par l’intermédiaire de deux condensateurs, chacun étant branché entre la base d’un transistor et le collecteur de l’autre.

Ce montage pourra être utilisé dans de nombreuses applications, par exemple comme sonnerie de porte, indicateur de remplissage ou comme feu clignotant pour train miniature.

PRINCIPE DE FONCTIONNEMENT

A la mise sous tension, une légère dissymétrie entre les deux transistors fait que l’un des deux commence à conduire le premier, par exemple T1. La faible tension à laquelle se trouve alors le collecteur de T1 est transférée, par l’intermédiaire de C1, à la base de T2 qui est donc bloqué. Dans cette situation, la lampe est allumée et C1 se charge à travers R2. Lorsque cette tension devient insuffisante, T2 se débloque, provoquant une chute de tension au niveau de son collecteur. Par l’intermédiaire de C2, une tension négative est alors appliquée sur la base de T1 qui cesse de conduire. La lampe s’éteint, et cette situation dure jusqu’à ce que C2 se soit suffisamment chargé , à travers R1, pour rétablir la tension nécessaire au déblocage de T1.

Le temps nécessaire à la charge des condensateurs détermine la fréquence du clignotement. Celui-ci peut être rendu plus rapide en diminuant la capacité de C1 et C2, ou en diminuant la valeur des résistances R1 et R2.

LISTE DES COMPOSANTS

R1, R2: 2,2 kW ¼ W
R3: 220W ¼ W

C1, C2: 220µF à 470µF

T1, T2: Transistors NPN
ex: BC547, 2n2222, 2n1711

Lampe: Lampe 3,5V 0,2A

Le circuit conçu pour une tension d’alimentation de 9 Volts pourra être utilisé sous 4,5 Volts en diminuant la valeur des résistances de moitié. et en utilisant des transistors TUN présentant une amplification en courant du groupe B (comme le BC547B par exemple).

En changeant la valeur des deux condensateurs on pourra influer sur la fréquence de clignotement. Le circuit consomme environ 20mA et pourra être alimenté sans problèmes par une pile.

CLIGNOTANT A LAMPE CLIGNOTANT A L.E.D

Clignotant à LED

Clignotant à LAMPE

L’oeil averti auras sans doute reconnu dès le premier coup d’oeil qu’il s’agit encore d’un simple multivibrateur. les deux TUN conduisent tour à tour, ce qui fait que les diodes s’allumeront alternativement.

Le circuit conçu pour une tension d’alimentation de 9 Volts pourra être utilisé sous 4,5 Volts en diminuant la valeur des résistances de moitié. et en utilisant des transistors TUN présentant une amplification en courant du groupe B (comme le BC547B par exemple).

En changeant la valeur des deux condensateurs on pourra influer sur la fréquence de clignotement. Le circuit consomme environ 20mA et pourra être alimenté sans problèmes par une pile.


Electronique-Pratique Octobre-1980


Radio-Pratique n°1332 1971


Electronique-Pratique Avril 1980


Générateur de Son amortie

1
2
3
4

-----------

CYMBAL 1

CYMBAL 2

CYMBAL 3

ELEX mensuel electronique


Orgue numérique — Wikipédia

Un article de Wikipédia, l'encyclopédie libre.

L’orgue numérique est un instrument de musique offrant à l'instrumentiste la même disposition que celle d’un orgue classique à tuyaux : claviers, pédalier et registres de jeux. La différence essentielle est qu’au lieu de produire le son par des tuyaux, l’orgue numérique emploie des générateurs électroacoustiques dont le signal est envoyé vers des haut-parleurs via des amplificateurs.

Un des points communs avec l'orgue à tuyaux qui justifient le nom d’« orgue », est la capacité à prolonger les sons de manière indéfinie, contrairement à d'autres instruments à clavier tels le clavecin ou le piano.

Disques optiques générateurs de signal sonore

Sommaire

  • 1 Brève histoire de l’orgue électronique
  • 2 Orgue électrostatique
  • 3 L’épisode synthétiseur
  • 4 La naissance du son numérique
  • 5 Fréquence et résolution
  • 6 Qu’est-ce qu’un orgue numérique ?
    • 6.1 Techniques mises en œuvre dans l'orgue numérique
      • 6.1.1 Les échantillons courts…
      • 6.1.2 Les échantillons longs…
      • 6.1.3 Dispersion des échantillons (nombre d'échantillons pour un jeu)
  • 7 Les convertisseurs
  • 8 Les haut-parleurs
  • 9 Conclusion
  • 10 Principaux fabricants d'orgues numériques
  • 11 La technologie de l’orgue numérique comparée à celle du simulateur d'orgues à tuyaux (orgue virtuel)
  • 12 La technologie de l’orgue numérique comparée à celle du synthétiseur
  • 13 Schéma de fonctionnement d'un orgue numérique
  • 14 Articles connexes

Brève histoire de l’orgue électronique

Dès que la technologie a permis de créer des sons à partir de générateurs électroniques, l’idée de construire des instruments de musique utilisant cette possibilité est née. L’orgue électronique est le premier instrument qui ait été conçu pour pouvoir produite des sons uniquement à partir de l’électricité. Il ne faut pas le confondre avec l’orgue électrique, qui n’était en fait qu’un harmonium équipé d’une petite soufflerie électrique, ni avec l'orgue à traction électrique, orgue à tuyaux où l'électricité ne sert qu'à transmettre les commandes de la console vers les sommiers, pour l'action des soupapes et des registres. Plusieurs technologies furent mises au point pour produire des sons : le trigger de Schmitt, l’oscillateur sur couple condensateur-bobine à induction, l’oscillateur à lampe, l’oscillateur à transistor avec transfo-diviseurs et les générateurs à plateaux rotatifs (disques optiques, disques électrostatiques et disques magnétiques).

Dans les années 1930 naissait le fameux orgue Hammond mettant en œuvre une technique originale : des oscillateurs à lampes produisant un signal sinusoïdal pur et des tirettes ajustables correspondant à différents harmoniques. À partir de 1955 Hammond adoptait le générateur électromagnétique avec plateaux rotatifs. Certaines combinaisons arrivaient à se rapprocher du ripieno italien, mais on était loin de l’orgue à tuyau. En général les harmoniques étaient peu nombreux : 16, 8, 5 1/3, 4, 2 2/3, 2, 1 3/5, 1 1/3 et 1. C’était une approche grossière de la synthèse de Fourier, mais le son « Hammond » est cependant devenu un son à part entière qui a été adopté par le jazz et le gospel et qui est encore apprécié de nos jours, largement utilisé en particulier dans les églises aux États-Unis d'Amérique. C'est en 1938 que la manufacture Allen Organ (son fondateur Monsieur Jerome Markowitz) déposa le premier brevet (US Patent) de l'oscillateur stable et devient de ce fait le pionnier des orgues analogiques avancés des années 1930.

Les signaux élémentaires.

Le trigger de Schmitt a ensuite été le générateur le plus répandu car il était extrêmement aisé à mettre en œuvre. C’était sans doute un avantage pour le constructeur, mais le son obtenu était d’une extrême pauvreté, puisqu’il s’agissait d’un signal rectangulaire n’ayant aucun équivalent dans la nature. La décomposition de Fourrier montre qu’il n’est constitué que d’harmoniques impairs. C’est un son creux et agaçant. Dans les années 1965-1970, la plupart des orgues électroniques dits « liturgiques » étaient équipés de ce type de générateurs. Quels que fussent les noms sérigraphiés sur les dominos d'appel de jeux, le son était toujours pareil, grossier et pâteux. C’était l’époque des Vox Continental, Gibson G-101, Farfisa, Viscount, Gem, Bontempi et autres.

Dr Böhm est le premier à avoir essayé de sortir l’orgue électronique du ghetto en mettant au point un oscillateur générant des signaux en dents de scie, très riches en harmoniques, réalisé à base de transistors et diviseurs par transformateur. À la fin des années 1960, il mettait sur le marché des instruments étonnants qui offraient des sons très proches de ceux de l’orgue classique. Évidemment, ces instruments avaient tous les défauts de l’époque : si chaque jeu était intéressant par lui-même, les mélanges ne donnaient qu’un vague yaourt sonore. En effet, la même onde passant à travers plusieurs filtres passifs ne pouvait guère donner autre chose qu’elle-même, et ajouter des jeux les uns aux autres ne donnait absolument pas cet effet d’ampleur et d’augmentation propre à l’orgue acoustique. Paradoxalement, l’orgue Dr Böhm donnait de meilleurs résultats dans des registrations de détail (très belle Trumpet, très beau Horn Chalmey) plutôt que dans des combinaisons comme ripieno, grand jeu, plein jeu, tutti, au contraire des orgues concurrents de l’époque, Farfisa, Viscount, où les jeux individuels étaient moins réussis.

Complément sur la synthèse analogique : On a comme pour les couleurs envisagé une synthèse additive ou soustractive. La majorité des orgues électroniques ont utilisé la synthèse soustractive qui consiste à filtrer surtout en sortie (la pauvreté harmonique des ondes rectangulaires ayant été compensée parfois par l'utilisation d'ondes triangulaires). De rares fabricants ont utilisé la synthèse additive en ne prenant sur les barres de bus que les fréquences nécessaires le filtrage en sortie étant plus simple et plus efficace (par ex. orgues Amel). Le problème de l'attaque était un peu résolu par le décalage obligatoire des contacts multiples de chaque touche (pour les orgues haut de gamme). Sur les premiers orgues numériques l'attaque était d'une pauvreté très gênante. On a heureusement développé depuis des courbes d'enveloppe modulables.

Un problème majeur de la synthèse électronique reste l'addition de tensions avec risques de saturation au niveau de l'amplification et des haut-parleurs, un vrai orgue réalisant une addition purement acoustique. On a un peu contourné et l'on contourne toujours en partie le problème en multipliant les sources, les amplificateurs et les enceintes. En électronique analogique on a ainsi réalisé des orgues très haut de gamme très complexes presque copie des orgues acoustiques et l'on a repris les mêmes principes en numérique, parfois avec des réalisations impressionnantes (par ex. Orgues Allen ou orgues Rodgers)

Formes d'ondes gravées sur un plateau (technologie optique)

La technologie la plus étonnante fut celle du générateur électrostatique à plateaux rotatifs (différent du système Hammond). Le principe était audacieux : la forme d’onde d’un vrai tuyau d’orgue d’église était gravée sur un disque sous forme d’une couche métallique (qui dessinait une sorte de montagnes russes, voir illustration ci-contre). Il y avait autant de plateaux que de notes (douze) et chaque plateau portait la gravure en anneaux concentriques des différents jeux. Chaque disque, en tournant, agissait comme un condensateur variable et ces variations étaient amplifiées, générant ainsi le son voulu. Une méthode similaire utilisait des disques de verre, les ondes étant matérialisées par une couche d'argenture. L'onde sonore était générée par le passage du disque rotatif dans un lecteur optique semblable à celui utilisé autrefois par le cinéma avec la piste optique (une loupiote d'un côté, un capteur photoélectrique de l'autre traduisant les variations de lumière en oscillations électriques). Cette technologie fut utilisée par la marque allemande Welte pour fabriquer des orgues électroniques, les Lichtton-Orgel. Bien qu'apparenté, ce principe ne doit cependant pas être confondu avec le cellulophone dont le générateur sonore ne cherchait pas à reproduire le son d'un orgue véritable.

Orgue électrostatique

Dans les années 1960 et 1970, l’orgue Dereux qui utilisait la technologie des générateurs électrostatiques, était considéré par les organistes comme l’instrument "électrique" le plus « acceptable » pour l’oreille et la musicalité.

Le principe général est celui de l'inscription sous forme d'oscillogrammes concentriques, des enregistrements d'un nombre suffisant de tuyaux d'orgue sur chacun des 12 générateurs correspondant chacun aux 12 demi tons de l'échelle chromatique (ut, ut diéze, ré, etc.)

Ces 12 générateurs comportent chacun en regard des oscillogrammes gravés par photogravure, un analyseur composé d'un disque, assemblé à un axe tournant dans des roulements à billes de haute précision. Le disque porte un certain nombre de formes de rectangles rayonnants gravés. La lecture se fait donc par le passage à un rythme précis des rectangles devant les oscillogrammes.

Il s'agit, en quelque sorte, d'autant de condensateurs variables qu'il y a d'enregistrements de tuyaux.

Il est bien évident que le dispositif ne comportant aucun frottement est stable dans le temps. Le fait pour l'analyseur de tourner entre des gravures n'engendre naturellement aucune tension.

Par contre si un des oscillogrammes est porté à une certaine tension, un potentiel oscillant apparaît entre le rotor et la masse. Fait essentiel, ce potentiel est exactement proportionnel à la tension d'excitation et de forme rigoureusement semblable à l'oscillogramme qui lui a donné naissance.

Il est aujourd’hui de technologie ancienne, mais on trouve encore quelques instruments en activité, dans des chapelles et il est recherché par les collectionneurs et par des organistes qui sont heureux de jouer sur ces instruments, chez eux, et à un coût d'acquisition plus qu'acceptable. Le choix des jeux est judicieux et le son est superbe.

L’orgue Dereux était cependant un précurseur de l’orgue numérique puisque c’était la première fois qu’on avait eu l’idée d’utiliser un son réel enregistré et de le restituer le mieux possible. Les limites de l’orgue Dereux étaient liées à la technologie de l’époque. Toutefois cet orgue s'entretient facilement en raison de l'utilisation de composants discrets toujours disponibles chez les spécialistes (revendeurs de matériel électronique).

Il est à noter que les brevets Dereux ont été repris par la société espagnole Harmoniphon qui a construit notamment des orgues à trois claviers à 47 jeux.

L’épisode synthétiseur

Un nouveau souffle est donné à l’orgue avec la naissance du synthétiseur. Le son « synthé » profitera surtout à des orgues jazzy (avec claviers décalés et pédalier raccourci) et on verra alors l’explosion de ces instruments hybrides, avec boîte à rythme, accompagnement automatique et autres accessoires (portamento, vélocité, after-touch). C’est l’invasion des produits japonais avec les orgues Yamaha, Technics, Roland, Korg. Même Hammond trouve un second souffle en adoptant la technologie synthé en 1975. Mais les organistes classiques n'apprécient pas ces sons fabriqués, trop éloignés de ceux des orgues à tuyaux.

C’est grâce aux progrès de la technique du synthétiseur que l’orgue électronique va renaître. Il y aura d’abord le Mellotron (dans les années 1970), étrange machine reprenant le principe de l’orgue Dereux, sauf qu’à la place des disques électrostatiques, chaque touche du clavier déclenche la lecture d'une bande magnétique limitée dans la durée. Trop complexe, trop de problèmes mécaniques (les bandes finissent par bourrer et s’user), trop de pleurage, le Mellotron n’aura qu’une courte durée de vie, même s'il a permis à la musique électroacoustique de faire ses premiers pas.

La naissance du son numérique

Mais l’informatique arrive, et avec elle, l’idée de stocker la boucle sonore, non plus sur un disque ou sur un bout de bande magnétique, mais dans de la mémoire informatique. Pour y parvenir, il fallait mettre au point une technologie radicalement différente d’enregistrement du son : la numérisation.

Échantillonnage.

La numérisation ou enregistrement numérique consiste à convertir un son capté par un microphone (fig. 1) en une succession de valeurs numériques binaire (des "uns" et des "zéros") qu’il est aisé ensuite de stocker sur un support idoine (puce mémoire, disquette, CD). Cette opération s’appelle conversion A-D pour Analogique-Digital (fig. 2). Cependant, cette conversion oblige à exécuter une opération complexe : l’échantillonnage. Les premiers échantillonneurs sont nés dans le monde du synthétiseur ; il faut citer pour mémoire le Mirage de Ensoniq, né au début des années 1980. Il offrait une résolution de 8 bits, avait une polyphonie de 8 voix, mais il avait déjà un son exceptionnel (il y avait de très beaux sons d’orgue). L’échantillonnage consiste à analyser un son en temps réel, plusieurs milliers de fois par seconde ; chaque analyse consiste à mesurer la pression acoustique perçue par le microphone et à la convertir en une valeur numérique, compréhensible pour un ordinateur. C’est cette valeur que l’on appelle un «échantillon». L’échantillonnage se fait généralement à 96 kHz sur 20 ou 24 bits pour les professionnels (c’est-à-dire 96000 fois par seconde) et à 44,1 kHz lorsque l’enregistrement est destiné au disque compact, avec une résolution de 16 bits et en stéréo. Désormais, avec l’arrivée du DVD-Audio et du SACD, on s’oriente vers un nouveau standard : échantillonnage à 192 kHz, avec 24 bits de profondeur.

La restitution du son original se fait en réalisant l’opération inverse qui consiste à lire l’information numérique stockée en mémoire et à la convertir en signal analogique, on utilise pour cela un convertisseur Digital-Analogique ou D-A (fig. 3) (en anglais DAC pour Digital to Analog Converter). C'est le nombre de convertisseurs qui détermine la capacité de l'orgue numérique à gérer simultanément la conversion de plusieurs échantillons.

Ensoniq Mirage

Fréquence et résolution

La fréquence d’échantillonnage détermine la bande passante supportée par le système. Selon le principe de Shannon, «l’information véhiculée par un signal dont le spectre est borné n'est pas modifiée par l'opération d'échantillonnage à condition que la fréquence d'échantillonnage soit au moins deux fois plus grande que la plus grande fréquence contenue dans le signal.» Cela signifie que pour encadrer la bande passante auditive naturelle de l’homme, que l’on estime comprise entre 15 Hz et 24 kHz dans le meilleur des cas, il faut une fréquence d’échantillonnage au moins égale ou supérieure à 48 kHz (c’est-à-dire le double de la fréquence la plus haute). Les orgues numériques actuels utilisent au minimum une fréquence d’échantillonnage de 62,5 kHz, ce qui est amplement suffisant.

Mais la fréquence d’échantillonnage seule ne suffit pas pour produire un son de haute qualité. La résolution du signal est également un paramètre très important. Elle est déterminée par le nombre de bits utilisés pour coder chaque échantillon. On trouve sur le marché des instruments dont les sons sont codés sur 16, 20 ou 24 bits. Avec une résolution de 24 bits, on dispose d’une dynamique théorique de 144 décibels ce qui offre un confort d’écoute proche de la perfection.

Qu’est-ce qu’un orgue numérique ?

L’orgue numérique est donc l’héritier direct de cette technologie de l’échantillonnage. Les sons produits ne sont plus générés électroniquement par des oscillateurs, ni synthétisés (comme c’était le cas sur les anciens générateurs analogiques), mais ils sont stockés dans une mémoire statique (en général une eprom, parfois un disque dur) et proviennent d’un véritable orgue à tuyaux dont un nombre déterminé de notes a été soigneusement enregistré à l’aide de deux ou quatre microphones. Un enregistrement à deux microphones donne un son stéréophonique ; un enregistrement à quatre microphones donne un son 3D (codage THX 5.1, présence spatiale). La qualité d’un orgue numérique dépend donc de la qualité et du nombre de ses échantillons. Le soin apporté à l’enregistrement de chaque jeu et la qualité de l'amplification choisie conditionnent le résultat final.

Techniques mises en œuvre dans l'orgue numérique

Jusqu’à récemment, les premiers orgues numériques n’utilisaient qu’un seul échantillon pour tout le clavier, c’était nouveau, il y avait donc une pointe de réalisme, mais le résultat était très décevant. En plus, les échantillons étaient pauvres, réalisés à une fréquence de 11 kHz ou 22 kHz sur 8 bits et monophoniques, ce qui avait pour conséquence une surcharge de fréquences parasites dans les aigus (ondes stationnaires), des bruits de fond, du souffle, trop de transitoires, des saletés et des accidents dans les graves, etc. Il faut donc considérer que l’orgue numérique, grâce au progrès technologiques, a eu une évolution véritablement exponentielle dans les 1990 et a enfin acquis une maturité certaine grâce à des capacités accrues et un échantillonnage d'une qualité toujours plus grandissante.

Il est néanmoins patent que la qualité des orgues numériques est très inégale et qu’elle est encore perfectible. Il ne faut pas attendre de grande “émotion musicale” d’un instrument d’entrée de gamme !

Selon que le constructeur cherche à faire un instrument industriel bon marché ou qu’il se soucie davantage de perfection sonore, la technologie d’échantillonnage et de restitution sera différente. Nous avons vu que plus la fréquence d’échantillonnage et la résolution sont élevées, meilleure est la qualité du son, car c’est de la fréquence d’échantillonnage et de la résolution de chaque échantillon que dépend la finesse, la précision et donc la vérité (le « grain ») de l’onde sonore. Mais on ne peut pas faire un jeu d’orgue avec un seul échantillon. En pratique, il existe plusieurs niveaux de qualité. En premier lieu, on distingue deux types d’échantillons : les échantillons courts et les échantillons longs.

Les échantillons courts…

…ne contiennent pas beaucoup d’information ; ils sont constitués d’une seule forme d’onde (enregistrée à l’aide d’un vrai tuyau) simplement répétée en boucle et le son obtenu, bien que proche de l’original, manque de finesse, de dynamique. Ça sonne toujours « électronique » à cause de la platitude du son.

Les échantillons longs…

…sont dynamiques. Ils sont constitués de quatre éléments concaténés que l'on nomme ADSR : Attaque, Decay (retombée), Sustain (la tenue) et Release (le relâchement ou la fermeture). L’attaque est le moment particulier de l’ouverture de la soupape où l’air pénétrant dans le tuyau commence à entrer en vibration ; il se produit alors toutes sortes de bruits, d’harmoniques qui sont caractéristiques du jeu (par exemple le chuintement à l’attaque du jeu de bourdon) puis la retombée qui se stabilise dans la tenue. La tenue, dans un échantillon long, n’est pas une simple onde rebouclée mais un enregistrement d’une certaine durée qui couvre une rotation de phase complète. Il faut en effet savoir qu’un tuyau d’orgue n’est pas un simple générateur acoustique stable et uniforme ; c’est même tout le contraire d’un générateur continu. Le vent produit toujours des ondes stationnaires qui entrent en phase les unes avec les autres et provoquent de légères fluctuations harmoniques perceptibles sur une période cyclique, dont la durée varie d’un tuyau à l’autre. Pour enregistrer correctement une rotation complète, il faut donc avoir l’oreille, être musicien plus que technicien, et y passer beaucoup de temps. En pratique, on enregistre le jeu note par note (tuyau par tuyau), sur une durée de 5 secondes (ou plus) pour chaque note, la durée des phases étant généralement inférieure ou égale à 2 ou 3 secondes. Et c’est en studio qu’on isolera patiemment, tuyau par tuyau, chaque phase pour la reboucler (et éviter le “clic” du bouclage). Finalement, on obtiendra une banque d’échantillons (61 pour un clavier de 61 touches) qui auront chacun une longueur différente et dont on aura préservé les petites imperfections et les petites inégalités qui font le réalisme de l’orgue acoustique. Arrive enfin l’échantillon de fermeture qui va exactement restituer ce qui se passe au moment de l’extinction du son dans le tuyau. On appelle cette partie de l’échantillon la queue de résonance. Elle est très importante dans les jeux d’anche, car même si elle est presque imperceptible, la fermeture de la soupape provoque toujours un petit couinement ou un petit hoquet dû au fait que la languette continue de vibrer pendant une fraction de seconde.

Il existe une catégorie intermédiaire, l’échantillon court dynamiquement contrôlé qui consiste à exploiter un échantillon court et à y introduire, par traitement informatique, de petites altérations aléatoires pour lui donner plus de réalisme. Il s’agit de simulation et non de reproduction, le résultat est donc douteux car cela a toujours un goût de synthétique.

Dispersion des échantillons (nombre d'échantillons pour un jeu)

En théorie, l’orgue numérique parfait devrait avoir autant d’échantillons longs qu’un orgue acoustique possède de tuyaux. En pratique, pour des raisons de coût de production, les fabricants d’orgues numériques font des compromis qui sont parfois discutables.

L’orgue numérique d’entrée de gamme et bon marché n’aura que des échantillons courts et en plus, ces échantillons seront utilisés pour plusieurs notes, entre 4 et 12. En changeant la fréquence d’échantillonnage à la lecture, on reconstitue les notes manquantes de la gamme par transposition. Pour les douze notes d’une octave, on utilise seulement 1, 2 ou 3 échantillons. Pour couvrir 5 octaves, 5 à 15 échantillons suffisent. Évidemment, la qualité s’en ressent. Pour faire un mi avec un do, on prend l’échantillon du do et on en accélère la lecture, ce qui déforme le timbre et rend le son bizarre (comme lorsqu’on écoute une voix enregistrée au ralenti ou à l’accéléré). Pour trouver les solutions les plus économiques les fabricants poussent le vice plus loin : la première et la dernière octave du clavier peuvent n’utiliser chacune qu’un seul échantillon. Le pire étant de n’avoir qu’un seul échantillon décliné sur toute l’étendue du clavier ce qui a bien été le cas des premiers orgues numériques (et c’est toujours le cas des synthétiseurs-échantillonneurs bon marché). Ceux qui appliquent un tel procédé partent en effet du principe que l’oreille humaine serait moins sensible à la qualité timbrale dans le grave et dans l’aigu. C’est un postulat qui n’est pas valable pour tout le monde, surtout les musiciens qui ont développé plus que quiconque une sensibilité à la qualité du son. Raison pour laquelle la plupart des orgues numériques, bien que nettement meilleurs que ce qui se faisait dans les années 1980, ont du mal à convaincre organistes et musiciens.

Une marque d’orgues numériques a inventé la "simulation de l'attaque" : pour simuler l’attaque d’un tuyau, un peu de bruit blanc (bruit de synthèse créé par un générateur aléatoire) est ajouté à l’enfoncement de la touche, ce qui donne un effet plus ou moins plaisant. Le bruit est uniforme sur toute l’étendue du clavier, alors que ce n’est jamais le cas dans la réalité : dans un orgue acoustique, chaque tuyau a un comportement différent de son voisin, l’un pouvant produire plus de bruit que l’autre ou pas de bruit du tout.

De même, cette marque a voulu imiter le bruit du vent dans les tuyaux graves (basse, bourdon, bombarde) en ajoutant –encore lui– un peu de bruit blanc variant de façon aléatoire (un aléatoire généré artificiellement).

Sur des modèles d’entrée de gamme, la polyphonie est limitée : il est impossible de plaquer un accord de plus de 8 notes ; les notes supplémentaires sont muettes ce qui pose problème lorsqu’on espère trouver l’équivalent d’un orgue classique, par définition totalement polyphonique !

Les convertisseurs

Pour restituer les sons numérisés et les rendre audibles en les envoyant à travers les étages d’amplification vers les haut-parleurs, il faut disposer en amont d’une batterie de convertisseurs, système complexe. Sur les orgues électroniques utilisant la technologie analogique, les notes étaient toutes générées en permanence par un oscillateur général et les touches agissaient comme des interrupteurs envoyant le signal directement vers le ou les amplificateurs. La mise en œuvre de l’orgue analogique était suffisamment rudimentaire pour que, dans les années 1970, les orgues soient proposés en kit. Il y avait très peu d’électronique et beaucoup de fils (autant de fils de liaison que de notes et de rangs, par exemple 1 600 liaisons sur le modèle III/38). A contrario, l’orgue numérique contient beaucoup d’électronique et très peu de fils, ces derniers ne transportant plus le son, mais des données numériques entrelacées et multiplexées.

La complexité de l’orgue numérique réside dans sa capacité à traiter d’énormes quantités de données en temps réel. Sur un orgue à tuyaux, lorsque l’organiste tire le Tutti d’un instrument de 60 jeux et joue par exemple un accord de 8 notes (7 notes manuelles et une note de pédale), il fait sonner au moins 500 tuyaux simultanément. Pour obtenir exactement le même résultat sur un orgue numérique, cela suppose que l’on puisse simultanément lire, convertir, préamplifier, mixer et envoyer vers les amplificateurs 1 000 échantillons ! Chaque tuyau correspond à deux échantillons lorsque ceux-ci sont enregistrés en stéréophonie, d'où 500 × 2 = 1000. Il en faudra 2 500 si les échantillons sont 3D (codage 5.1).

Lorsqu'un CD est joué sur une chaîne stéréophonique, il n’y a que deux convertisseurs qui fonctionnent en continu, un pour le canal droit, l’autre pour le canal gauche. Sur un orgue numérique, il faut tirer tous les jeux sur trois claviers, tous les claviers sont accouplés, il y a 40 jeux sous un seul doigt, en comptant les rangs de mixtures et de cornets, cela correspond en moyenne à 50 tuyaux virtuels, donc à 50 échantillons stéréophoniques ou THX. C’est comme si cette touche déclenchait la lecture simultanée (et sans retard) de 50 lecteurs de CD (en stéréo) ou bien de 100 lecteurs de CD (en THX) ! Tout cela survient pour une seule touche enfoncée ! Un cluster est nettement plus exigeant.

Ces considérations techniques sont théoriques. En pratique, les fabricants réalisent le mixage des sons de manière logicielle, de sorte qu'il n'est nécessaire d'avoir qu'un convertisseur par canal d'amplification. Il reste que, en reprenant l'exemple ci-dessus, un orgue qui doit calculer le rendu sonore de 500 notes 44100 fois par seconde avec des échantillons 16 bits stéréo doit effectuer plusieurs milliards d'opérations arithmétiques par seconde ; chose que même les microprocesseurs grand public actuels peinent à faire. Sauf à multiplier le nombre de coûteux processeurs, ceci est impossible pour des raisons économiques. Il existe heureusement des processeurs dédiés à ces traitements de rendu sonore, et qui sont dans cette tâche spécifique plus performants que des processeurs du type de ceux qu'on peut trouver dans un PC. Cependant la polyphonie est toujours limitée, même si dans les modèles haut de gamme elle est suffisante pour jouer à quatre mains ou de faire de beaux clusters.

Les haut-parleurs

Disposition des haut-parleurs dans la console

Le son des orgues numériques est traité par des amplificateurs et sort par des haut-parleurs. Là encore, le pire côtoie le meilleur. Laissons de côté le pire et voyons simplement quelle est la solution choisie par les constructeurs d’orgues numériques haut de gamme : multiplier les amplis et les haut-parleurs, et n’utiliser que du matériel Hi-fi dédié. L’idéal théorique serait qu’il y ait autant de haut-parleurs que de tuyaux mais ce ne serait ni raisonnable, ni utile. De même pour l'écoute de l'enregistrement d'un orchestre symphonique, dans cette logique des choses, l'idéal serait de pouvoir séparer chaque pupitre sur un point de diffusion dédié. Cette comparaison est bien entendu absurde car les tuyaux numérisés des orgues numériques ne sont pas enregistrés dans leur spatialisation d'origine, mais en chambre sourde, sortis de leur buffet et de leur acoustique naturelle. L'art du facteur d'orgues numériques consiste donc à reconstituer le mieux possible un son exact et une acoustique artificielle à partir d'échantillons bruts. C'est la raison pour laquelle il est nécessaire de recréer une spatialisation pour donner un relief plus ou moins heureux avec une séparation UT/UT# différentes sur chaque jeu. La technique d'échantillonnage stéréophonique global de tuyauterie d'orgues effectué dans le buffet d'origine et en acoustique naturelle (voir rubrique orgue virtuel) fonctionne parfaitement avec un système stéréophonique sans nécessité de spatialisation artificielle.

La norme du "haut de gamme" de l'orgue numérique à échantillonnage partiel en chambre sourde débute avec 7 amplificateurs pour 13 haut-parleurs. Certains fabricants d’orgues numériques ont réussi là où la plupart des fabricants de chaînes stéréophoniques ont échoué : ni distorsion, ni saturation. Mais cela n’a rien de surprenant, la puissance est répartie sur 13 voies indépendantes et c’est un principe acoustique connu : Quand le nombre de voies augmente, les collisions acoustiques diminuent (à cause de la spatialisation). N’est-ce pas d’ailleurs le principe de l’orgue à tuyau où chaque son se produit en un point différent dans l’espace ? Il paraît en tout cas naturel qu’il y ait 2, 3 ou 4 voies par clavier afin de simuler la spatialisation de l’orgue. La plupart des orgues numériques disposent de haut-parleurs situés à hauteur des jambes, ce qui n'est pas sans rappeler la disposition d'émission du son des harmoniums.

Conclusion

Orgue numérique à 4 claviers. La console reproduit en tous points celle d’un orgue classique. Seuls quelques potentiomètres trahissent la présence de l’électronique.

Le meilleur orgue numérique serait un instrument à échantillonnage complet de tous les tuyaux, fonctionnant avec des banques de sons d'orgues identifiées (Cavaillé-Coll, Clicquot, Silbermann, etc), reproduisant fidèlement (avec une amplification de qualité HIFI) un grand choix de jeux échantillonnés afin que l’organiste puisse composer librement son instrument, des mixtures échantillonnées tuyau par tuyau (et non note par note). La plupart des fabricants proposent des orgues numériques à échantillonnage réduit (quelques tuyaux seulement sont échantillonnés en chambre sourde pour chaque jeu) ; on peut citer, par ordre alphabétique, Allen, Baldwin, Benedikt, Briston, Cantor, Content, Copeman Hart, Eminent, Hoffrichter, Johannus, Phoenix, Rodgers, Van der Poel, Viscount et Wyvern; les orgues Monarke et Makin sont fabriqués sous licence Johannus.

Même si la qualité sonore des orgues numériques n'atteint évidemment pas celle d'un bon orgue à tuyaux, ils possèdent néanmoins quelques avantages sur ceux-ci :

  • D’abord, il est possible, avec le même instrument, de basculer d’un style baroque à un style romantique ou symphonique grâce à un filtrage du son spécifique à chaque esthétique. On a le choix entre plusieurs tempéraments historiques : mésotonique, Tartini-Vallotti, Werkmeister-III ou égal. On peut bien sûr le diapason pour imiter les orgues baroques qui sont souvent accordés en La 415, 427 ou 390 hz.
  • On peut enregistrer ce que l’on joue sur ordinateur grâce au MIDI et, si on le souhaite, convertir cet enregistrement en partition (très pratique pour immortaliser une improvisation ou plus modestement pour se corriger, pour juger de l’acoustique en prenant du recul : on peut s’écouter jouer sans jouer). Précisons cependant que cette fonctionnalité commence également à voir le jour sur certains orgues à tuyaux.
  • On peut jouer en silence, avec un casque sur les oreilles, ce qui est bien pratique pour ne pas déranger les voisins ou pour travailler à toute heure du jour ou de la nuit.
  • Un orgue numérique prend peu d'espace et se transporte assez commodément.
  • En comparaison avec un orgue à tuyaux, même petit (3 à 5 jeux), l'orgue numérique est très économique à l'achat et demande peu ou pas d'entretien.
  • Et bien sûr, un orgue numérique tient parfaitement l’accord. Pas besoin d’accorder les anches tous les quinze jours !…

Principaux fabricants d'orgues numériques

Fichier audio
Plein-jeu de Louis Marchand joué
sur orgue Johannus Studio 150
Menu
0:00
Des difficultés à utiliser ces médias ?
Des difficultés à utiliser ces médias ?
Consultez la documentation du modèle

Il n'existe pas à proprement parler une production industrielle de l'orgue numérique classique car le marché est naturellement limité et il est de toute évidence beaucoup plus réduit que le marché de l'orgue de variété et du synthé. C'est pourquoi la plupart des grandes marques ne sont en fait que de petites unités de production et à la rigueur des petites chaînes de montage peu automatisées et où persiste un certain artisanat.

Les marques les plus connues mondialement sont : Allen (États-Unis), Rodgers (qui est un département de Roland, Japon/États-Unis).

Les autres marques sont : Ahlborn (Italie), Baldwin (États-Unis), Dr Böhm, Cantor (Allemagne), Content (Pays-Bas), Copeman-Hart (États-Unis), Eminent, Hoffrichter (Allemagne), Johannus (Pays-Bas), Lowrey, Makin, Monarke (Pays-Bas, division de Johannus), Van der Poel, Viscount (Italie), Wyvern, Wersi, etc.

Les marques connues qui n'existent plus : Dereux, Garrel, Givelet-Coupleux, Hohner…

La technologie de l’orgue numérique comparée à celle du simulateur d'orgues à tuyaux (orgue virtuel)

Depuis plusieurs années, une nouvelle génération d'orgues numériques se développe rapidement sous l'appellation d'"orgue virtuel" ou "simulateur d'orgues à tuyaux". La caractéristique première de cet instrument nouveau réside dans le fait que le son est généré par un micro-ordinateur avec un logiciel permettant d'utiliser des banques de sons d'orgues constituées de l'enregistrement de tous les tuyaux d'instruments identifiés.

On sort du système des sons génériques des orgues numériques "classiques" décrits plus haut : il ne s'agit plus d'entendre UNE montre 8', mais LA montre 8' de tel orgue, restituée avec l'acoustique d'origine.

L'organiste choisit virtuellement au fil de ses interprétations l'orgue qui lui chante le mieux : LE Cavaillé-Coll de St Etienne de Caen, LE Silbermann de Freiberg, LE Schnitger de Zwolle, etc.

La technologie de l’orgue numérique comparée à celle du synthétiseur

Il existe dans l'opinion courante une confusion entre orgue numérique et synthétiseur numérique. Ce chapitre entend dissiper cette confusion.

Un synthétiseur sérieux (nous ne parlons pas des jouets vendus par la grande distribution) coûte en général plus de 1 000 €. Comme on dit que les orgues numériques actuels ont hérité de la technologie des synthé-échantillonneurs, on a tendance à ne pas comprendre qu’un orgue soit beaucoup plus cher qu’un synthé. En fait, les deux technologies sont cousines, mais servent des instruments dont la philosophie est différente.

Le synthétiseur ne s'utilise en général pas seul: on en joue en groupe avec d'autres instruments, ou en s'accompagnant avec un séquenceur. La raison d'être du synthétiseur est de pouvoir produire (synthétiser) une grande variété de timbres, voire de pouvoir ces timbres tout en jouant. La création sonore est l'essence de l'art de cet instrument. Le synthétiseur est adapté à cette philosophie, et comporte à cette fin plus de commandes qu'un orgue (boutons, potentiomètres, sensibilité à la vélocité, à la pression exercée sur le clavier (aftertouch), pédales de contrôle). Il a aussi l'avantage d'être facilement transportable, et comparativement abordable par rapport à l'orgue.

L'orgue est en comparaison un instrument ou l'instrumentiste se suffit à lui-même ; il doit pour cela se transformer en "homme orchestre", jouer des deux mains et souvent des pieds. La pratique de l'orgue est à cet égard plus exigeante que celle du synthétiseur. Pour permettre à l'instrumentiste d'être le plus efficace possible, l'instrument doit avoir une interface bien pensée, avec des claviers bien positionnés l'un par rapport à l'autre, et des commandes qui permettent de changer les réglages de l'instrument rapidement pour s'adapter aux différents mouvements d'une pièce de musique, en plus d'un pédalier qui ne glisse pas sur le sol ! Tout cela mène à des instruments volumineux qui présentent l'avantage de fournir de la place pour loger une amplification adaptée à l'acoustique de l'instrument. Mais la différence majeure entre l'orgue et le synthétiseur, c'est que sur un orgue on peut empiler les sons (jeux) ; c'est d'ailleurs la manière spécifique de varier la palette sonore sur un orgue puisque les capacités d'édition d'un timbre unique sont, quand elles existent, beaucoup plus limitées que celles d'un synthétiseur dont c'est la raison d'être. La puissance de calcul nécessaire à un orgue numérique croît avec sa capacité à additionner les jeux. Même si les sons sont individuellement moins complexes à calculer que sur un synthétiseur (dont le son peut dépendre de centaines de paramètres), l'orgue nécessite beaucoup plus de puissance pour pouvoir empiler les sons, ce qui explique aussi son prix. En outre, un orgue électronique "liturgique" peut avoir des fonctions de rendu particulières pour simuler un orgue à tuyaux tel le principe des reprises d’une fourniture, d’une cymbale ou d’un plein jeu.

Schéma de fonctionnement d'un orgue numérique

Schéma de fonctionnement d'un orgue numérique utilisant la technologie des sons d'orgue échantillonnés.


Drum Tone

Vu dans ... http://www.sdiy.org/richardc64/new_drums/paia/paia_top.html

Back to Projects or Publications

NEW PLAN
Updates
DrumTone
DR-110
Samples
Construction
Documents
Miscellaneous
Synsonic

PAiA Drum Tone

This board, still available in kit form, was once part of PAiA's discontinued Thumb Drum product. It consists of six ringing oscillators with names such as Tom-Tom, Conga, Wood Block, etc. All typically retro. It also has a Snare Drum, and seemed an acceptable replacement for my damaged and nearly useless Synsonic. Here's a nice, cleaned up scan of the complete Schematic.

The d.i.p. patterns J1 and J2 at the top left corner are for mapping the (discontinued) finger drumpad outputs to the voices of the user's choice. Of particular interest to me was the SynthDrum voice, and its Theory of Operation. It seemed to me it should be capable of more than disco-age pitch "Glide."

Looking at the schematic, I saw that if resistor R4 were made variable, that would give control over the Pitch. I also saw that there was no control over the depth of the frequency sweep brought about by the diodes and other parts that connect to R4, so that would be something to correct. Lastly, there was no control over the Decay length of the "ringing."

That last shortcoming seemed easily fixed by replacing the "Q" trimpot with a potentiometer, but it wasn't that simple: the trimpot's range included no oscillation at one extreme and constant oscillation at the other. By cutting pcb traces and adding a jumper and fixed resistor, I rearranged that part of circuit so that the trimpot limited the range of Q (resonance,) controlled by a front panel Decay pot.

Varying R3 (R29, below) to control the depth of pitch sweep didn't work. I removed one diode and put a pot in its place, and that worked very well. But modulating with an LFO had problems, hence the big red X.

SynthDrum details
Click for details, including wiring and audio files

Other features added were cross-over distortion, (labeled "Warp,") which sounds more percussion-like to me than clipping, and an optional Impact click. Click the schematic for full details.

"Conga" Modifications

Given the similarity of all the the DrumTone oscillators, I saw no reason why they couldn't all have the same features. Seeing that the SynthDrum pitch-controlling resistor connected to ground, instead of +5V, I reasoned that the other oscillators could be that way, too, so that's where I put the Conga's Pitch pot.

Studying other ringing oscillator schematics, I saw other ways to control the Q/Resonance/Decay. The simplest to retrofit to the pcb was to put a pot to ground in series with the capacitor in the R-C-R "T" network. (C10 in the schematic below.) Trimpot R21 then limited the maximum decay length that the Decay pot can be set for -- which was quite long. long_conga.mp3

Conga details
Click for details, including wiring and audio files

To bring about voltage control of Pitch, I replaced the diode(s) of the SynthDrum with a transistor paralleling the Pitch pot. This addressed two problems with the diode method: First, if the CV is from an LFO, and at too great an amplitude, the peaks will constantly re-trigger the oscillator. Second, if the modulation is also at an audio rate, as when trying to bring about a pseudo ring-mod/metallic sound, it will bleed through to the output -- even when the oscillator isn't ringing. The transistor method greatly minimizes, but still does not completely eliminate, both problems.

Click the schematic for full details, again including wiring and audio samples.

DrumTone Overview

Here's how I plan to utilize a modified D.T. board: DISCONTINUED

[ Image Deleted ]

(Although I still consider this a pretty good plan, what I want is a self-contained system, one in which the electronics isn't a module external to the drum pads. Given my skills in mechanical construction, to make everything fit, such a setup would end up being too large for apartment living. I've purchased a commercial product that I can enhance or augment with minimal d.i.y. circuits. I will post details when that project gets further along.)


Vu dans ... http://mickeydelp.com/blog/anatomy-of-a-drum-machine

Anatomy of a Drum Machine

Published: July 31, 2012
Tags: synth drums
Share:

This is the story of the design and development of the Delptronics LDB-1 Analog Drum Machine with a focus on the technical details.

I had been studying analog drum circuits for about a year, including both classic drum machines and more modern drum circuits and modules. In January of 2012, having just finished several projects, I felt it was time to dive into building some drum circuits. My goal was to build a small, low cost drum machine, and I knew that the first step was to get the sounds right. I breadboarded every drum circuit I could find and compared the results with samples from the classic drum machines, particularly the venerable Roland TR-808. I worked on it full time for two weeks. By the end of that time, I had the circuits refined and tuned and sounding just the way I wanted them.

The one sound I could not get quite right was a rim-shot. The closest I could get was a woodblock. I figured it was time to build a prototype and I would get back to the rim-shot sound later. To my surprise, I got a lot of compliments on the woodblock sound, so I kept it as is.

I then went through the process of choosing a microcontroller to be the brains of the drum machine. That process is described in more detail below. I worked out the basic code for a microcontroller triggering the drums and built the prototype. Having worked out the bugs, I designed a printed circuit board and built several devices.

The most time-consuming step in the development of the LDB-1 was to program all of the features. I went through many iterations of the code to get every feature of a classic drum machine into the LDB-1 with an easy to use interface. A three month long beta test cycle really paid off.

When development was complete, there was still a ton of work needed before it could go to market, tasks like writing the user manual, sourcing the components, assembly, the design and production of the enclosure, and so on.

Original Prototype | Final Production Model
LDB-1 Drum Machine Prototype | LDB-1 Drum Machine

The Circuits

The rest of this article is a description of the LDB-1 circuits. The information presented below should provide you with all of the information that you need to understand and even modify the LDB-1. If you have specific questions not answered by this article, please feel free to contact me. As you read the article, follow along with the LDB-1 Schematic .

Drum Circuits

The circuits in the LDB-1 are very similar to those used in classic analog drum machines, albeit greatly simplified. For example, compare the amount of circuitry for an individual LDB-1 drum with that of the TR-808. Page 9 of the TR-808 Service Manual shows the schematics for the drum sounds. Each instrument in theTR-808 has two to three times more components than the corresponding circuit in the LDB-1. An important design goal of the LDB-1 was to make it as small and inexpensive as possible. To do that, the circuitry for each instrument was pared down to its core, and the component values were carefully tuned until it sounded perfect.

The LDB-1 uses bridged t-networks to produce decaying sine waves, just like the TR-808 and many other classic drum machines. The bridged t-network is actually a filter that is excited into self-oscillation by a pulse wave. In the LDB-1, the pulse is provided by the microcontroller. The circuits for the bass, toms, and woodblock are identical except for the resistor and capacitor values. My first exposure to using bridged t-networks to produce drum sounds was in 1982 when I saw the Rhythm Pattern Generator schematic on page 143 of the Forrest Mims Engineers Notebook. The circuit was too advanced for me at the time, but it stuck in my mind as something that I would like to build eventually. It only took 30 years to get around to it.

Page 5 of the TR-808 Service Manual gives the schematic and formula for the bridged t-network.

Bridged T-Network from TR-808 Service Manual

As you can see, the circuit consists of two resistors and two capacitors, all of which combine to determine the properties of the sound: the pitch, resonance, and decay. Changing any one of the values effects all three of the properties. Some rudimentary tuning of the pitch can be obtained by replacing R1 with a potentiometer. Given the relatively large resistors used by the LDB-1 for R2, at most a 5K pot is recommended. In the TR-808, there are quite a few additional components in the circuitry of each of the instruments that enable their pitch and/or decay to be tuned.

Snare Drum

A snare drum is really two sounds: the sound of the drum head being hit and the sound of the snare wires vibrating against the bottom resonant head of the drum. The circuit for the snare drum contains the same bridged t-network used by the bass and toms, but instead of triggering it with a simple pulse, the snare drum is triggered with a burst of white noise. The white noise is first passively low pass filtered by C22 and R24. Then it is sent through a single transistor VCA (voltage controlled attenuator), a circuit referred to by the Roland engineers as a "Swing Type VCA." The VCA envelope is provided by a pulse from the microcontroller passing through a very simple RC circuit (R26 and C24). The same VCA circuit is used for the hi-hats.

The method of exciting the bridged t-network with white noise saves a lot of components when compared with the alternative method of separating the circuitry for the drum head and snare wires, triggering them both, then mixing their outputs.

Single Transistor Swing VCA from TR-808 Service Manual

Cymbal Circuits

The simplest cymbal implementation uses filtered white noise. That is the method used in the earliest drum machines, but it is not very realistic. The method used by many later analog drum machines is to mix four or six tuned square waves to simulate the very complex harmonics of a cymbal. If the LDB-1 hi-hats sound a lot like the Boss DR-110, it is no coincidence. The LDB-1 uses four square waves at the same frequencies as the DR-110. A little white noise is added in as well, again, just like the DR-110. The result is a fairly realistic, and very nostalgic, sounding hi-hat.

The "noise chip" in the LDB-1 schematic is a microcontroller programmed to output the digital white noise and four tuned square waves. The white noise is 16 bit LFSR (linear feedback shift register) algorithm that produces a pseudo-random bit stream. The noise chip does exactly the same thing in a single 8 pin chip that the DR-110 did with 27 discrete components, as you can see in the DR-110 schematic.

R1 through R5 control the mix of the square waves and white noise. That mix is sent through a band pass filter (another bridged t-network), then through a single transistor VCA. The VCA envelope is provided by a pulse from the microcontroller passing through an RC circuit. The closed and open hi-hats use the same circuitry except for their envelopes. C13 determines the decay rate of the closed hi-hat, and C14 determines the decay of the open hi-hat.

Hand Clap

Hand clap sounds are a staple of drum machines, and absolutely had to be included in the LDB-1. The implementation is very simple. Band pass filtered white noise is passed through a VCA. Roland used two VCAs and a rather complex quadruple envelope waveform to generate the TR-808 hand clap (see page 6 of the service manual for a detailed description). I actually implemented that in the microcontroller software, but found that the sound was not very different from the simple method and did not warrant the extra code complexity.

Audio Output

The individual instruments are mixed by op amp U1.2. The seven resistors that feed into that op amp are the mixing resistors and determine the relative volume of the instruments. You can raise or lower them to taste, or replace them with a 10K pot in series with a 1K resistor. A larger series resistor is recommended for the hand clap because that is proportionally much louder than the other instruments.

R51 controls the gain and, at 1K, provides line level output. If you need synth level output, R51 can be increased to 10K, or a 1K resistor in series with a 10K pot for variable gain. If you want to add a volume control to the output, a passive attenuator at the output is recommended over a 1K variable gain pot.

Some people have asked if it is possible to add separate audio outputs for each instrument. To do this, you would wire a resistor to the same point as the mixing resistor, and buffer the output through an op amp. If you do not buffer the individual outputs, then the individual sound circuits will interact and distort one another.

If you are wondering why a circuit with eight op amps uses one quad and two dual op amp chips instead of two quad op amp chips, it is because the cymbal and clap filters are (by design) noisy and so are isolated in their own chip to avoid cross talk. The noisy chips also have a separate ground plane on the PCB.

The Brains

The microcontroller is what triggers the sound circuitry, handles button presses, lights LEDs, and communicates via MIDI and analog inputs and outputs. In some respects the requirements of the device determines the choice of microcontroller, and in other respects, the choice of microcontroller determines the capabilities of the device.

The LDB-1 uses Microchip PIC18F26K22 microcontroller. I chose a PIC microcontroller because I like working with PICs. That is a personal preference, because I have a good familiarity with the devices and tool chain. Other microcontroller families would have worked just as well. I chose that particular microcontroller from the 700+ devices that Microchip offers for three reasons. I wanted it to be through-hole to be DIY/kit friendly. I wanted a 28 pin part as opposed to a 40 pin part to keep the PCB small. I wanted as much EEPROM space as I could get because I wanted the LDB-1 to have non-volatile memory for the patterns, songs and config options and I did not want the added cost and board space of an external EEPROM chip. The PIC18F26K22 has the most EEPROM memory of all of the 28 pin PICs, so it fit the bill. Actually, it is far more powerful than necessary. The LDB-1 code only uses half of the available RAM and less than half of the program memory. It is also much faster than necessary. It can run at up to 64 MHz. The LDB-1 runs it at 32 MHz, but even that is overkill.

The amount of EEPROM memory, and the decision not to use an external EEPROM chip, indirectly determined the number of instruments. One byte is eight bits, so a single step in a pattern can be stored in a single byte as long as there are no more than 8 instruments. Using two bytes per step would halve the number of stored patterns.

The number of pins determines the number of connections to the rest of the circuit and to the outside world. So, having chosen the chip, I started counting pins and their functions. I went through many iterations of this to determine how many jacks, buttons and LEDs could be on the final device.

I settled on 12 buttons and 12 LEDs. The buttons are in a 3x4 matrix and use 12 pins. Each button has a diode so that multiple buttons can be pressed simultaneously without any ghosting or masking issues. The LEDs are Charlieplexed, so only 4 pins drives all 12 LEDs. Only one LED is illuminated at a time, but they appear constant due to persistence of vision.

The outside world connections are audio output, trigger output, MIDI input, clock input and gate (start/stop) input. The MIDI jack can also be used as a DINsync input connection. DINsync was easy to implement because it uses pins that are not used by MIDI. The analog clock input and gate (start/stop) input jacks are wired right to the corresponding DINsync pins.

The trigger output is a unique design that I am quite happy with. Most drum machines have trigger out on one or more instruments. The TR-808, for instance has a trigger output on the cowbell, clap, and accent. The LDB-1 has a single dedicated trigger output jack that is configurable to output trigger signals on any instruments and/or steps that the user chooses. The trigger output length is also configurable.

Some people have asked if it is possible to add a separate trigger output for each instrument. The microcontroller triggers the instruments with a 4ms pulse. To send that pulse to a jack, you would connect a wire from the microcontroller pin that triggers each of the instruments to a buffer, and from there to an output jack. The separate trigger outputs must be buffered so that the circuitry plugged into the output jack does not interact with the LDB-1.

Acknowledgements

Thanks to everyone at the Austin synth meets who gave their input and encouragement, to Guy Taylor for his advice and lending me his TR-606, and to Joseph Pailo for being the best beta tester ever.

Copyright © 2009-2020 Mickey Delp


Drum Tone Oscillators - PAiA - DIY Music & Sound Electronics Kits - Synthesizer, Theremin, Studio

Vu dans ... https://paia.com/syndrum/

Welcome to our new site! Please let us know if you run into any problems. Thank you for your patience!

Drum Tone Oscillators

The circuit shown is the most interesting of several drum oscillators on an analog sound board that appeared as part of an article in the June 1993 issue of Electronics Now.

Drum Tone Oscillators

Like most drum tone oscillators, the circuit is a very high Q resonant filter that is only slightly overdamped and on the verge of oscillating. Triggering pulses (coupled through C5 and R5) provide an excitation signal that “rings” the oscillator — an analog of the rapidly decaying envelope of percussion sounds. This circuit topology is sometimes called a “Twin-T” because of the arrangement of components R1, C1, R2 and C2, R4, C3 and it’s the values of these parts that set the characteristic pitch of the percussion sound — bass, tom, bongo, clave, etc. Decay rate (“Q”) is adjustable with R8, which in conjunction with R6 sets the gain of the amplifier stage. Rotating R8’s wiper toward the “+5V” end increases “Q” for a slower decay rate. The circuit will self-oscillate at high “Q” settings.

This circuit has the embellishment of a simple Voltage Control mechanism. The diodes D1 and D2 are effectively in parallel with R4 (one of the components that determines pitch). As the CV-in voltage increases, the exponentially increasing current flow through these diodes causes their effective impedance to decrease, which raises the frequency of the Twin-T network.

Such a simple Voltage Control implementation has an interesting secondary characteristic — as the CV increases, “Q” also increases and above some threshold value the circuit acts like a Voltage Controlled Oscillator. A classic synth-drum down-scale gliss can be quite long since at the higher pitches the circuit is essentially a VCO which “quenches” when lower CVs produce lower effective “Q”s. This single simple circuit combines the functions of VCO, EG and VCA and is easy to mod and tweak.

On the PAiA Drum Tone Board, the downward sweeping ramp CV is generated by using the trigger pulse to charge C4 through D3. The voltage on C4 is the Control Voltage, which decays over time as it discharges through R3. The amplitude of the trig-in pulse determines the peak voltage on C4 and consequently how far upscale the down-scale gliss begins.

The circuit was designed to work with a power source having 12VDC and 5VDC rails. It can be converted to use a bi-polar supply by connecting all +5V points to ground and pin 11 of the IC to the negative supply rail. Bipolar supply voltages can be from +/- 5V to +/- 15V. Here’s how to tap power from the 9700 MIDI2CV8 MIDI>CV converter and use the pair for a MIDI controlled Drum Card.

  • View Full Drum Tone Board Schematic
  • Buy Drum Tone Board Kit
  • View 9700 MIDI2CV8 Kit

Places to Tweak

Change the glide time with C4. Increasing values increase time proportionally.

Change gross frequency range with C1, C2 and C3. Keep their values proportional to those shown, e.g. taking C1 to 0.02uF and C2 and C3 to 0.002uF lowers the frequency range an octave.

Sensitivity to CV should be adjusted at R3, but be aware that this will also shift the center frequency somewhat. It’s best to only increase the value, it’s presently optimized for about a 0-5V range and doubling it to 2.2Meg would take this up to 0-10V. The response is exponential (V/Oct), more or less, but is by no means chromatic in any given scale.

Removing C1 changes the response to low-pass with resonance, which is often more useful musically, but doesn’t ring quite as well for drum sounds. It could be switched in and out.

MIDI2CV8 to Drum Tone Board Connections →

Items in Your Cart

Product Search

Product Catalog

  • Analog Synthesizers Modules
  • » 9700 Series Analog Synths
  • » 9700 Series - New Modules
  • Theremax Theremin
  • Fatman Analog Midi Synth
  • Vacuum Tube Preamplifiers
  • Guitar FX
  • MIDI to CV Converters
  • Studio Series
  • » Vocoder
  • » MS Stereo Microphone
  • » Headphone Distribution Amplifier
  • » Submix Master
  • » Four-Band EQ
  • » Hot Springs Reverb
  • » Dual Limiter
  • » Parametric Equalizer
  • » Direct Interface
  • » Vocal Zapper
  • » Phono Preamps
  • Headphone Buffer Amp
  • Electronic Projects for Musicians
  • Experimenter
  • » Experimenter
  • » Power Wing
  • » Bipolar Power Supplies
  • Drum Tone Board
  • Dual Phantom Power Pre-Amp
  • Quadrafuzz
  • MIDI Controllers
  • Ducker
  • Building Block Kits
  • » Multimeters
  • » Simple Audio Amplifiers
  • » Basic Preamps and Tone Control
  • » DC Power Supplies
  • » Communications-mono, optical...
  • » Test and Measurement
  • » Touch Switches
  • » Motor and Lighting
  • » Odds and Sods
  • » Relay Logic and Control

Recently Viewed

My Account


How to build an electronic drum pad | Suono Elettronico

Vu dans ... http://www.suonoelettronico.com/articolo_dettaglio.asp

How to build an electronic drum pad

If you want a basic electronic drum sound with no frills at a minimum cost here it is.

This circuit makes use of an active filter's transient response to produce the sound. This is a circuit commonly used in older rhythm boxes.
Lengthening the decay time and adding a pitch sweep produces a basic drum synthesizer sound.

The circuit is simple and construction is not at all critical. Parts values are pretty flexible too, so you can probably build it with parts on hand.

How it works.

IC1 and IC2 are common 741 type op amps. Using a 4136 and built three separate drums on one board, with IC2 acting as a mixer for the three drum sounds; however, the schematic in figure 1 shows the pinout for 741-type amps.

To mix in additional drums, feed the drum outputs into the inverting (-) input of IC2 through additional volume controls (R5) and 10k resistors (R3).
IC3 is one-sixth of a 4049 hex inverter, and is used as a voltage controlled resistor.

Note that power is not applied to the 4049. Remember too that this is a CMOS chip, so observe proper handling procedures.

Testing. Once the circuit is wired, set RI for minimum resistance and R7 for maximum resistance. Apply power and connect the output to an amplifier (the circuit will also drive high-sensitivity earphones directly): Turn up the volume with R5. Now set R9 to maximum and adjust R14 until the circuit oscillates; next, back off on R14 until the oscillation just stops.

Now press switch SI and experiment with the controls:
R9 controls the decay (length of the tone)
R1 controls the pitch
R7 control* the sweep rate, and
R5 controls the volume.

The range of the pitch control is a bit narrow and the sweep range suffers at lower pitch settings. If you want a different pitch range, experiment with Cl's value.

You can use any momentary switch for S1, ad example you could use a Remo practice drum pad (the kind with a real drum head on it) for SI. See figure 2.

Glued aluminum foil to the bottom of the drum head, and another piece of foil to a block inside the practice pad. Connect the switch wires to each piece of foil with a screw.
When the head is struck by a stick the pieces of foil contact each other, thus closing the "switch" and triggering the drum.

Although this circuit doesn't give touch sensitivity, noise, upward sweep option, LFO, or similar extras, the basic drum sound is as good as most analog commercial equivalents.

Parts List
Resistors (10%, 1/4 Watt except as noted)

RI 500 Ohm pot
R2-R4 10k
R5 10k audio or linear pot
R6 47k
R7 50k linear taper pot
R8 68k
R9 100k linear taper pot
R10-R12 100k
R13 270k
R14 500k trimpot
Capacitors
Cl 0.05 to 0.1 uF (see text)
C2-C3 0.1 uF mylar
C4 0.22 uF mylar
C5 2.2 uF electrolytic
C6 10 uF electrolytic
Semiconductors
D1-D3 1N914 or equivalent diode
ICI, IC2 741 op amp (see text)
IC3 4049 CMOS hex inverter


Vu dans ... https://synthr.fr/faites-le-vous-meme/modules/

Modular Mini Drum - circuit imprimé disponible

Voilà je désirais avoir quelques éléments de percussion sur mon modulaire sans mobiliser trop de filtre, j’ai donc étudié le marché de l’analogique connu : TR606, TR808, TR909, DR110 et ce que j’ai trouvé sur le net puis j’ai commencé à réaliser des essais, instruments par instruments et je suis arrivé à caser sur une carte format Europe 8 instruments qui ma foi ne sonnent pas trop mal.

Le principe de ces instruments est d’utiliser des filtres dit en « T ponté » qui oscillent dès la réception d’une impulsion et des VCA extrêmement simple à un transistor dont les principes sont donnés dans le service manuel de la TR808. Voir figures. L’intérêt de ces schémas est leur simplicité en nombre de composants et leur inconvénient est que lorsqu’on modifie un paramètre on joue à la foie sur la fréquence, la résonnance et donc le decay. Donc les appellations des potentiomètres sont en fait très approximative. De plus ils sont sensibles à l’énergie contenue dans l’impulsion de départ (donc amplitude et durée). Bref cela pour éviter VCO+VCF+EG +VCA, ces concepts on été retenus sur la quasi totalité des Drum Machines analogiques avant l’avènement de l’échantillonnage.

La carte réalisée ici ne comporte que les instruments avec sortie individuelle, un mix général et une entrée TRIG par instrument. Il y a un connecteur de type HE 10 qui permet d’envoyer les trig par une carte externe de pilotage ce que mon ami OZOE est en train de développer. Il y aura ainsi la possibilité d’avoir des rythmiques en mémoire à foison pour piloter cette carte. Chacun pourra faire son extension. L’esprit reste tout de même un module pour modulaire et non une Drum machine MIDI comme on en trouve aujourd’hui. L’idée étant de compléter une séquence, ou d’activer les trig par LFO. Que puis je vous dire de plus, que le circuit imprimé est réalisé de manière industrielle et que vous le trouverez dans la boutique pour la modique somme de 20€. Pour le reste schéma, implantation câblage nomenclature se trouvent ci dessous.

Un petit conseil à ceux qui se lanceront dans sa réalisation, câbler cette carte instrument par instrument sauf pour les trig qui peuvent être tous câblés au même moment. Ce sera plus facile à dépanner au cas où, car la carte est dense. Certain pourront même jouer avec les valeurs de résistance pour modifier les sonorités.

En ce qui concerne la petite logique utilisé pour le Clap, partant du trig issu du LM339, on génère 4 petites impulsions d’environ 10ms de période puis une dernière de 24 ms, cela permet un petit effet de réverbération pour le rendre plus réaliste.

Bonne réalisation, voir dans la zone téléchargement quelques vidéos.

Liens pour plus d’informations :

  • Schéma
  • Câblage
  • Implantation
  • Vue 3D
  • Exemple de Fav
  • Nomenclature

Pour acheter ce circuit cliquez ici


Générateurs en Pont de Wien

http://www.turneraudio.com.au/Wien-bridge-oscillator.html

Documentation sur le pont de Wein

wien7

wien_op

wien_fet

Sinegen

WIEN HEATHKIT AG8

Oscillateur pont de WIEN HP200A 1941

Oscillateur pont de WIEN Philips GM327

Oscillateur Pont de WIEN "EAGLE projets"

Generateur ULTRA LOW Distorsion"

Pont de WIEN Texas Instruments LM386"

1.5kHz-15kHz_Low_Dist_0.001percent_Osc

10Hz_to_100kHz_Sinus-Rect_Generator_OE1MSA

10Hz-1MHz_RC_Signal_Gen

15Hz_40kHz_Wienbridge_Signal_Gen_W6GXN

15Hz-to-1.5MHz_Wien-Bridge_Signal_Gen

Audio_Gen_50Hz-to-36kHz

Pure_Sine-Wave_Wien_Oscillator

Autres Générateurs en Pont de Wien

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

PW_ELEKTOR_203

Radio-Plans Octobre 1965

PW Radio-Plans n°130 1958

Radio-Constructeur n°109 1955

PW Elektor India

Pont_Wien_ELEKTOR_1976

PW_Transistors_RC_1964


Vu dans la TLR 1952


Toute L'électronique Octobre 1967


PW_ELEKTOR 303 1988 Pont de Wien


Operation explanation of the sine wave oscillator

Vu dans ... http://www.massmind.org/images/www/hobby_elec/e_ckt18_2.htm

Operation explanation
of the sine wave oscillator

Sine wave is what?
    The one to have shown the height which changes when moving the circumference in the time is the sine wave.

It returns to the original place when going around the circle.
At present, it uses the unit, the hertz (Hz), to show the frequency. It was using the word, the cycle per second, before as the unit which shows the frequency.
This shows the 1-second number of rotations.(The once is the 1 cycle) The many turns occur in the high frequency.
With the figure on the left, 0V [image] positive [image] 0V [image] negative [image] 0V is called the 1 cycle.

There is "a period" in the word which is related with the frequency. This is the time which the 1 cycle takes. It becomes the frequency reciprocal.
Period(T) = 1 / Frequency(F) and Frequency(F) = 1 / Period(T)
In case of Japan, the electricity to be using in the home is 50 Hz or 60 Hz. In case of 50 Hz, the 1-cycle sine wave occurs the 50 times for the 1 second. 60 Hz are the 60 times.
Because it is, the 1 period becomes 1/50 = 0.02 seconds (the 20 milliseconds). In case of 60 Hz, it is the 16.67 millisecond.

There is a way of making make the Lissajous as the way of understanding that the sine wave relates to the circle. In case of the sine wave which doesn't have the distortion, the Lissajous becomes the true circle.

Principle of the oscillator
    Have you brought the microphone close to the speaker and have made an unpleasant sound? This is the phenomenon, the HOWLING.

As for some oscillators, the principle which is the same as the howling is used. It is the way of returning the output of the amplifier to the input.

    The feedback circuit of the oscillator has the following role mainly.
It fixes the oscillation frequency.
 | It controls to oscillate at the specific frequency. It returns only the specific frequency signal to the input.
It controls the input level which is necessary to oscillate.
 | The amplifier becomes the saturation state when the signal which returns to the amplifier through the feedback circuit is too big and the beautiful signal doesn't come out.
It adjusts the phase of the frequency which is necessary to oscillate.
 | The phase means the position of the signal. At the electronic circuits, phase of the input and the output depends on capacitors, the coils, the amplifier itself. Because it is, it doesn't oscillate when not adjusting the phase of the input signal.
There is a circuit to be making have the role of the oscillation frequency's, output's not changing by the temperature in addition to above-mentioned, too.

Principle of the Wien bridge oscillation circuit
    The basic composition

The figure on the left is the basic form of the Wien bridge oscillator which used the operational amplifier.
The part which is composed of C1, C2, R1, R2 becomes the positive feedback circuit of the operational amplifier. With it, the operational amplifier works in the oscillation. Also, the circuit sets the oscillation frequency in the damping time constant of the CR.
On the other hand, the circuit of R3, R4 controls the mu factor of the operational amplifier.
This oscillator begins the oscillation when it makes the mu factor equal to or more than 3. At less than 3, it doesn't oscillate. The beautiful signal doesn't come out by output's being saturated when the mu factor is more than 3.
The mu factor must be controlled to 3.
Because it is, only this basic circuit can not use for the practical use.

    Where is the bridge?

The part of the circuit diagram becomes the figure on the left when it changes the position.
The balance condition of this bridge becomes the oscillation condition.
The oscillation frequency can be calculated by the following formula.

In case of C=C1=C2, R=R1=R2, the formula becomes the following.

The condition of the operational amplifier which is necessary to do the stable oscillation is the mu factor=3.
It becomes the following when finding the relation between R3 and R4 from the mu factor.( Noninverting Gain amplification )
3=(1+R4/R3) That is, the condition of R4=2xR3 is necessary.

    The principle of the frequency decision by the CR circuit

The circuit composition of the positive feedback circuit becomes like the left.
You find that the composition of this circuit is composed of the low pass filter and the high pass filter.
The low pass filter make pass the low frequency signal and blocks the high frequency signal. The signal flows through the grounding with C1 and the output voltage becomes low when the frequency becomes high.
Oppositely, the high pass filter make pass the high frequency signal and blocks the low frequency signal. It is because the signal which passes C2 becomes little when the frequency becomes low.

    When combining these two, the signal in the area that the characteristic is the overlapping frequency gets to pass. Such a filter is called the band pass filter.
The oscillation frequency of the Wien bridge is fixed by this characteristic.

Amplitude control of the Wien bridge oscillation
    With the Wien bridge oscillation circuit which used the operational amplifier, the most difficult part is the amplitude control circuit.
    There are various circuits from the simple one to the complicated one.
    The circuit to be using this time changes the resistance value of the Field Effect-type Transistor(FET) at the d.c. voltage which rectified the oscillation output in the full wave.

    The operation principle of the field effect-type transistor (FET)

The figure on the left shows the operation principle of the Junction-type FET on the N-channel.
The electric current of the controlled circuit flows from the drain terminal of the semiconductor on the N-channel to the source terminal. The semiconductor on the P channel is used for the gate. When the negative voltage is gained by the gate terminal, the electron on the N-channel(it has the negative electric charge) repels and can make the depletion region to be the junction part with the P channel. Because the electron doesn't exist in the depletion region, the electric current doesn't flow. When the voltage which is gained by the gate isn't high, the depletion region is small and the flow of the drain electric current isn't too much influenced.

When the voltage which is gained by the gate becomes high, the depletion region gets widely.
Therefore, as for the drain electric current, the place to flow through becomes narrow and the electric current decreases.
Because it is, by changing the voltage to add to the gate, the drain electric current can be controlled.

The big characteristic of the FET is the fact that the electric current doesn't flow through the gate.
It is possible to control only at the voltage of the gate. The electric power(current X voltage) isn't necessary in spite of the control. This operation resembles the operation of the tube well.

    The amplitude control circuit

The circuit to compose in IC(2/2) is the full-wave rectification circuit.
When the output voltage of the oscillator is the positive voltage, the signal spreads through the negative input terminal of IC(2/2) through D2. At the positive input terminal, it is prevented by D3 and the signal doesn't spread.
At this time, IC(2/2) does the inverting gain amplification. Because it is, the output of IC(2/2) becomes the negative voltage.

Next, when the output voltage of the oscillator is the negative voltage, the signal spreads through the positive input terminal of IC(2/2) through D3. At the negative input terminal, it is prevented by D2 and the signal doesn't spread.
At this time, IC(2/2) does the noninverting gain amplification. Because it is, the output of IC(2/2) becomes the negative voltage too.
In this way, the voltage which is always negative is output by IC(2/2).
Because the output of IC(2/2) is the ripple current, there is a smoothing in R7 and C4 through D1 and it makes the total direct current.
The d.c. voltage by the full-wave rectification circuit changes in the change of the output voltage of IC(1/2).

The d.c. voltage which was made by the full-wave rectification circuit is added to the gate of TR1(FET) through R6.
The negative voltage which is gained by the gate of TR1 becomes high when the output signal of IC(1/2) becomes big. Then, the resistance value between the drain and the source of TR1, too, becomes high. The mu factor of IC(1/2) falls when the resistance value of R3 and TR1 which is stored in series becomes high. The output of IC(1/2) is restrained by it.
R5 and C3 improve the frequency characteristic of TR1. It makes the distortion of the oscillation signal by TR1 little.
Without frequency improvement With frequency improvement

By above operation, the oscillation of IC(1/2) does the stable operation. Such operation is called AGC(Automatic Gain Control).

Data sheet for TL082

Data sheet for 2SK30


Wien-Bridge oscillator has simplified frequency control

Vu dans ... http://www.zen22142.zen.co.uk/Design/wien_osc/Wien-Bridge%20Oscillator.htm

Wien-Bridge Oscillator has
Simplified Frequency Control
Circuit : Ramon Vargas Patron
Email : rvargas@inictel.gob.pe
Web : Ramon's own website

Wien-Bridge Oscillator has Simplified Frequency Control
High-quality audio signal generators make extensive use of the Wien-Bridge oscillator as a basic building block. The number of frequency decades covered by these instruments is variable, three being the minimum, and they all cover at least the audible spectrum ranging from 20 Hz to 20 kHz. In addition, frequency can be continuously varied over each decade.

A Wien-Bridge oscillator designed for one decade of continuous frequency control makes use of a two-gang variable capacitor or a two-section variable resistor for frequency adjustment (fig.1). This is the usual approach. However, these are expensive precision components, as accurate tracking between sections is necessary.

In this article, a modified version of the classical circuit that uses a single low-cost variable resistor for frequency control will be described.

Wien-Bridge Oscillator Basics
The typical Wien-Bridge oscillator comprises a differential amplifier having a large open-loop gain (U1 in fig. 1), an R-C network for frequency determination and a non-linear resistive network for amplitude stabilisation. The transfer function of the frequency-sensitive network is:

for a signal fed back from the amplifiers output to the non-inverting input. The same signal is fed back from the output to the inverting input, the transfer function for the non-linear network being:

Loop-gain at unity for oscillations to start requires that:

...(1)

where w o is the oscillations radian-frequency and Ad is the differential amplifiers open-loop gain. The above equation is satisfied at:

...(2)

when:

...(3)

this is, when:

...(4)

D is given by:

and is in fact a very small number. So, for all practical purposes R1 equals 2RNL at the end of the stabilisation period.

Usually, RNL is a low-power incandescent lamp. Commonly found specifications for this device are 24V-50mA and 12V-60mA, when split power supplies of +12V and 12V are used for the circuit.

The amplitude of the low-distortion output sine-wave can be adjusted varying R1. RNL automatically adjusts its own value so that eq.(4) is always satisfied. Due to this dynamic action good amplitude and frequency stabilities are attained.

Following is a graph showing the static V-R curve for a Philips 24V-50mA incandescent lamp. The data for this curve was obtained measuring the DC current through the lamp with a set of DC voltages applied and computing R as R = V / I.

For a particular oscillator peak output voltage Vo, the lamps voltage drop is calculated as Vo / 3, according to eq. (3). This data is entered to the V-axis on the above graph and a corresponding lamp resistance R is obtained. Equating RNL to this value yields the required R1 [ eq. (4)] .

The thermal response of the lamp imposes a limit on the minimum frequency of oscillation if total harmonic distortion (THD) is to be kept below 1%. For this type of lamp the limit is around 20 Hz. Low-distortion operation at lower frequencies can be achieved through the series-connection of two lamps. However, longer stabilisation periods should be expected.

The New Approach
Consider the frequency-sensitive network of fig. 2. We would like to use this network for frequency determination in the Wien-Bridge oscillator. Its transfer function is:

...(5)

The oscillations frequency is now given by:

...(6)

Eq. (5) reduces at w= wo to:

...(7)

Again, for oscillations to start eq. (1) must be satisfied. Then:

...(8)

Now, if we let k2 be a fixed quantity, from eq. (6) we may infer that frequency can be varied over one decade if k1 changes in a 100:1 ratio. Attempts should be made though to maintain T+(jwo) constant over the tuning range. This will minimize amplitude variations when the oscillators frequency is changed. T+(jwo) will be approximately constant if:

or if:

Letting k1min = 10 the result can be easily achieved. Then:

...(9)

for any frequency setting.

Table I compares exact and approximate values for T+(jωo), as calculated by eqs. (7) and (9).

TABLE I
 | T+(jωo)
k2 | k1 = 1000 | k1 = 10 | eq. (9)
0.25 | 0.7993 | 0.7407 | 0.8000
0.5 | 0.6662 | 0.6250 | 0.6666
1 | 0.4997 | 0.4762 | 0.5000
2 | 0.3332 | 0.3226 | 0.3333
10 | 0.0909 | 0.0901 | 0.0909

Because the lamp has a positive temperature coefficient, THD, amplitude and frequency stabilities are all temperature dependent. So, some effort has to be spent in figuring out how to minimize room-temperature influences on the circuit. Smaller values for k2 yield higher working voltages and operating temperatures for the lamp, thus reducing external temperature effects. However, minimal variation of T+(jwo) over one decade requires larger values for k2. As a compromise, k2 = 2 or k2 = 3 may be chosen.

If an OP-AMP is selected as the active device, it should be of the low-drift type, for better frequency stability.

Design Example
Fig. 3 shows a Wien-Bridge oscillator with the modification discussed. The oscillator can be tuned from 1 kHz to 10 kHz adjusting RP. The LF411CN is a JFET-input low-drift type OP-AMP with a typical slew-rate of 15V/us and a typical GBW product of 4 MHz. The NPN and PNP transistors boost the OP-AMPs output, reducing the signal current drawn from the IC. This effectively contributes to minimize the circuits warm-up time.

In this design example, R = 470 ohms and k1R can be varied between 4.7 kohms and 470 kohms (k1min = 10, k1max = 1000). A value of k2 = 2 was selected. The oscillator delivers a peak value of 6 Volts or 4.24 Volts RMS. Accordingly, the voltage drop across the lamp is 6/(k2+1) = 2 Volts peak. Entering this figure into the lamps V-R graph yields a value of 167 ohms for RNL. Then, R1 = 2RNL = 334 ohms. From eq. (6), with fo = 1 kHz, R = 470 ohms, k1 = 1000 and k2 = 2, a value of 7.57 nF is obtained for C. Accordingly, k2C = 15.14 nF. Good-quality capacitors must be selected for C and k2C for good frequency stability and low THD (some capacitors are very non-linear and temperature-unstable, such as the common low-cost ceramic types. Mylar and NPOs are a good choice).

Ramon Vargas Patron
rvargas@inictel.gob.pe
Lima-Peru, South America
May 16th 2004

Return to Circuit Design


4QD-TEC: Audio signal (sinewave) generators

Vu dans ... http://www.4qdtec.com/singen.html

4QD-TEC: Electronics Circuits Reference Archive
4QD-TEC: Audio signal (sinewave) generators

There are dozens, probably hundreds of circuits for audio sinewave generators but certain 'old chestnuts' are still favourite and the basic circuits haven't changed significantly since they were built with valves.

The Wien Circuit

There is one 'favourite' circuit for making an audio oscillator the Wien bridge. It is a bridge, i.e. a circuit having four 'legs'. The circuit below shows the basic idea.

The Rx, 2Rx feedback divider establishes a gain of 3 in the op amp. Positive feedback is via the Wien network, R and C (two of each). The characteristic of this network is that the network's output (at the +ve input to the opamp) has a maximum at a frequency Fo, as shown on the diagram. The mathematical analysis of any network tends to simplify itself if resistors/capacitors are related to each other by some simple ratio: with the Wien network the maths come out best if the two resistors are equal and so are the two capacitors! Hence the simple formula for Fo.

So, for 1kHz put, 1000 into the formula in place of Fo, choose a sensible value for R - let's chose 100K. swap the formula round to read C= 1/(2 x PI x 1000 x 100,000) and C works out to be 1.59nF: This is not a particularly sensible value for a capacitor but if we increase the capacitor we need to decrease the resistor and vice versa, so we can now chose a sensible capacitor: how about 4n7?

Putting 4n7 in the formula and rearranging gives R=1/(2 x PI x 1000 x 4.7 x 10-9). We get 33.9K for the resistors. At this point you need to decide how accurately you want 1kHz. Most Wien bridge circuits tend to be variable frequency, so we simply calibrate the scale to suit!

Because the Wien circuit attenuates the input by 3 times, we need a gain of 3 in the amplifier to make it oscillate. This was why we chose the 2Rx/Rx negative feedback.

There is one slight problem: is the feedback resistors define a gain of slightly less than 3, then the circuit won't oscillate. It the gain is slightly more than 3 the circuit will oscillate and the amplitude will only be determined by the IC's output hitting the supply rails and clipping - not a sinusoidal waveform. So how do we keep the gain at exactly the right level to just sustain a sinewave? What we need is some component which has a resistance proportional to the signal level: if the level increases, so does the resistance, putting down the gain. Similarly if the output drops, the gain will increase, maintaining stability. Fortunately there are several ways of doing this.

A Practical Wien Oscillator

The second circuit is a practical implementation of a Wien oscillator but in this the Wien network is inverted. It is the 'wrong way up' and in the negative feedback path. Positive feedback is applied via the 500R preset to make it oscillate. And there's a nice incandescent light bulb to show that it's working....

You see, light bulbs get hot and the resistance of a piece of wire goes up as it gets hot. A bulb filament gets very hot so its resistance can change quite a lot (typically the hot resistance can be 10 times the cold resistance) and the higher the voltage, the higher the resistance, so this is the stabilizing element that we require! Quite a simple circuit which will give about 1.5v rms output with a distortion of about 0.3%. Not excellent performance but certainly useful - and such a simple circuit. Of course you can use an op-amp to do this - as long as it can give enough current to drive the bulb. But the circuit with 2 transistors is actually simpler.

A low distortion Audio Signal Generator

The next circuit (above) is a better implementation of the Wien circuit: this uses the Wien in the normal fashion, in the positive feedback path and with negative feedback to maintain stability. The device marked Th1 is a glass bead type thermistor: some of these thermistors consist of a bead in an evacuated glass envelope and they are designed specifically for amplitude stabilization in such circuits. If necessary the 100R can be altered to suit various thermistors (and to trim the amplitude).

The 6 transistor circuit is, in effect, an op-amp and there is no reason you can't simply use an op-amp. This circuit pre-dates op-amps but the principles haven't changed.

A dual ganged 100K (logarithmic) pot is used to vary the frequency and a 2 pole 6 way (rotary) switch is used to switch bands. With the values shown there is a useful overlap at the ends of each band. With the pot set at around 16K the 10n gives 1kHz so the 'center' frequencies with the values shown are 100hZ, 300Hz, 1kh, 3kHz, 10kHz and 30kHz.

You could increase the range at the bottom with another capacitor (1µ) but settling time will be very long. Similarly you could add another range at the top using (100pf) but the waveform will not be very good: the high frequency end is restricted by the 270pF capacitor which is present to ensure stability: with as good layout and modern transistors you could reduce this capacitor significantly to increase high frequency performance.

A circuit such as this can give extremely low distortion if properly built. The distortion level will depend on the gain of the op-amp used and on the performance of the thermistor, especially at low frequencies. For audio test purposes, low hum and noise are also important so low noise components and a good power supply are essential.

The Twin-T Network

The next circuit doesn't use a Wien network but a circuit called a twin-T network so I will introduce the network first. The 'standard' twin T is as in the diagram below.

As with the Wien there is a relationship in the circuit that causes a simplification of the formula - the arms of the T should have equal values and the capacitor in the foot should be twice as large as the arms. The foot's resistor should be half that of the arms. With these ratios the Twin T is a notch filter which passes everything except for a notch at the centre frequency as shown in the formula. Note that this formula is the same as for the Wien but is shown in a slightly different form. So - now to

A Practical Twin-T Oscillator

Perhaps the first thing that will strike you (if you have met the twin-T before) is that the input to the twin-T (from the bulb) is actually fed into the foot of the network and output is (as you might expect) from one arm (into the base of the transistor) but the other arm is earthed. Now hold on a minute: an emitter follower has no voltage gain and surely you've been taught that an R-C oscillator must have voltage gain? Well this one works and has no voltage gain (of course it does have current gain).

The first time I met this circuit, I puzzled a little. Then I sort of 're-drew' the circuit in my head. Imagine looking at it with a scope, and the scope's earth on the bottom of the bulb. Now (for the a.c. signal) the 0v line is connected to the collector of the transistor. So one arm of the T is fed from the collector and the other arm feeds the base, with the foot going to the new earth. The circuit is effectively a standard Twin T, but with power supplies fed unusually to confuse things. Quite a few unusual circuits look better if you 're-engineer' them.

Afterword
One correspondent has pointed out that

The circuit actually does have voltage gain. If you analyze just the resistor-capacitor twin-T network (plus the 1 nF to the 12v supply), with the input taken from the bottom of the bulb, and the output taken at the base of the first emitter follower, the gain is 1.08845 at a frequency of 135.548 Hz, which is the frequency where the phase shift through the network is zero.

See "Synthesis of Passive RC Networks with Gains Greater than Unity", Proceedings of the IRE, July, 1951, p 833.

Gated RC Phaseshift Oscillator

The last circuit is a simpler R-C phase shift oscillator, but this is one with a difference: it is gated, i.e. it can be turned on by an input signal. Earth the input and the oscillator stops, connect it to 5v and the oscillator starts. The oscillator will always start in the same fashion, with a positive edge

Page Information

© 1996-2011 4QD-TEC
Page's Author: Richard Torrens


Multivibrator mit ECC 81

Vu dans ... http://www.jogis-roehrenbude.de/Bastelschule/Multivibrator.htm

Multivibrator mit der Röhre ECC 81

Beim Empfängerbau erweisen sich eine Tonfrequenz- und eine Hochfrequenzquelle als sehr nützlich. Für unsere Zwecke ist der Multivibrator wegen des einfachen und billigen Aufbaues besonders praktisch.
Die nachfolgend vorgestellte Multivibrator-Schaltung mit der Röhre ECC 81 verzichtet auf Schwingkreise und verwendet Kondensatoren und Widerstände als frequenzbestimmende Glieder.

Die Schwingungen sind nicht sinusförmig, sondern sehr oberwellreich. Bemißt man C 1, C 2 und R 1, R 2 so, daß die Grundrequenz in den Tonfrequenzbereich fällt, so entstehen Oberwellen bis etwa 20 MHz. Jede Oberwelle ist gewissermaßen mit der Grundfrequenz moduliert. Im Empfangsgerät können wir daher ein gleichmäßiges Senderspektrum aufnehmen. Es eignet sich für die Überprüfung von AM-Empfängern im Hf- und Tonfrequenzteil und auch für den Abgleich von Geradeausempfängern.
Bei den im Schaltbild angegebenen Widerstands- und Kondensatorwerten erhalten wir eine Grundfrequenz von etwa 600 Hz. Der Außenwiderstand des zweiten Triodensystemes ist veränderlich (P 1, 5 kW) und arbeitet als Lautstärkeregler.
Im Netzteil mit dem Kleintransformator N 20/1 von Engel (1 x 250 V, 15 mV und 6,3 V, 0,8 A) dient ein Einweg-Selengleichrichter zur Gleichrichtung. Die Anodenstromsiebkette besteht aus dem Doppel-Elektrolytkondensator 2 x 8 µF (C 4, C 5), und dem Siebwiderstand R 4.
Das folgende Bild zeigt die praktische Bauform des Multivibrators.

Das Chassis fertigen wir aus Aluplatte 140 x 120 x 1 mm, deren Seitenteile wir gemäß dem folgenden Bild so abbiegen, daß eine Montageplatte von 120 x 90 mm zur Verfügung steht. Auf dieser sind Netztransformator, Selengleichrichter, Doppelelektrolytkondensator und Röhre ECC 81 befestigt.

An der Vorderseite ist die Doppelbüchse B herausgeführt. Potentiometer P 1 mit Skala, Netzschalter und Skalenlämpchen befinden sich an der Frontplatte. Diese wird aus einem 120 x 90 mm großen Alublech gefertigt und an den beiden Längsseiten jeweils um 10 mm abgebogen. Die entstehenden schmalen Blechstreifen dienen zur Frontplattenbefestigung auf dem Montagechassis und zur Verschraubung mit dem Gehäuse.

Unterhalb der Montageplatte ist eine Hartpapierplatte (110 x 65 x 1 mm) mit vier Nietlötösen für die Befestigung der Kondensatoren, Widerstände und der Sicherung eingebaut. Die folgende Skizze zeigt Einzelheiten der Verdrahtung .

Diesen kleinen Multivibrator sollte sich jeder bauen, der öfters mit der Konstruktion verschiedener Geräte beschäftigt ist. An den Ausgangsbuchsen B 1 kann z. B. eine Tonfrequenz für die Prüfung von Verstärkern, Lautsprechern, Leitungen usw. entnommen werden.
Das Frequenzgemisch liefert aber auch Hochfrequenz. Führt man diese der Antennenbuchse eines Rundfunkempfängers zu, so arbeitet der Multivibrator als Prüfsender.

Viel Spass beim Nachbau ..

Zurück zur Hauptseite


Art's Theremin Page: Twin-T Audio Sine Wave Oscillator

Vu dans ... https://www.theremin.us/Circuit_Library/twin_t_oscillator.html

Twin-T Audio Sine Wave Oscillator

The circuit illustrated produces a clean sine wave signal ideal for audio testing, or wherever a good-quality sine voltage source is required. It uses one integrated circuit which is a widely-available dual operational amplifier, the Texas Instruments TL072CP. The values shown provide an output frequency of about 1000 Hertz. This frequency may be varied over a wide range, using the equation shown in the schematic. Frequency is almost exclusively determined by the twin-T network in U1A's feedback loop, provided that the gain-bandwidth product and slew rate specifications for the op amp are sufficiently high. For frequencies exceeding 10kHz, an faster op-amp in the U1A position is recommended.

The oscillator's frequency-selective twin-T network, C1, C2, C3, R1, R2, and R3, is in the negative feedback path of the operational amplifier. U1A's positive-input to output transfer function is a notch filter with a frequency and depth determined by those components' values, with zero degrees of phase shift at the notch frequency. The twin-T network characteristics are defined by these equations:

The positive feedback required for oscillation is provided by R4. Transistor Q1 is part of an automatic gain control (AGC) servo that regulates U1A's positive feedback to keep the sine wave output at a consistent amplitude. The circuit will oscillate at the notch frequency when Q1's emitter-to-collector resistance (Rec) is:

(R4 + Rec) / Rec (expressed in dB) = U1A's open-loop gain (expressed in dB) - the magnitude of the notch depth (expressed in dB)

U1B and its associated components complete the servo. The series-connected diodes provide negative peak-level detection of the sine wave voltage and also determine the amplitude of the output. Q1 is operated close to maximum conduction, so the small voltage from its emitter to collector contributes negligible distortion to the sine wave. The 0.1uF integrating capacitor in U1B's feedback path was chosen to provide adequate AGC-loop stability for the selected oscillation frequency. The 10K resistor in parallel with Q1 provides start-up.

The ratios of the resistors and capacitors in the twin-T network must be accurate to ensure oscillation, and at the desired frequency. For that reason, ±1% components are indicated. R1, R2, and R3 should be metal film, and C1, C2 and C3 should be C0G ceramic or mica (best), or polystyrene (good). Polyester capacitors may be used for economy if large C1, C2, and C3 values, such as those exceeding 10nF, are required.

A capacitor ratio of 2:1 is most conveniently obtained with the standard values that have that nominal relationship, e.g., 750pF and 1500pF (as shown), 1000pF and 2000pF, 1100pF and 2200pF, 1500pF and 3000pF, and 1800 and 3600pF. Alternatively, four equivalent capacitors may be used, with two of them paralleled to make C1. The same technique is also applicable for the three resistors, especially when an exact 2:1 ratio of resistance values is not available.

Interestingly, Q1's emitter and collector may be interchanged without any significant effect on the circuit's performance, although convention dictates that the emitter is biased negatively with respect to the base. If the two diodes are reversed, then Q1 may be a PNP transistor such as type 2N3906.

The oscillator's amplitude, as well as frequency, is essentially independent of the power supply voltage. An output amplitude of 1.6 volts peak-to-peak was chosen to accommodate power supply voltages as low as 6 volts. Replacing the TL072CP with a rail-to-rail dual operational amplifier such as the Analog Devices type AD823AN will permit operation from even-lower supply voltages, such as 4 volts. The oscillator will operate conveniently from a single 9-volt battery, and consumes less than 5 milliamperes of current when using the TL072CP. The 470 ohm resistor in the output prevents instabilities from capacitive loads such as long cables, and the 1uF capacitor removes the DC offset at U1A. The output's 100K resistor discharges the 1uF capacitor to prevent voltage transients when connecting a load.

The author gratefully acknowledges Rick Hansen for providing an analysis of this circuit's operation.

April 12, 2001

Text and images ©2001, 2018 by Arthur Harrison

Back to the Circuit Library Index

Back to the Opening Page of Art's Theremin Page


Wien-bridge-oscillator

Vu dans ... http://www.turneraudio.com.au/Wien-bridge-oscillator.html

Wien Bridge Oscillator. August 2013.

This page describes a switched frequency Wien Bridge oscillator with j-fet Vo stabilization,
Buffered Rout = 55 ohms, peak Vo max = +/- 5.1V for both sine waves and square waves,
switched attenuator for 4 levels at 10dB steps below 0dB, and with logarithmic variable
Vo. There are 6 ranges between 1Hz and 1MHz, with an F decade each. There
are 4 images,
Fig 1. Sheet 1, basic block diagram schematic of WB oscillator with details of switches.
Fig 2. Sheet 2, full schematic details of discrete bjt amp for oscillator, and attenuators, and buffer output stage.
Fig 3. Explanatory diagram of basic Wien Bridge network with two equal value R and two equal value C.
Fig 4. Schematic of Schmitt Trigger sine to square wave converter with 2 discrete bjts.

I was cleaning up my workshop when I discovered I had been given an old BWD Electronics
141A audio oscillator which had many problems. I delayed my life for 2 weeks while I rebuilt
the darn thing.
It was made in Australia in the 1960s or 70s and designed to be used with batteries if need be.
Therefore contained the bare minimum of current needing devices and used the bare minimum
of other parts. Current and parts cost money, and bean-counters and CEOs hate any expenses,
and BWD had no ambitions to seriously compete with other expensive brands like HP at the time.
The 141A unit was "budget test gear" and since it offered nothing special, it is not disrespectful
to dismiss ideas used by the original designers and to consider the unit to be completely
expendable in pursuit of better operation, while keeping the box, and the few parts inside worth
actually re-cycling.
I have never ever needed battery operated test gear.

The only way to improve the performance was to revise the circuit inside the small box completely.
After measuring and making an intelligent appraisal of the existing usability, and having to give the unit
a 1 out of 10 score, I removed all discrete bjt + R + C and tracks from the circuit board, except 6 pairs
of plastic and styrene C and tracks around the interactive press button F range switches.

The 15k wire wound reverse log dual gang Compton pot for varying was intermittent and thus faulty
and junked. It is impossible to dismantle it and clean it, or inspect its internals. Switched resistors
were used instead of a pot for F control.
I removed the entire PSU which was not original, but a bodgy replacement by someone.
The new PT and R&C parts of PSU are in a box screwed to the steel plate rear panel.
I put in a new amp on an additional board for the Wien bridge oscillator.
Another board has the j-fet as variable NFB resistance needed to control output level.
I built a new Schmitt Trigger square wave circuit where the old one was.
Another small board with a complementary pair of darlington connected bjts connected as a PP emitter
follower buffer preserves the HF content of all output signals and reduces Rout to 55 ohms for all
levels of operation. I re-designed the output attenuator switch to give 0dB, -10dB, -20dB -30dB
levels which is more usable to me than the original. I replaced the variable output level pot.

My new circuits contain more parts than the overly simplistic previous original had, but it work better,
and there is now no DC offset at the output, and peak voltage for sine waves and square waves is 5.1V,
and the rise time for square waves excellent, 104V/uS. There still a few trimpots to adjust, and 3 trimC but
that is inevitable with much analog test gear where best performance depends on very small changes
to R and C values.
There are 3 schematics :-
Fig 1 shows the switched R & C positive FB network and the simplified amp schematic with output attenuator
and the negative FB network with j-fet to vary the amount of NFB.
Fig 2 shows the full details of the amp using discrete j-fets and bjts which gave wider BW than most common op-amps.
Fig 3 Gives basic properties of the Wien Bridge network.
Fig 4 shows the Schmitt Trigger square wave schematic.

Fig 1.

The Fig 1 schematic took me many hours to design and construct and test and adjust and revise before
I got flawless operation over the six F ranges covering 1Hz to 1MHz . The original BWD 141A Comptom pot
was replaced with a 1950 dual wafer 12 position break-before-make ( BBM ) switch taken from a defunct tube
tester I was given which was quite beyond repair. I found the amplitude bounced badly at first with this
switch so I converted it to make-before-break ( MBB ). It required careful metal work with 2mm x 3mm brass
plates and a steady hand with soldering iron and Dremel to clean up where needed, with two pairs of reading glasses.
This reduced the trace bounce on the oscilloscope.

If you build this, RS components sell suitable 40mm dia wafer type switches with MBB with 12 positions and
1 pole per wafer. I arranged the resistance combinations "R comb" hanging off the large lugs of the old rugged switch.

Although I show rotary switches for capacitors the original press button spring loaded interactive switches have been
retained and the action is so fast that little trace bounce occurs from high transient amp voltages at amp Vo.

The much more detailed schematic of the oscillator amp, buffered output etc and PSU is here :-
Fig 2.

The original BWD 141A used an ITT P54 thermistor which is a low wattage type of 50k cold R and minimum of maybe100r.
It was used where the Vo was 2.5Vrms, and thus 1.66Vrms was across the thermistor and this slightly heated it to reduce its
resistance to approximately 2,000 ohms. It worked well except that the Vo bounced crazily. It was used where the R12 2k7
above is used between oscillator amp Vo and NFB input port.
The principle with P54 is that If Vo rises, thermistor gets hotter, reduces its R, and increases NFB thus reducing Vo
until an equilibrium is achieved after the yo-yo of Vo settles down. THD was at least less than 0.1%.

I didn't want to rely on getting a replacement P54 in future. No modern thermistors seem designed to work to give a
sufficient temperature rise to cause enough useful resistance change. All mainly seem designed to change their resistance
usefully as a result of an external change in temperature. So modern thermistors are useless as substitutes for P54.

In the case of the Wien bridge oscillator, we want the thermistor ( or lamp globe ) to operate at a near constant T
well above room T and to vary its R due to minute changes to power and heat generated by Vac or Vdc across the
"element" or tiny glass coated thermistor or tungsten lamp filament within a glass tube. But lamps are very prone to Vo
bounce when switching anything, because like thermistors, some transient high current causes a delayed rise in or fall
or resistance because temp change is not instant. Therefore, with temperature dependent R there is an unwanted time
constant that can cause LF amplitude modulation of the Vo signal.

So, I changed the NFB circuit to use a j-fet and rectifier circuit to produce a negative gate bias of between about -0.8V
and -1.1V.
The negative bias voltage for j-fet gate begins to be generated when Vo = exceeds 3.2V peak. The 8 x 1N914 do
not begin conducting until their forward voltage = 0.4V each, or 3.2V across all. The turn on voltage of a silicon
diode is not linear, and the forward voltage across an Si diode does not reach a max of about 0.7V until the max
allowable rated I flows.

The series diode action was found to be a smoother than trying to use a low voltage zener and series 1 x 1N914.
When gate bias = 0Vdc, the j-fet has minimum Rd = 180 ohms approx. This then makes ß a lot less than 0.333 so that
much less FB is present and oscillations start and increase Vo very quickly. But as Vo increase, gate bias becomes
more negative and j-fet Rd increases which increases ß so the NFB increases thus preventing an increase in Vo
when the NFB applied to Q2 gate is very nearly the same amplitude to PFB signal at Q1 gate.
Equilibrium is reached and oscillations and "magically", you get the same Vo amplitude for all F between 1Hz and 1MHz.
The j-fet characteristic curves do not describe their properties fully but for each value of negative gate bias the
"diode" resistance line with high line slope near vertical id axis varies with gate bias voltage. What isn't shown is that
the Rd operates even if the applied voltage at drain goes negative below the source voltage.
The amount of current change in Rd across the Rd "diode resistance" has to be kept small because the diode
R line on curves is not straight, and rolls over to a virtually flat high value R line because above about 2Vds,
the Rd maybe thousands of ohms. If we have Vo at 3.66Vac, then there is about 1.22Vac at both NFB and PFB
ports of the amp. In fact, the amp has open loop gain at 1kHz = 40,000 approx, and PFB voltage is only 0.09mV
above the NFB voltage. The gate to gate voltage cannot easily be measured.

The ideal region of operation for j-fet is where Rd = 300r approx. If I have R12 = 2,700r, and ß = 0.33,
then the whole lower R of the FB network must be 1/2 x 2,700r = 1,350 ohms.
The total R of both R = 1.35k + 2k7 = 4.05k, and if Vo = 3.66V, then Iac = 0.903mA.
Therefore if Rd = 300r, then Vd = 0.271Vac, not much you may say, but little things have great and fundamental
importance. Therefore the VR1 1k pot plus R6 470r must equal 1,350r - 300r = 880r so pot is set for 880r - 470r
= 410r. Because the R&C values used in the Wien network cannot be accurate enough to demand ß always
exactly equal 0.33, and because of other slight variables in the circuit, using a pot for NFB adjustment is
imperative.

If Vo goes higher than 3.66Vac, ß would rise above 0.333, and oscillations would stop. To gain stable equilibrium
and thus stable Vo there must the pot VR1 1k0 to give some fine adjustment of NFB so that oscillations do not dither
and bounce, or have too much THD. The VR1 pot controls Vo across a small Vo range. If pot resistance is set high,
oscillations to stop and start and "dither about", but THD is low. If pot R is too low then you get very stable Vo but
high THD, easily exceeding 3% mainly 2H and seen in the CRO as you twiddle the trim pot with a screw driver.
Between the two extremes there is a sweet spot where action is good, and THD < 0.5%, and the production level of
gate bias with diodes must be just right to get the sweet spot.

To further reduce bouncing of the Vo level when switches are used, the Vo has a voltage clamp using 5.1 zeners and
1N4007 seen in Fig 2 below. During switching, the oscillations try to change momentarily to higher voltage transient
bursts of other F and as square waves. The zener+diode clamp stops Vo exceeding about 5.7V which is enough
to prevent most Vo bounce. The amp I have uses +/-20V rails and transient Vo peak V can be up to +/- 12V.
The circuit must not generate excessive gate bias quickly which then subsides much too slowly to allow
oscillations to continue. All operations MUST be free of delays due to troubles with signal bounce and intermittent
oscillations, or delays between stopped and re-starting.

The major troubles you never see mentioned or quantified in 99% of online information about WB oscillators are
the issues of stability when changing F, and the distortion generated by the darn little j-fet.
Now if you look closely to my above Fig 2 you will see I have a local shunt NFB network used between drain and gate
using R8, C8, R9. At above 1Hz, the ß = 0.5, and so 1/2 of whatever Vd exists is applied to the gate, so any THD
generated by the j-fet is half applied to the gate, thus it tends to be amplified to reduce itself. Now the circuit works
without R8, C8, R9, and typical THD will be 2%, mainly 2H, because the naked Rd without NFB is not a linear
resistance but one which generates up to 10% 2H right at the drain. Part of this feeds into the NFB port and makes
the maybe 2% of 2H at Vo.

Now you may think the use of R8, C8, R9 changes the ß but they make negligible difference to the range of values
wanted for Rd because that range is between about 200r and 1k0, and the loading effect is negligible.
The R8 and R9 are 10k each, and at very low F where C11, C12 are high Z, the value of R17 needs to be about10k
to prevent excessive FB at LF which makes LF stability very bad because you have a high open loop gain amp
also involved and, where possible, shit happens that you cannot forecast. I had R12 = 100k at first and LF stability
was terrible, but all calmed down when I made R12 = 10k. But then you need to have sufficiently long time constants
for oscillation down to 1Hz so C11 had to be 220uF. C8, also needed to be 220uF.
The other needed thing about the NFB loop is that it controls the amp Vdc output offset. Ideally, Vdc at Vo should
= 0.0Vdc, and pigs will fly before you get that. BUT, I have used fets for the amp inputs which have high Z in and
thus I get away with using the C4 2u2 + R7 1M0 network to allow Vo DC to reach Q2g, without being mauled by the
rest of the NFB network. The loading effect of 1M in parallel with R12 2k7 is negligible.
With R8, C8, R9, the THD drops to less than 0.03%. But other factors affect THD. The limiting voltage clamp
diodes begin to conduct on both + and - wave crests at Vo when Vo reaches +/- 4.9Vpk.
Such wave crest suppression causes some slight 3H++ to be generated. But in my unit I ended up getting
THD = 0.09% at 1kHz, mainly 3H. This is much better than having 2% 2H, and is much better than many other
signal generators and function generators using chips to generate a fabricated sine wave.

I also tried 6 x series 1N914 in 2 directions ( 12 diodes total ) to act as a voltage clamp plus VR pot across R12 2k7
but the sharp threshold action of diodes causes high 3H at maybe 5%, so that idea is hopeless.

I tried using a few 12V x 50mA lamps in series and a variable DC current bias with pnp bjt from +20Vdc.
This made what I thought could be a good variable R for NFB control. Two more bjts and a rectifier were
needed and it looked good in theory but amplitude stability was appallingly bad, so I quit that idea. THD
was about the same as the j-fet with local FB though.

Now do you see how much everybody else online in the world does not say about their published electronic junk?
There is always more than ONE simple thing to consider about any single R, C, or any point of connection anywhere
around any analog circuit. But at least we can get an idea, something you cannot do with a multi-layered PCB
with zillions of multi-pin ICs, all operating digitally.

The Fig 2 shows the whole voltage amp and it looks like a good quality solid state audio power amp. Indeed it could
be a power amp but the load to be driven is a much higher ohm value so small signal bjts can be used throughout and with
no heat sinks.
There are 4 loads on the amp, in parallel.
1. There is the NFB R network of R10, VR1, R6, and Rd of j-fet.
2. There is the output attenuator, minimum 772 ohms.
3. There is the PFB network of switched R&C.
4. There is the series resistance R1 5k6 Fig 4 from amp to Schmitt trigger square wave circuit.

1. The NFB resistance network is always 1.5 x R12 = 1.5 x 2k7 = 4,050r. Why? Because when Vo is stable and 3.66Vac,
Q2 gate has 1/3 of Vo present, or 1.22Vrms. So there is 2.44V across 2k7, and I = 0.904mA so load = Vo / I = 3.66 / 0.904
= 4.05k ohms.
The PFB signal at Q1 gate may be 1.221Vrms and is only just above Q2 gate. The gate to gate voltage is extremely low
where open loop amp gain may be say 40,000 which would make Vg-g = 0.09mV, and quite difficult to measure.

2. The output attenuator load is VR2, 772 ohms and it came from my junk box, and seemed to have no serious
faults so common in old pots when dust, dirt, pollution, corrosion, and loose terminals make many useless.
I always clean out the pot with white spirits and plenty of turning actions then blow out with compressed air
and then compress rivets holding lugs to tracks using long nose pliers in a vice. I seal up the hole near the lugs
with cardboard and tape and THEN such pots give many more years of trouble free operation.
Most cheap log pots you buy won't be exactly 1k0, and somewhere between 700r and 1k2, and mine is 772 ohms.
If I ever change to another "1k0" replacement LOG pot, a parallel trimming R will be needed to ensure the total
nominal R value = 772 ohms. If the R is not 772r, the switch S2 attenuator with its set resistances cannot give
correct -10dB reductions of output signal amplitude because the attenuator R values are calculated for only 772r.
-10dB is a nicely convenient reduction of output level. It means Vo is reduced by factor 1 / square root 10,
or x 0.3162. This is near 1/3. Two such reductions of x 0.3162 give a reduction of x 0.1, and you will eventually
find this engineers' way of reducing outputs and inputs is a pleasure to use.

3. The positive FB circuit is the Wien bridge RC network. For where the WB network has equal two value C and R,
the input load impedance becomes 2.121 x resistance value, and because R is varied between R for highest F
and 10xR for lowest F, the load we need to consider is the lowest because it needs the highest current and
in this case R = 1,590r, and load = 2.121 x 1,590 = becomes 3,372r. So where did the constant 2.121 come from?

The factor 2.121 is the factor calculated from 1.414 x 1.5. Huh? Why?
In all Wien RC bridges, the output signal response is that of a low Q tuned circuit and Vo can only ever rise to 0.333 x Vin
which occurs at only one frequency, that of "resonance" Fo, where phase shift between Vin and Vo = zero degrees.
See Fig 3 below.
Fig 3.

From the above basic Wien bridge when operating at Fo we see Vin = 10Vrms and V0 = 3.3V.
So that 6.67V exists across R1 in series with C1. And we need to know that phase shift between
Vin and Vo = 0 degrees, lest all our statements about measured voltages are wrong.

At 1kHz Fo, reactance XC = R ohms, and impedance, Z for R and C in series
= 1.414 x R = 2,248 ohms. Therefore current flow = 6.67V / 2,484r = 2.966mA.
Therefore impedance looking into the input = 10V / 2.966mA = 3,370 ohms.
The result validity depends on the the 0 degrees of phase shift between Vi and Vo.
The same 2.966mA flows through the Z of R2 and C2 in parallel, and may be calculated as 0.707 x R
= 1,124r, or we may calculate from observations, Z = 3.3V / 2.966mA = 1,123 ohms.
So total Z between Input and 0V = 2,248 + 1,123 = 3,372 ohms.
The simplest way to calculate Z in for Wien bridge network at Fo is Z in = 2.121 x R.
For decreasing frequencies below Fo, the Z in rises towards infinity at 0.0Hz
because the C become open circuits.
For F increasing above Fo, Z in reduces to a minimum of R, because the C become short circuits at HF.

4. There is a feed resistance from oscillator amp and square wave circuit, Fig 4, R1, 5k6.
The voltage at the Q9 base end of R1 is less than 1/5 of Oscillator output so in fact effective
loading is about 6k2 from this resistance of 5k6. ( See how there is always more than ONE thing to consider
about any single part in an electronic circuit! ).

So, we have 4 loads in parallel = 4,050r // 772r // 3,372r // 6,200r = 501r ( 501 ohms ).

The amp must be able to power the load with little THD caused by loading.
I like my signal generators to make +/-5V peak at least, and in this case 3.66Vrms.
So load current at 3.66V = 3.66 / 501 = 7.3mA rms. It could easily be possible to have idle DC current
in Q6 and Q7 to give pure class A operation if Ic =11Adc. But this is not necessary, and the Q6&7 may operate
in class AB at low enough THD because the NFB acts to reduce distortion in the amp which has very wide
open loop bandwidth at 3.66Vac thus allowing 1MHz without any attenuation. But anyone is free to have
Ic = say 20 mA, and perhaps gain a slight amount of better HF stability. I found that capacitive loads on the
amp may cause oscillations cease but very little HF gain reduction was needed with Zobel R&C between
Q4 base and collector, see R9 and VC1, Fig2.

The Vo from the sine wave oscillator in Fig 2 is prone to poor HF performance especially if there is even a small amount
of C, say 100pF between the output side of R16, 33r, and 0V. This is enough to destabilize HF oscillations above 300kHz.
But the shown switched attenuator S2 and pot VR2 cause negligible C shunting themselves. To protect the oscillator amp
from effects of C shunting of signal due to cables or C in of gear and from low Rin of gear connected, I decided a
buffer output stage was needed.

To make it rugged, simple, and wide band, I used PN100+BD139 and PN200+BD140
connected as a complementary emitter follower pair which gives gain close to 1.0. Its Rout is set by 22r emitter resistors
and the 47r output resistance. A zener diode + diode 10V clamp prevents high V from something external to the unit
providing a high voltage signal back into the unit output which would instantly fuse the bjts. The 47r is 1/8 W rated,
and fuses open if high voltage enters the unit. Diode clamps are also placed from 22r junction to rails for further
limiting of stray unwanted back flows of current, like when you accidentally touch an RCA lead on an anode at +400V.

The buffer works in class A with all loads with Z above about 400r. Now that allows 400pF as a load at 1MHz.
Class AB action occurs with lower loads. A shorted output with maximum Vo of 3.6Vac being generated
causes a peak current of 74mA, and heats the 47r, but won't blow it, and causes about 0.5W of heat in
each of BD139, BD140 which won't kill them. Notice the R36, R37, both 680r emitter resistors for drivers
Q9 and Q10. These R make the idle current in Q9 and Q10 larger than if it was only the base current
of Q11 and Q12, and give a path for discharging turn off current from bjts at HF, something bjts don't do so
well.

With the attenuator S2 and VR2 placed before the buffer, there is no attenuation of HF content from the
sine wave oscillator and the HF content of the square wave appears well preserved. I found the square wave
at 1MHz to look well compared to many other units I have used, and its highest F appears to be 10mhz, and
the rise time was calculated to be 104V/uS.

However, most good audio amps are not designed to operate above 65kHz, -3dB pole for the amp, and the
response may be measured with test sine waves of 1Hz to 200kHz. However, to examine reactive behaviors
and transformer resonant behaviour, it is often useful to have sine wave signals up to 1MHz, or beyond,
especially where mosfets are used in an SS amp which may possibly produce 5MHz, intentionally, or not
intended, when they oscillate, or are provoked into oscillations with a fast enough square wave.

--------------------------------------------------------------------------------------------------------------------------------------------------------

The Schmitt Trigger square wave circuit in the original BWD 141 had 2 x BC557 pnp transistors with feeble Idc flow.
The good "squareness" of square waves disappeared above 100kHz, and at LF.
The original 141 had a very low square wave output level and squareness above 100kHz was poor, ie, there
was much HF content removed by the attenuator network and following cable capacitance.

I searched the Internet, and found many examples for Schmitt Trigger sine to square wave converters.
None of the pages had any mention about the troubles ppl face with distortions and odd behaviors
before they get a good square wave. I tried a few online circuits with npn bjts, and then with j-fets,
and mosfets, but the npn bjts were just fine using BC546 or PN100 or 2N2222. During my trials of the devices
I played around with variations on R&C values until I eventually found further experimentation pointless,
unless I was to try something one never sees, such as a pair of Schmitt Trigger circuits with two pairs of N bjts
and two pairs of P bjts wired in parallel with cap coupling. But I did get good enough performance with the
circuit below......
Fig 4.

The input to the Q13 base network via the above R1 5k6 is permanently connected to the sine wave
amp output in Fig 2, ie, output side of R17, 33r. The square wave converter works continuously
while ever the whole unit is turned on, so that when switching from sine wave to square wave
there is minimum delay while Vdc rails and working voltages establish themselves because
long time constants are involved.

When switching S1 Fig 2 to sine wave, there is no sign of any leakage of square wave gate crashing the
sine wave party.

As sine wave F rises above 500kHz, there are some difficulty getting enough energy to trigger the base input
at Q13 and Q14 to maintain square wave symmetry.
To ensure enough triggering voltage at HF appears at Q9 base to give symmetry, R1a 150r and C1a 100pF
have been added as a Zobel network across R1 5k6.
This was found to have a negligible extra loading on the sine wave amp at HF.

The Q15 and Q16 complementary pair emitter follower buffer overcomes the problem of attenuation of HF
on positive going V rise at R9, 1k1.
The 1k1 is not a low enough resistance to overcome any stray C in following attenuator network, and the
attenuator network has low minimum R in of 770r, so the buffer IS NEEDED.

The Fig 4 schematic has 470uF bypassing R6 15k. In most other schematics online, R6 is not bypassed,
or bypassed with a small value of C, perhaps 100pF. But after trialing several values, I concluded 470uF was fine.
With no bypass C or low values of C, the delivery of positive FB from Q9 collector to Q10 base is rather too slow.
And I found the square wave's lower horizontal had a large kink, so the wave looked wrong, and unacceptable.
The RC coupling as I have it works best.

VR3 and R7 must be adjusted carefully to get the wanted level of +/- 5.17Vpk AND good wave symmetry
where both top and bottom horizontals of the square wave have equal length, and time between verticals
is equal. The range of VR3 pot movement needed to get square waves to occur at all is rather small.
The R7 value was adjusted with a temporary pot to get the wanted peak Vo while VR3 was adjusted
for best symmetry as R7 is adjusted.

Nobody else tells you that you MUST adjust these two resistors together because they are somewhat
interactive, and beginners will be frustrated when they build something they saw online and it fails to
work and they stare at it for 10 years without knowing what questions to ask or what to try to get it
working. When using 10kHz sine wave input you should get a splendid
looking square wave and you should find all other F give the same peak Vo and good symmetry.

I have no provision for applying DC offsets at the output, so that in effect a positive or negative bias
voltage cannot be included in the total Vo signal. Nor can you vary the asymmetry for a weird looking
square waves.
I have never needed Vdc offsets, and have always found that having Vdc content in signal gene
outputs is a royal pain in the arse when testing something where you WANT ONLY 0Vdc at the
input to something you are testing, and if you do want some DC, then make up a suitable C&R coupling
circuit and add the Vdc bias manually. If there is to be any biasing of amps under test, it will be
done within the amp, which should not have any Vdc present at its input, say from a grid which
is drawing some slight grid current at idle, and every time you switch sources you get a loud click.

I do not propose to add more boards for a "triangle wave" or saw tooth wave, or for AM or FM modulation.
To test audio amps, there is no need for more than what this unit now does, ie, give sine and
square waves up to 5.15Vpk level, 1Hz to 1MHz, and with no Vdc content.

For the extra functions an additional box could be made with a suitable circuit you will have to research
and develop after perhaps beginning with something you'll find online but which probably will not be fully
explained properly, or which just won't work very well. A good triangle wave with straight lines can indicate
very basic linearity of an amp because you can see when the straight lines get a bend if you have a
dual trace CRO.
F distortion can occur, ie, "integration", ie, further action by C&R or L&R circuits within the tested amp.
For measuring THD, it is better to use a dedicated low THD sine wave and following notch filter as described
elsewhere at this website, thd-measurement.html

Because of long time constants used in the unit, Vdc settlement after turn on takes about 20 seconds
before 0Vdc appears at the output with negligible Vdc measured. Some variation of the Vdc offset
will occur with use and switching F ranges or from sine to square.
Vdc will eventually settle. Most good amps have a C&R high pass filter at their input such as say 0.33uF
plus 68k, giving LF pole at 7.1Hz. The time constant = 0.022 seconds. This will cause serious distortion
of LF square waves. But you will find the distortion where square wave horizontals become highly sloped
at below 30Hz is of little concern. With this oscillator unit you can place a bypass link across the 0.33 uF and then the
time constant is set by C24 200uF and 68k plus R41 47k at unit Vo thus giving time constant of 5.5 seconds,
and LF pole at input at 0.028Hz. The distortion of LF square waves is then negligible.

At the unit's Vo, the R41 47k, gives a long time constant = 9.4 seconds when unloaded. So where
you have a tube amp with 0.22uF and 470k at input, the TC = 0.103 seconds, LF pole = 1.53Hz and you
will still get square wave distortion at the input. If the 0.22uF was bypassed with say 22uF NP cap, then
you get a TC = 10.3 seconds and square wave at input will keep its integrity.
However, tube amps have maybe 3 internal C&R couplings and at least one R&L OPT coupling
which all cause trouble with square wave inputs. The NFB used will correct much of the errors
in square waves that are inevitable. But do the so called errors with square waves at LF matter?
Fortunately, nobody has proved the C&R and R&L coupling causes bad LF sound, and in fact
well made tube amps just cope, and sound is excellent.

What is important is the HF square wave performance of any amp and its stability with C loading
or without any load at all.
The amp under test should be able to give a good looking reproduction of square waves between 100Hz and 5kHz.
There should be very little ringing or overshoot with no amp load or with a pure R load of nominal value +/- 100%.
So something designed for 8 ohms should work OK with 4 ohms or 16 ohms even though less PO is available.
Some overshoot may be allowed to occur with solely C loads between 0.05uF and 10uF, and where Vo is kept low
to avoid overload.

Many amps fail when tested with square waves and they can oscillate badly at some RF when no load is connected
or when a pure C load is connected. Most dynamic speakers are inductive at HF and many do not have a Zobel network
at their X-over filter to ensure there is a nominal R load when F rises above 20kHz, such as say 8r2 + 0.47u.

The beauty of square wave testing is that you can adjust the the C value used to bypass the FB resistance from
amp output to its FB input port, and adjust the HF gain and phase change of the voltage amp to ensure HF gain at
F above 20kHz is reduced, along with phase shift so that FB remains negative, and not positive, even when C loads
are used. A CRO and a good signal gene are essential tools for getting any amplifier to work well as it can,
and give optimal bandwidth and complete unconditional stability when NFB is used. In amps without NFB,
the signal gene is still essential to make sure sine wave response is as wide as wanted. Without NFB, most amps
have no stability or oscillation problems, but the CRO will tell you their transient response is much poorer than
their brothers with well designed NFB networks.

Back To Education and DIY

Back to Index


Wien-bridge-tubed-oscillators

Vu dans ... http://www.turneraudio.com.au/Wien-bridge-tubed-oscillators.html

Wien bridge oscillator with tubes, March 2015.
Last update of this page, 26 March 2015.

The only schematic difference to earlier versions of this page is for better HF
stability in amp in Fig 2, by adding S1c, and C4a, 2n7, etc. Please use the
Fig 2 schematic as I have it if you copy the design. Just remember, if you make
smallest change to anything I have done, it may result in degraded performance.
Be prepared to solve all your own problems.

Many past sine wave oscillators with tubes had insufficient bandwidth with high THD.
Here are details of two I built which were much better than Hewlett-Packard's
1930s first Wien bridge AF oscillator.
Many old variable F tubed oscillators used LC circuits which are not covered in this page.

I have used tubes to produce the sine waves with both Wien bridge oscillators here.
I begin with a re-engineered 1950s AWA telephone tech oscillator for sine waves
only from 1Hz to 220kHz.
The second has tubes to make sine waves from 1Hz to 2.2MHz. It has a solid
state Schmitt Trigger circuit to convert sine waves to square waves, and has
a solid state output buffer and multi level switched output attenuator. Overall
performance is far better than many units using common audio op-amps.

Picture 1. Re-engineered 1955 AWA oscillator.
Fig 1. Schematic WB tubed oscillator, 2005. 1Hz to 220kHz.
Table 1. Measured R values for WB RC network.

Sheet 1. Schematic, WB tubed oscillator, Sheet 1, amp, 1Hz to 2MHz 2013.
Sheet 2. Schematic, buffer output for WB tubed oscillator, Sheet 2.
Sheet 3. Schematic, Schmitt trigger and amp for WB tubed oscillator, Sheet 3.
Graph 1. Square wave harmonic content.
sheet 4. Schematic, Power supply for WB tubed oscillator, Sheet 4.

Fig 2. Small signal bjt discrete bjt op-amp.

Picture 1. Old AWA oscillator sold to PMG ( Govt post & telephone company ) from 1950s.
In around 1995 I was given a tubed Wien bridge oscillator made by AWA Australia
for telephone technicians. Like many ancient oscillators made after about 1933
there were only 3 frequency ranges; this one 20-200Hz, 200-2kHz and 2kHz-20kHz.
The original AWA unit used a dual gang AM radio radio tuning cap to vary F
by switching 3 pairs of resistors with highest R value = 22M, lowest value 220k.
It was very inadequate test gear for testing hi-fi amplifier amplifier response needing
examination between 1Hz and 220kHz at least.
I recall it had a 6SL7 and 6SN7 used as output tube driving 20k : 600r OPT which
I still have for odd purposes.
I completely re-built the unit........
Fig 1.

There are 5 frequency ranges, 1Hz-22Hz, 10Hz-220Hz, 100Hz-2.2kHz, 1kHz-22kHz,
10kHz-220kHz.
F control uses available Alps dual gang log 50k "Black" pot with 27mm square
body to alter the F. There are 5 pairs of fixed capacitors switched by
2 pole x 6 position old wafer switch. One position is wasted.
The Alps pot has well matched tracks with continuous wiper contact so that wave
form amplitude "bounce" is minimized. I found each track measured 48.2k max.

With the added series R of 2k2, max R = 50.4k, min R = 2k2, and at centre
rotation ( dial = 12 o'clock ), total R = 11.14k, and pot R = 8.94k which is
0.18 x max pot R.

Some "log pots" produce -20dB attenuation from wiper at the centre position or
"12 o'clock" position, ie, there is 10:1 signal voltage reduction at centre position.
AFAIK this is regarded as a true log pot but depends on source signal
R < 100 x total track R, and assumes the loading of wiper output > 10 x track R.
A true log pot of 50k driven by a cathode follower and for gain pot to a preamp
grid and set at centre has 5k from wiper to 0V and 45k from wiper to source.
( The output resistance from wiper = 5k // 45k = 4k5 ).

Many so called log pots including the Alps I have used have a voltage step down ratio
of approximately 5:1. The "50k" Alps pot I used had track R = 49.6k and between
wiper and 0V track was 8.9k when in centre position.

WB oscillators using pots generally have one end of track connected to the wiper
to make a simple variable R. The Alps gave me a pot range 49k to 0k0. There is a
series R1&R4 = 2k2 each so that each R in Wien RC network is varied between
52.2k max to 2k2 min. This allows F variation between 10 and 220.
At near centre of rotation R = 11.1k and F = 50. F between 10 and 50 fill 1.2 the dial
and numbers 50 to 220 fill the other half so numbers are spread out to allow easy
reading to at least 2 significant figures keeping reading errors less than +/-2%.
The dial readings have been verified by measurement of R in Table 1 below.

With the Alps pot I used, and with a series 2k2 I measured the total R values :-
Table 1. Measured R values with dial pointer set to calibrated dial numbers.
Hz | 10 | 12 | 14 | 16 | 20 | 30 | 40 | 50 | 60 | 70 | 80 | 100 | 120 | 140 | 200 | 220
R total k ohms | 50.4 | 41.7 | 35.5 | 32.0 | 24.6 | 16.4 | 12.6 | 10.0 | 8.29 | 7.03 | 6.11 | 4.80 | 3.94 | 3.44 | 2.48 | 2.25
The "50k" pot plus 2k2 gives variation slightly more than max & min values of table
so the real F range is from about 9.8 to 223 and allows for trimming C values.

The pot for a Wien bridge oscillator needs to have a smooth R change giving centre
position attenuation ratio of between 4:1 and 10:1.

This applies where you want each F range to be a decade of F, say 10Hz to 100Hz.

Don't try to use a linear pot. There is no way to add additional R to make a "quasi log"
pot for this application. I tried, nothing works. If a linear pot is used for a decade of F
between 10 and 100, then centre position gives 18.1, and numbers between 18 and 100
become very crammed and the high end of dial.

Few cheap dual gang "log pots" give a smooth R change vs rotation. The $4 types
from Jaycar are mostly not worth buying for a WB oscillator. Some seem linear
for part of the turn, then suddenly change to a lesser R, and maybe again, so the
pot does horrible things to how the dial numbers appear. The two tracks are often
poorly matched and added trimming R do not much improve the pot function.
Cheap pots are unsealed, allowing pollution, dust, and soldering fumes to settle on
tracks pots tend to have loosely riveted track connections.
If you must use such crap, spray insides with WD40, press up rivets more tightly
with long nose pliers, seal around open holes with cardboard and silicone before
soldering. Take your Fluke DMM to the shop and sort through their bin for the
best match of tracks and obtain the highest ratio for track R for each side
of the track with wiper set to centre position. Seek the "most logarithmic"
with highest attenuation ratio at centre you can find. And don't be surprised when
you find they ain't very good when you use them.

I tested an ancient 1dual gang 5.0k Colvern wire wound pot formerly used in WB
oscillator. These were very well made with precise matching and smooth R change.
But they suffer from rust on tracks and one gang had a deep rust spot and could not
be cleaned so could not be used. Other track is like new. In centre position R ratio
is 10k2 : 4k8 which is attenuation ration near 3:1. It is not much better than a linear
pot with 2:1 atten ratio ( centre position ).
For the Colvern used for F between 10 and 100 the fixed R = 1.67k for R min
and 16.67k for R max. At the centre of rotation R = 4k8 + 1.67k = 6k5. The F will
be 25.6, so 1/2 of dial is 10 to 25.6, and other 1/2 is 25.6 to 100, with crammed
numbers towards the 100. People accepted this. The wire wound pot does cause
because wiper "bumps" over individual wire turns, but once adjusted they are
extremely reliable, ( if not rusty ).
The Colverns were "REVERSE LOG" which meant the low F numbers appear
on left side of dial, and as you turn knob clockwise, F rises. This is opposite
to all common log "volume" pots, with increasing signal with clockwise turn.

Probably, the best pot will give double the F number for each 90 degrees of turn.
So at zero turn on right side of dial, F = 10, then +90d gives F = 20, and +180d gives
40, and +270d gives 80, and the remaining 30d gives 100.

Many ready made WB oscillators you might buy or build from a kit have unacceptable
calibration errors because the supplied dial numbers do not match the poor quality
pots supplied.
So, if you have an existing variable F oscillator which you wish to restore for use
building amps, try checking calibration with a digital F meter, and be prepared
to change the pot to better brand and re-make the dial.

In other Wien bridge oscillators I built I used a 12 position switch to give 12 F
per decade with F spread apart similarly to standard R values between 1 and 10.
Using a dual gang 24 position switch would be much better, but be prepared to
spend a day or two calculating R values, then using paralleled standard values to
get within 1% of the calculated value.

For all Wien Bridge oscillators, F = 159,000 / ( R x C ),
where 159,000 is a constant = 1,000,000 / pye, F is output frequency in Hertz,
R in ohms, C in uF. BTW, pye = constant = 22/7 = 3.14286.

If you calculate the theoretical F for each chosen R and C value, the measured
F will always be slightly different to the theoretical F because of stray C in the
circuitry and slight differences in R values and R tolerances, and R measurements.
It takes considerable experimentation, adjustment, and patience with final R&C values
before the pointer on the dial gives you the exact frequency indicated, +/- 2%, AND
you find the same dial numbers suit all selected F ranges. But you should find a
a strong correlation between theoretical R, C and F to what is measured.

For audio F response testing we do not need more than 2 significant figures for
F numbers. If we adjust the oscillator pointer to 50Hz on the dial, the exact F could be
between 49Hz and 51Hz and we do not need to have 50.000Hz. The +/-1Hz for 50Hz
setting is within +/- 2% accuracy and is quite OK for 99% of response testing of all that
anyone does with Hi-Fi gear including testing a L+C eq filter network for a loudspeaker.
If you need more F accuracy, use a digital F meter to monitor the oscillator which
may be adjusted to be more accurate, ie, say indicate the high Q peak of a
LF loudspeaker box resonance.

To calibrate my dials :-
1. Cut dial card from good white cardboard to slightly over size shape and size
needed.
2. temporarily attach dial card to unit panel and mark in pencil where centre
are on panel, to allow removal and replacement after calibration.
3. Use digital F meter to move dial pointer to exact F numbers and draw lines and
F numbers in light HB pencil.
4. When happy with the F readings for 5 F ranges, remove card from panel and
overwrite pencil with black ink and erase pencil.
5. Trim size of dial card to wanted exact size but without losing positioning lines
6. Brush on semi gloss varnish to both sides of cardboard until saturated when it
should be slightly opaque and cream colored.
7. The dial card may be left to dry and later glued to panel.
8. Alternatively, the panel is sanded where card sits and then painted with varnish
when dial is varnished. Oscillator is tuned on bench to have panel horizontal and dial
placed in correct position and all left alone until next day when varnish has
hardened.

This is Primitive DIY, but it works OK and you don't need a PC.

The digital meter was also used to trim C values shown at S1A and S1B, so only
one scale was needed for all 5 F ranges.
The digital meter I have is a kit I built and able to measure between 1Hz and 50MHz
in 3 F ranges. It is fine above 20Hz, but below 20Hz it becomes slow to give a reading.
Below 10Hz it cannot give fractions of a Hz, and below 5Hz its unreliable, and very
vague below 2Hz, so to calibrate a dial you need a stop watch and then count the
cycles using a CRO. If you count 12 peaks in 10 seconds, you have 1.2Hz.

The Fig 1 schematic can operate to give a higher F up to 800kHz. But above about
200kHz the dial readings used for lower F ranges become incorrect. Vo level declines,
and you get parasitic F. The tube Miller C, stray circuit C, and grid current will all too
easily affect operation too much. With R values I show, the value of Ce to get to
2.2Mhz is a theoretical 31pF. I found that about 220pF was the smallest C value
I could use before the overall function became awful. If I wanted higher F, a
much bigger change to circuit was needed so I settled for 220kHz.

Feel free to do better with neat PC controlled laser cut dials or machine engraved
or laser printed dials on opaque plastic and with LED lamps behind.
I'm always too busy to get around to finer DIY work which does nothing to improve
the work I do with amps I build. Don't be a tradesman who blames his tools.

Most pots have 300 degrees of turn and I found no need for a reduction drive
so setting the F is fine enough even with 10-220 F numbers instead of the more
common 20-200 or 10-100 F range on dial.

The use of a pot to tune F does generate a slight amount of Vo level bounce
because of the very slight noise during movement of wiper on carbon track.
The noise comprise intermittent transient voltages at output thus feeding noise
voltage to NFB so that lamps over-heat slightly, increase ß, reducing Vo, then
lamps cool, and ß reduces, Vo goes higher, and amplitude becomes unstable
and "bounces" a bit after noise stops, because of the lamp's slow thermal time
constant. Many old oscillators had huge bounce problems. I found the zener
diodes Vd2 to Zd5 across R11 fixed the bounce problem.

The Fig 1 schematic is not prone to LF or HF parasitic oscillations where you get
your wanted F but you also get an additional oscillation signal making the unit
unusable. The WB oscillator depends on having a high gain amp with both a
PFB network plus a variable ß NFB network used to control gain.
All such circuits are prone to instability if there is excessive open loop phase
shift in the amp, and PSU rails are not well stabilized.

The NFB network has 12 seriesed 12V x 50mA lamps. Each lamp is known as a
"grain of wheat" incandescent globe used in model trains etc. With 12V applied,
I = 50mA, R = 240r and power is 0.6Watts with hot bright filaments.
When cold, lamp resistance is approximately 27r. Ideal lamp resistance for large
R change for a small V change is about twice the cold R or about 50r.
To double the cold resistance you need less than 0.5Vac applied and there is a
high rate of R change for a given small increase of voltage.
The 12 lamps should be fairly well matched or else one or more will tend to turn
on more than others, so that effective lamp R is not what you want it to be.
There are very few if any available lamps with high R per Volt and which are able
to be used with output tubes such as 6V6, 6F6 in old WB oscillators.
Thermistors are possible in theory in the NFB network but AFAIK, nothing suitable
is available. The best were vacuum sealed inside a glass tube with delicate
element for use on input side of NFB network. The delicate element gives high
amount of R easily driven by tube or transistor and gives high rate of R change for
small voltage change. The glass helps stabilize temperature, and stops heating from
surrounding hot things.
But I don't know if such thermistors are now available, I could not find a source.
The thermistors have lower R as they heat up, so when Vo rises the ß increases
and NFB increases, gain reduces and Vo is kept constant.

The lamps give low enough THD and work better than many other ideas since 1930s
when they were first used in commercially made WB oscillators. Many special things
made before 1970 for odd uses such as control elements in PFB or NFB circuits
are no longer made.

The adjustment of VR3 10k pot adjusts the gain and Vo slightly, and you may find
that as you adjust this pot for least THD the Vo tends to become more "bouncy"
and unstable. While it might be possible to get much less THD than I have here
the price to be paid is instability, so its better to settle for THD just under 0.5%
at 1kHz, than have bounce problems when THD = 0.1% or less.

I have arranged an output stage of amp to be 6AC7 pentode to provide high gain
to a White follower buffer using two 6CM5 in triode, each with Idc = 25mA.
The 6AC7 is a metal can tube from 1940s and I had a lot of them. They have
quite high gM compared to say 6SJ7 and derivatives. 6SH7 might be usable.
A mini nine pin 6BX6/EF80 could also be used.
The White follower enables loading by both PFB and NFB networks without much
affecting amp gain.
Total RL minimum = 1k3 with NFB and PFB in parallel at HF end of the F ranges.
The White follower produces 16.5Vrms and this is fed to the output attenuator pots
for two output voltage ranges, up to 14Vrms or 1.4Vrms.
There are R&C networks for F compensation to give flatter response for all F ranges.

The Wien bridge PFB network loads the amp with Zin = 2.112 x R where R is
the network R value. So if R max = 52k, R min = 2k2, then load changes between
109k and 4.65k for each F range. The NFB network with 12 series lamps has each
lamp operating with 0.46Vrms each which raises cold R or 27r to about 55r.
So the output side of NFB network has R = 660r, and slightly variable if applied
voltage changes. The input side of NFB network has an adjustable R which is used
to trim Vo and THD. Once variable R is set, it becomes fixed, and is twice the
average lamp R value, so 1,320r, so lamps plus fixed R = about 1,960r total.
When in parallel to PFB at highest F the total RL = 1.3k approx.

Other suitable lamps are the type "327" rated for 28V x 40mA, 1.1W, and has
cold R = 60r and good for Wien bridge use. One should always choose an
easily replaceable lamp and make sure excessive voltage cannot occur in
your circuit.
During operation, minute Vo change causes minute change of lamp current and
lamp resistance. This alters the voltage fed back to input, ie, ß varies.
ß is NOT constant.
If Vo rises, ß increases, open loop gain is reduced. If Vo reduces, ß is reduced
and OLG increases. The PFB ß remains constant, 0.3333 for the output frequency.
For F above or below Fo, the PFB ß is always lower than 0.3333 and lower than
NFB ß so the circuit only oscillates at Fo ( providing there are no parasitic F. )
With both PFB and NFB applied the oscillations remain at a point of equilibrium,
and Vo is unable to increase or decrease.
The Vac difference between applied PFB and NFB drives the amp to produce Vo.
At frequencies above or below the output F there is less PFB applied,
and NFB acts to reduce THD and noise.

The open loop gain of amp = x 355 (about +50dB) and from V1+V2 12AU7
differential pair with cathode CCS followed by 6AC7 pentode.

Notice the input pair has the V1 PFB triode with anode load of 560r and its
B+ = 100Vdc. The input C for PFB is low, like a cathode follower. The 560r may
be omitted, but I recall it is for HF stability. Differential gain of the 12AU7 is about
8.0 and 6CA7 gain with unbypassed Rk = 42, hence total gain 335. The bypassing
of the Rk of 6AC7 would much increase gain and also increase problems with stability.
As it is, the non bypassed Rk much reduces the THD of 6CA7 locally, leaving less
mess for the NFB loop to clean up.

The open loop gain is reduced to 3.0 with NFB and so gain at mid band at say
1kHz is reduced by NFB by a factor of 3 / 335 = 0.00895, or by about - 41dB.
At 1kHz, THD is at its minimum, and less than 0.5% and you cannot see it
using a CRO. Tests revealed it is mostly 2H.
THD in such oscillators does not follow all normal rules for THD in amps with NFB
because where you have say 3H being fed back from Vo it is phase shifted
and its difficult to fully calculate results. My calculations suggest THD is reduced
by a factor 0.083, or by approximately -22dB, and thank you Mr NFB,
we will accept your gift!

In practice, the measured THD is seldom equal to the theoretical THD expected.
there is some THD generated by lamps and by limiting diodes just beginning to turn on.

If one wants extremely low THD with Wien bridge then it is most achievable where
the oscillator is dedicated to 1 F as in the case of one WB oscillator I made
with an op-amp giving 0.004% THD at 1kHz.
See my page at http://www.turneraudio.com.au/thd-measurement.html

Now for a much better WB oscillator using tubes for sine waves
and SS for square waves....

Picture 2. Front of tubed WB oscillator.
This was nearly completed 2013. Dials and finish were completed later.
The paint finish is a bit rough but what is inside the box is important.

Notice there are two F dials. Left dial is for AM radio tuning gangs, and right dial
is for an Alps pot for the lower F.

The dials and labels were made using a PC. A cardboard template with all F markings is
scanned to make a .gif image in MS paint and in black and white only.
The scan was tidied up in MS Paint. The tidied dials were printed and altered until
I got the sizes about right after printing.
Because the two frequency dials are circular, they can be slightly bigger or smaller
than originally intended and the pointers will still point to the same F numbers.
Three printed paper copies were made, then overlaid in exact position and soaked in
furniture vanish which also acts as a glue to metal case front. Overlaid copies
gives depth to the printing and looks much better than using just one varnished copy
with allows old numbers and metal defects to be seen through the opaque varnished
paper.

Sheet 1. The more capable Wien Bridge oscillator in Picture 1 at top of page......

Sheet 1 shows the result after many experiments with different circuits and tubes
to get maximum possible F = 2.2MHz.
After many trials with triode input stage LTPs with 12AU7 and 6DJ8,
the use of 6BX6 / EF80 were found to be the best for both gain stages, despite
the complexity of cathode biasing and screen bypassing.
Mid frequency open loop gain of V1 & V2 at 1kHz = 22 x 30 = 660.
The gain of the white follower is about 0.75x with all loads used, so total open loop gain = 495.
The GNFB reduces open loop gain to 3.0 so the amount of NFB = 44dB approximately.
The open loop gain below 30Hz and above 10kHz is reduced with the gain shelving networks
and bypassing of V1& V2 470r cathode resistors with appropriate R&C to give LF stability.
The -24.7Vdc rail enables the use of high value Rk which helps to keep the anode Vdc
very stable, so direct coupling of V2 anode to White follower V3 grid is possible to avoid
the phase shift.

It is not until anyone tries to build something like this that it becomes difficult to see how a
simulation program could predict the exact R&C values better than I have with an old brain.

But I did draw Nyquist graphs of open loop gain and trials of R&C values and I spent much
time testing before I was satisfied the circuit would not oscillate, yet give me a passable
square wave at 2MHz.
I could get the initial circuit to be stable after initial warm up, yet half an hour later when
using the LF range I'd get bursts of HF parasitic F above 12MHz. I had to add an extra
wafer S1c to rotary switch, and add C4a 2n7 to reduce HF gain while using LF range.

I had a number of identical 3 gang AM radio tuning caps and I was able to mount them
all together using 4mm plastic and plywood and rotating them with dial cord around
4 x 65mm dia 20mm thick plywood discs glued to cap shafts. A dab of glue hear and there
made the dial cord idea work well to move all C gangs together.
The alternative would be fine chain wheels and tensioned chain but I found nothing
available and able to be adapted.

The marine ply discs were easy to make using a plumber's hole cutter blade in a drill press.
Each C gang gives C range approximately 13pF to 400pF. The effective C range of each C
used in the Wien network for PFB is approximately 180pF to 2,580pF which includes
some added fixed trimmer C.
This meant having low R value of 253r for the 200kHz to 2MHz range. The minimum C
of about 200pF including stray circuit C and the low 253r gave the F extension to 2MHz
and with stability. All other attempts with higher R and less C failed to give good
stable results.

The circuit was difficult to stabilize at both LF and HF to get the full bandwidth 1Hz to 2MHz.
The S1 range switch I have used was an old well made switch from 1950s with 3 poles
and 9 positions and I have used 6 positions after adjusting metal work to only
give the 6 positions. S1a and S1b change the range F, and S1c just switches in the 2n7
to 0V, via link X to X.

So why use so many ganged tuning caps?????
To get up to 2.2MHz the minimum C needs to be above about 180pF or you get all sorts
of HF or LF instability. If C min = 180pF, then R must be theoretically = 401r. But you
can see I have 253r. So there must be considerable unknown stray C in the circuit,
maybe 105pF. If C is any less than I have it, the circuit won't work very well, and for higher
F you would need to think about much lower R and still keep C highish and use higher gm
devices such as RF signal mosfets etc. I could not find any schematics online for Wien
bridge oscillators able to go to say 22MHz.

If I wanted a decade of F change per range, and C min was 285pF including stray C, then max
C would have to be 2,850pF. To get this C variation I needed lots of variable caps.
Then to get down to 1Hz, the R size = 55.8Meg ohms. Well, that's quite an impossible R value
because the minute grid current in V1 ruins the function and you find you just cannot get down to
1Hz with tuning C unless you had R not more than about 5Meg. I settled for lowest F with
tuning C = 20Hz which allowed R = 2.8Meg. I wanted to have fully variable F and a pot for
lowest F range with fixed C was more sensible, and I could get from 20Hz down to 1Hz.
I could have had 24 values of switched C or R but I would not have "tunability" in operation.

THD is fairly constant at < 0.4% from 100Hz to 5kHz. It would be possible to have far less
THD but then there are problems of trace bounce and stability, so the circuit has TWO
networks to manage the problems. There are 12V zener diodes plus 1N4007 to limit the
positive and negative FB from the output of V3&4. Then I have two strings of 14 x 1N914
in series, facing in both directions so that once the Vo rises too much, the diodes conduct
and apply MORE NFB to the 4 series lamps and NFB applied to V1 cathode increases
immediately without waiting for lamps to warm and increase their resistance, which
happens too slowly, and leads to trace bounce.

Without diode clamping, the circuit tended to oscillate at both LF and HF when Vdc
conditions changed slightly and briefly at range switching, and at high end of the 20Hz
to 200Hz F range where grid biasing resistance for V1 is 2M8 in the PFB network.
The phenomena may be called hysteresis, (( harder to deal with than a hysterical wife )),
and the phenomena affects all amplifiers with high open loop gain, several stages of
tubes which draw grid current at mild overload, lots of RC couplings, large amounts
of PFB and NFB loop and a NFB loop. I was amazed that the damn thing worked at all.

It is very easy to make a Wien bridge oscillator with range from 20Hz to 200kHz.
The difficulties occur when you aim for 1Hz to 2MHz.

The diode clamps with 14 x IN914 in series exploit the gradual conduction beginning
at forward voltage of about 0.4Vdc when current is less than 2mA, and each diode
becomes a low resistance at 0.72Vdc. With 14, the V range for threshold turn on is from about
6Vpk to 9.8Vpk. So the diodes form a non linear voltage controlled resistance where an
increasing applied voltage causes a logarithmically increasing current, and lowering of
effective resistance. This action rapidly increases the NFB voltage delivered to V cathode
before the lamps have heated up to increase their resistance. The lamps have a fairly
slow time constant and diodes have an instant time constant, so the diodes give an
immediate increase of NFB to prevent the instant rise of PFB from causing excessive
Vo to occur. The circuit settles quickly between range switching, and once settled,
diodes have only a slight effect while lamps take over the major part of the NFB regulation
of the Vo.
At Vo level of 7.5Vrms, some 3H begins to be produced by the diodes, but it is better to
have that to enjoy the easy stable operation as a result and without lengthy settling times
and jittery Vo amplitude. I found that if the Vo level was reduced to say 6.4Vrms by adjusting
VR2, the THD < 0.1%.

You can look at the above Sheet 1 schematic and be repelled by the terrible complexity
and massive amounts of RC "damping" networks, but if you analyze each stage and even
draw the open loop response then it all makes sense. If you want such wide bandwidth,
and reasonably low THD, but with complete LF and HF stability, then complexity is the price.
The open loop phase shift never exceeds about 100 degrees. With gain reduced by
gain shelving networks the amount of NFB applied at 2Mhz and at 0.5Hz is very much
lower than at 1kHz, so you get stability. The tubes are inherently linear at their normal
signal voltage levels. The increase of THD at extreme HF and LF is difficult to see on
the oscilloscope and of no concern. The F response between 1Hz and 2MHz is
within +/- 0.5dB.

The PFB and NFB networks create the load on the White follower output buffer stage.
With variable C and fixed R in PFB network the minimum PFB load = 2.11 x 253r = 534r.
Lower F ranges give higher load ohms with less THD and gain reduction.
NFB network load is 180r in 4 series lamps plus 360r in VR2 and surrounding R giving
total load NFB load = 540r.
Therefore both PFB and NFB networks give lowest total load = 270r. The maximum
Vo is determined by the minimum loading and idle current of output buffer.
Vo max = 7.5Vrms so if load = 270r, then Iac = 28mArms = +/- 40mApk, and idle
current in White buffer = 56mAdc so there is adequate Ia for class A in output tubes.

EL86 in triode needed to have Iadc at idle of 56 mA and Ea = 125Vdc, with
Pda = 7 Watts each, and less than their 12W rating. The EL86 works better than
EL84 because EL86 has 1/2 the Ra of EL84, hence is less affected by the change
of total RL across each F range, caused by change in PFB network impedance.
The gain of the follower begins to decline slightly in the top F range but the NFB boosts
the V2 signal to compensate.
V2 has to make a maximum of about 11.5Vrms, well within its SE capabilities without
cut off or grid current.

 Sheets 2, 3, 4 give details for what follows the sine wave oscillator.
There is a switch for sine wave or square wave, a solid state discrete component
Schmitt trigger square wave generator with its own amp for +/- 10.1Vpk.
There is an emitter follower buffer to power a low resistance output attenuator
switch for 6 levels of output in
-10dB steps, and a 300r linear output pot to output terminals.
Sheet 4 gives PSU details including voltage regulators.

Sheet 2. Output buffer and attenuators.

Sheet 2 has npn and pnp bjts in a pair of Darlington connected complementary
emitter followers to make a buffer stage after sine wave or square wave sources
to drive the low resistance output attenuators without losing any bandwidth or
increasing THD.

The buffer stage is needed to avoid loading the sine wave or square wave
circuits with low R attenuator networks. and to prevent connections with outside
world devices from having any effect on the signal production of the oscillator.

The minimum output load for the buffer could be 47 ohms if short circuit between output
and 0V occurs with switched attenuator in position 1 and pot VR5 is turned up for
maximum Vo. A square wave of +/-10V peak from buffer will create load current
of +/- 212mA peak, so each pnp and pnp output bjt must have Idc at idle of about
120mAdc to allow *class A* power even when Vo is shorted to 0V.
With +/-10Vpk square wave output the 100mA fuse will blow.
Pd in R14 47r is 2.1Watts and rating is 0.12W so R will blow if fuse does not,
For all other switch positions buffer load is higher ohms and signal all class A
and THD very low.

To avoid damage by accidental connection of unit output to damaging voltages,
ie anode B+ supply, or mains active input, the network with R14 47r 0.125W,
100mA fuse and diodes to +/-15V act before allowing damaging current into
buffer bjts.
Ideally, all signal sources above 100kHz should have low impedance of 50 ohms
to avoid effects of cable or device input C or L. But because I have gone up
to only 2.2MHz and not to 10MHz, then a 300r output pot is OK.
Little change to the square wave occurs at F above 200kHz, regardless of level setting.

The bandwidth of the bjt buffer is from DC to 12MHz at least. A CRO shows no
change to the shape of 2MHz square wave.
The rise and fall of square waves at 2MHz looks like the highest harmonic is about
5MHz. This limited H content is due to simple Schmitt circuit which was used instead
of other more complex or delicate IC parts which would not produce the
+/- 10Vpk I have here. There is little use for square waves over 100kHz to what is
here is just fine, and at 5kHz the square wave is better than nearly everything else
I have ever seen.

Notice the Sheet 2 has a table on how to calculate the resistance values for this simple
switched attenuator network. This network is very useful for getting an easily
adjustable wide range of output voltages.
A phono preamp can be easily be supplied with a 5mV of input signal.
All good phono amps for MM or MC carts should survive having 5mV at 20Hz,
50mV at 1kHz, and 0.5V at 20kHz.

With 7Vrms available at maximum level setting, one may test the F response any
OPT and most low Z inputs of say 600r, knowing the Rout = 50r, and quite low enough.

Sheet 3. Square waves with Schmitt trigger.

Sheet 3 shows a Schmitt trigger sine-wave-to-square-wave converter followed
by a small signal discrete bjt op-amp which I developed especially for this project.

Most tubed Schmitt trigger circuits using tubes consist of a single 12AT7 with each
half used in a similar way to Q6 and Q7 in Fig 4 above. But they struggle to make a
good square wave without reducing rise times and "rounding of corners" of the wave,
ie, HF content is attenuated. So while a 10kHz square wave may have F up to 100kHz included,
the 100kHz square wave will have very poor shape so I did not try to use them.
Perhaps a pair of EL86 or EL84 in pentode mode might work better than a 12AT7.
I leave YOU to try, and I wish you good luck, you will need it.

Here is a result of spectral analysis performed on a 1kHz square wave...
Graph 1.

Notice that for a perfect square wave the odd number harmonics would have to extend
to an infinite frequency well beyond the ability of home brewed test gear to achieve.
But a good looking square wave will have 21 times the lowest frequency present, what
is called the fundamental frequency, aka H1, or Fo. With this in mind, for testing HF
stability of amplifiers, use of a 10kHz square wave should tell us if there is an unwanted
peak in the F response below 210kHz, something very common in all too many awfully
engineered amps. But seldom will 21 times H1 exist in any square wave, and at 2MHz,
the attenuation of the 10MHz content and beyond may be below -35dB and all other
higher H buried in noise.

So to get anywhere near the ideal spectral analysis shown above, we need fast
switching of devices used to produce the waves. I tried all sorts of Schmitt triggers
with bjts based on what could be found in books and online. Always the performance
failed to satisfy above about 350kHz, and failed to function properly by 2MHz.

Googling for an easy way to generate a 10MHz square waves from a sine wave
using a few simple devices gave no solutions.

But there were very complex schematics with many ICs which like others
online probably failed to include all associated circuitry to give certain results.

I tried a 4093 C-mos chip, and all ran right out of puff by about 300kHz, and
none could have the necessary trim pots adjusted to give a symmetrical square
wave for all F between 1Hz and 2MHz. I concluded mosfets would be best
because they don't conduct current at their bases like PN100 or PN200 bjts
especially at HF that they become so mis-biased by 300kHz the circuit becomes
unstable, and there is little wave symmetry and H content is poor, and Vo level
sags. Sheet 3 shows exactly what I found to be
best using a pair of 2SK363 driven at the input by a PN100 in emitter follower mode.
There is fixed bias of +2.8Vdc at the second mosfet and there are TWO trip pots,
one for input Vdc bias and the other for the level of input. The circuit works well
right up to 2MHz, without difficult R&C compensation networks or super critical
adjustment of the trim pots. The 2MHz wave isn't all that good, and it looks like
a 10V peak sine wave which has been clipped down to 4V peak with slight corner
rounding. But at 100kHz, the square wave appears to have H content probably
extending to 2MHz, or 20 times the Fo, so good enough. But my circuit can make
only about +/-2.8V peak. Increasing Vo with a following amp might reduce H content.
 But the amp has BW = 0.3Hz to 12MHz, and good enough. There is a network
R11 + C8 between trigger and amp input to stop parasitic H above 20MHz
between mosfets and input bjts.
Whatever networks you see used have all been trialed for best component value.
But this simple amp with 6 bjts works better than nearly all op-amp chips anyone
can buy at Jaycar, Dick Smith, or The Radio Shack etc.

With the high Vo of +/-10V peak, there is an opportunity to use an external
clipping circuit with a low value R of say 470r and a pair of 1N914 diodes in
parallel in opposing direction to give +/- 0.7V peak. Use of 4 diodes could
make +/- 1.4V peak. This may then produce a square wave of sufficient amplitude
to make many power amps clip, and including much extended F content.
I have not fully explored possibilities, but fast diodes UF4004, UF4007,
Schottky 1N5819, are easily available.

Sheet 4. Power Supply.

Sheet 4 shows a generic PSU which need not be exactly the same as any
you might build but you just need make up the voltages and currents as
shown and with the regulation shown with equal functionality.
One should be careful with discrete bjts used for HV regulation because
all too easily the 3 bjts use above can all instantly fuse to a sullen short
circuit needing 2 hours of work to replace them. Hence the protection diodes
you see, and which you don't always see on schematics posted online by
idiots who never consider that stuff fails after shit happens. YOU need
to stop shit happening.

Regulated rails are essential to stop very LF noise appearing in the output.
Such noise is mostly under 10Hz, but its presence interferes with tests on
amplifiers, so it cannot be tolerated. The LF rail noise is created by
unavoidable changing mains voltage levels of other mains users switching on
devices continually. Solid state regulators are so much easier to make than
tube regulators. The +266V regulator works very well. There MUST be
good insulation between the Q1 BU208 heatsink lest a tiny little arc occur
which will cause instant bjt death.
-------------------------------------------------------------------------------------------------
If anyone want to make a discrete part op-amp for a general purpose
small signals up to 10MHz, they may consider this......
Fig 2. Small signal amp, bjts.

Fig 2 is basically the same amp as in Sheet 3.
But here it is as I developed it and there are precautions about its use.
It should be used with loads above 600r. It may not like capacitance loads.
R19 100r increases its Rout, but reduces effects of C loads. Careful adjustments
of C6 & R12 will give best HF extension depending on the load to be driven.
You may have to add a 220r with 33pF LPF at input to reduce extreme HF
oscillation when used with a preceding amp. But it is food for thought.
Good luck with your soldering.

Back to Education and DIY

Back to Index
-----------------------------------------------------------------------------------------------------------------------------


Electronique - Realisations - Generateur audio 010

> Générateur audio 010
Dernière mise à jour : 13/06/2009

Présentation

Ce générateur BF délivre un signal sinusoïdal de fréquence fixe dont la pureté est relativement bonne (taux de distorsion de l'ordre de 0,1 %).

Sa fréquence est voisine de 1,5 kHz mais il est possible de la rendre ajustable, comme indiqué un peu plus loin. Voir aussi Générateur audio 012.

Principe de base

Ce générateur est construit sur la base d'un amplificateur en tension classique dans lequel un filtre passe-bande est inséré dans une boucle de contre réaction positive, le but étant de faire entrer le montage en oscillation (ce qu'on ne cherche pas à faire avec un amplificateur classique dont la boucle de contre-réaction est de type négative).

Ce synoptique fort simplifié montre ce qu'il en est : le filtre passe-bande constitué des quatres composants R1, R2, C1 et C2, réinjecte sur l'entrée de l'amplificateur AMP1, ce qui en sort. Mais il est une fréquence qui est favorisée par rapport à toute autre, c'est celle qui correspond à la fréquence centrale Fc du filtre passe-bande, et qui est définie par la formule suivante :

Fc = 1 / (2 * PI * R * C)
où Fc est la fréquence centrale du filtre, R = R1 = R2 et C = C1 = C2.

Remarque : dans ce type de montage, il est aisé de se rappeler que C1 = C2 et que R1 = R2, mais ceci n'a rien d'obligatoire. Il est tout à fait possible d'adopter pour R1 une valeur dix fois supérieure à la valeur de R2, et d'adopter pour C2 une valeur dix fois plus grande que celle de C1. Le principale étant d'avoir l'égalité R1 * C1 = R2 * C2.- LM741 : 5 mV / 50 ohms

Si on prend par exemple les valeurs de 10 KO pour les deux résistances et 10 nF pour les deux condensateurs, on obtient une fréquence centrale voisine de 1,5 KHz et une bande passante qui a la forme suivante.

Remarque : la courbe s'applique au point In du synoptique et non au point Out, du fait que l'on regarde ce que le filtre laisse passer en partant de la droite et en allant vers la gauche (de la sortie de l'ampli vers son entrée).

Il se trouve que la fréquence centrale du filtre correspond à la fréquence d'oscillation de l'oscillateur, ce qui est finalement assez logique : cette fréquence est celle qui passe le mieux de la sortie vers l'entrée, il est donc normal que l'amplificateur se "focalise" plus dessus. A ce point précis de la bande passante, le déphasage entre entrée et sortie du filtre est nul, et l'atténuation est assez importante, de l'ordre de 66 % : on ne retrouve au max que le tiers environ de l'amplitude du signal d'entrée. Cette perte de niveau nécessite une compensation et donc une amplification, car si on ne rattrape pas la perte de signal, cette dernière devient de plus en plus importante au fil des rebouclages de la sortie vers l'entrée, et le signal de sortie s'amenuise rapidement et fini par disparaitre totalement : le montage n'oscille pas. En même temps, une amplification excessive va provoquer une bonne oscillation, mais avec un signal de sortie fortement distordu à cause de la saturation occasionnée par les limites haute et basse permises par le circuit d'amplification (limites liées à la tension d'alimentation et à la tension de déchet de la sortie de l'amplificateur). Il est donc nécessaire de stabiliser le facteur d'amplification et donc l'amplitude de sortie pour disposer d'un signal le plus propre possible, ce point sera abordé un peu plus loin (paragraphe Stabilisation de l'amplitude).

Schéma

Le schéma ne fait appel à aucun composant exotique et est très simple à réaliser. Il reproduit le synoptique vu avant, avec il est vrai quelques composants supplémentaires. Mais le but d'un synoptique n'est-il pas de montrer les choses en simplifié ?

Principe général
C'est ce qui a été expliqué avant. L'amplificateur est construit autour d'un AOP de type TL081, et une cellule de filtrage, composée de R1, R2, C1 et C2 permet un rebouclage positif de l'entrée vers la sortie (bouclage positif - ou réaction positive - du fait que la sortie du filtre est reliée à l'entrée non-inverseuse de l'AOP). En même temps, le gain de l'ampli est défini par les composants reliés sur son entrée inverseuse, soit R3 et R4 quand les deux diodes sont passantes ou R3 et R4 + R5 quand les diodes D1 et D2 sont bloquées.

Modification de la fréquence
Avec le schéma présenté ci-avant, la fréquence du signal de sortie est fixe. Mais il suffit de modifier la valeurs de R1 et R2 ou de C1 et C2 pour s'adapter à toute valeur désirée. On peut donc envisager de remplacer R1 et R2 par un potentiomètre double de type log ou lin (mais de très bonne qualité car il est important que les valeurs R1 et R2 restent identiques en toutes circonstances), et de commuter les condensateurs C1 et C2 au moyen d'un commutateur rotatif 2 x 6 positions, ou moins si la plage de fréquences à couvrir n'est pas très importante. Le schéma qui suit montre un exemple de ce que l'on peut faire.

Les trois condensateurs et le potentiomètre double de 2 x 100 KO (lin ou log) permettent de couvrir la plage audio de 20 Hz à 20 KHz en trois gammes.

Stabilisation de l'amplitude
Il existe plusieurs méthodes permettant de disposer d'un signal stable en amplitude, en sortie du circuit. Parmi celles-ci, on peut citer la régulation par diodes, la régulation par ampoule, la régulation par thermistance et la régulation par transistor FET (transistor à effet de champs utilisé en résistance variable). La stabilisation de l'amplitude est assurée ici par les diodes D1 et D2, qui entrent en conduction quand le signal de sortie atteind une amplitude suffisante, et qui de fait diminue le gain de l'amplificateur. Ces diodes jouent en quelque sorte le rôle de "limiteur" d'amplitude. Il existe une autre solution pour stabiliser efficacement l'amplitude du signal de sortie, qui consiste à utiliser une petite lampe à incandescence à la place de R3.

L'ampoule présente en effet une résistance interne qui augmente quand la tension augmente à ses bornes et que le filament chauffe. Cette ampoule peut être un modèle dont la tension de service est comprise entre 6 V et 110 V, et dont la consommation nominale est de quelques dizaines ou centaines de mA, par exemple une ampoule de 12 V / 20 mA ou 60 mA. Le potentiomètre RV1 doit être ajusté pour que le signal de sortie soit sinusoïdal et avec le minimum de distorsion. Notons qu'avec cette méthode, le taux de distorsion peut remonter un peu dans les basses fréquences.
Remarque : la régulation avec ampoule est la plus ancienne et est encore utilisée de nos jours, car elle permet d'obtenir de bonnes performances et bénéficie d'une simplicité de mise en oeuvre sans égal. Il faut cependant être conscient que cette méthode n'est pas sans défaut (sinon pourquoi en chercher d'autres). Il existe plusieurs types d'ampoules à filament, et chaque type d'ampoule présente des caractéristiques électriques qui lui sont propres. Les caractéristiques principales exploitées dans le cas présent sont le temps de réactivité et l'inertie. Un filament long et fin réagit rapidement et la variation de la résistance en fonction de l'échauffement est importante, et présente une faible inertie. En outre, un tel filament est très sensible aux vibrations mécaniques et un choc sur le circuit peut entraîner une modulation d'amplitude parasite. Un filament court et épais offre une meilleure stabilité mécanique mais la variation de la résistance en fonction de l'échauffement est plus faible, et le courant absorbé est plus important, ce qui impose que le circuit oscillateur soit en mesure de délivrer une puissance suffisante (un simple AOP peut ne plus suffire). Certains auteurs préconisent l'emploi de lampes dont la tension de service est comprise entre 30 V et 110 V, par exemple une ampoule 48 V / 3 W. Dans tous les cas, l'ampoule doit s'illuminer faiblement en fonctionnement nominal, pour une dynamique de variation optimale et une durée de vie maximale.

Modification de la forme d'onde
Tel quel, le montage est conçu pour délivrer un signal de forme sinusoïdale, mais il est possible de lui faire sortir un signal de forme rectangulaire. Pour ce faire, rien de plus simple, il suffit d'augmenter la valeur de R4 dans une grande proportion, et la porter par exemple à 1 MO (en pratique 100 KO suffisent déjà).
Remarque : la fréquence d'oscillation varie légèrement en fonction de la valeur donnée à R4.

Circuit imprimé

Réalisé en simple face. Dans la version avec fréquence variable, il ne sera pas bien compliqué d'utiliser ce circuit imprimé et de relier les commutateurs et potentiomètre double à l'emplacement des composants R et C à remplacer.


Electronique - Realisations - Generateur audio 012

Sommaire | Services Pro | Musiques | Publications | Connectique | Electronique | Logiciels | Divers | Contacts | Liens | Glossaire | Historique

Electronique > Réalisations > Générateurs > Générateur audio 012

Dernière mise à jour : 19/01/2014

Présentation

Ce générateur BF délivre un signal audio sinusoïdal de fréquence fixe (aux alentours de 1 kHz) avec une amplitude de quelques mV, et s'alimente via un +48 V Phantom. Il convient pour tester rapidement l'entrée micro d'une console ou d'un enregistreur portable sans sortir un micro.

Il se connecte directement sur une XLR d'entrée microphone dont l'alim phantom est activée, et fournit son petit signal audio de façon totalement autonome. Tout comme pour le générateur audio 011, une version CMS serait sans doute pratique.

Schéma

Le coeur du montage est un oscillateur à pont de Wien, comme celui décrit en page générateur audio 010.

Oscillateur BF
Le circuit repose sur l'emploi d'un AOP monté en amplificateur, et où le signal de sortie est réinjecté dans l'entrée en passant par un filtre passe-bande (R1/C1 et R2/C2). La fréquence d'oscillation correspond à la fréquence centrale du filtre, qui est privilégiée par rapport aux autres. Tout repose sur l'AOP U1:A et ses composants périphériques R1 à R6, C1, C2, D1 et D2. Les deux diodes D1 et D2 permettent de stabiliser l'amplitude du signal de sortie, que l'on récupère sur la broche 1 du circuit intégré. Ce signal arrive sur un second AOP (U1:B) monté en suiveur de tension, dont le seul but est d'isoler l'oscillateur de l'entrée micro à tester. Son gain en tension est de 1 (0 dB). La sortie de ce second AOP correspond au signal "point chaud" du générateur, on ne sera donc pas trop surpris de la voir raccordée à la broche 2 de la prise de sortie XLR (J1), via une résistance (R10) et un condensateur de liaison (C3). La résistance R10 permet d'atténuer sérieusement l'amplitude du signal délivré par l'oscillateur, elle forme un pont diviseur avec la résistance (l'impédance) d'entrée micro à tester. Le condensateur C3 quant à lui bloque la composante continue superposée au signal BF qui aimerait bien sortir avec lui, et en même temps il bloque la tension de l'alim phantom qui elle aimerait bien rentrer dans le montage par une porte détournée. Pour le signal "point froid", le rincipe est exactement le même, on utilise un troisième AOP (U1:C) pour inverser la polarité du signal délivré par le générateur et les composants R1 et C4 copie leur fonction sur celle de R10 et C3. Pour que l'oscillation sur l'AOP U1:A ait lieu et se maintienne, il faut que l'amplificateur ait un gain de 3. S'il est inférieur, on obtient à la mise sous tension un bref signal amorti, et s'il est trop élevé, l'amplitude augmente rapidement jusqu'à saturation. Le potentiomètre RV1 permet de régler le taux d'amplification une bonne fois pour toute.

Alimentation (de l'oscillateur)
L'alimentation de l'oscillateur est prélevée sur la même XLR qui sert de sortie, au travers des résistances R12 et R13 de 22 kO et de R14 de 56 ohms, suivies d'une régulation de tension par les deux diodes zener D3 et D4 de 4,7 V et d'un filtrage simple mais suffisant composé de C5 et C6. Pourquoi utiliser deux diodes zener et non pas une seule, ce qui aurait suffit ? Pour changer un peu. L'AOP est alimenté par une tension simple (non symétrique) et il lui faut ici un point de référence central de valeur Valim / 2 pour fonctionner. Ce point central est celui des deux diodes zener D3 et D4, il correspond au repère Vb indiqué sur le schéma. C'est sur ce point que sont polarisées les entrées des AOP U1:A (via R2 et R3) et U1:C (via R9). Oui, vous pouvez appeler cela une masse virtuelle. Si vous posez la pointe de touche noire de votre multimètre sur la ligne Vb, et qu'ensuite vous posez la pointe de touche rouge (du même multimètre de préférence) sur les broches 4 et 11 du circuit intégré, vous trouverez respectivement des tensions de +4,7 V et -4,7 V. Mince alors, on a une alimentation symétrique ! Voyons maintenant à quoi correspond ce mic-mac autour de l'inverseur SW1, pile 9 V et résistance R14. Normalement, ce circuit est prévu pour fonctionner avec une alimentation phantom 48 V. mais s'il nous vient l'envie de tester une entrée micro dépourvue d'alim phantom avec ce générateur, c'est fichu. Alors, pour parer à toute éventualité et pour faire comme certaines DI actives, un petit inverseur (SW1) permet de choisir entre alimentation Phantom et alimentation par pile. Il peut paraître surprenant d'utiliser une pile de 9 V et de garder les diodes zener de 4,7 V. Après tout, la somme des deux zener donne 9,4 V, qui est supérieure à la tension de la pile. Normalement, ça ne fonctionne pas dans ce sens car les diodes zener ne recoivent pas assez de courant pour fonctionner correctement et leur résistance interne est plus élevée qu'en condition normale, ce qui pousse à avoir une masse virtuelle de moins bonne qualité (et une tension inférieure à leur tension nominale). J'ai bien dit normalement. Si ce choix vous gêne (et je vous comprendrai), n'hésitez pas une seule seconde à utiliser des zener de 4,3 V ou même de 3,9 V. Je ne vous en voudrai pas.

Prototype

Pas encore réalisé. Il le sera sur plaque sans soudure et je le testerai sur les entrées de ma RME FireFace 800 et de mes enregistreurs portables DR100 et DR680.

Circuit imprimé

Non réalisé.

Historique

19/01/2014
- Première mise à disposition.


Generateur_OR778_B


Radio-Constructeur 1964


Toute l'électronique 1967


PW_01 ETSF_H.SUTANER


ELECTRONIQUE 3D - Generateur de test sinusoidal

Vu dans ... http://www.electronique-3d.fr/Generateur_de_test_sinusoidal.html

- Un petit générateur BF portatif est un instrument extrêmement pratique lorsqu’il s’agit de tester le trajet du signal dans un appareil audio quel qu’il soit. Tant qu’il suffit de procéder à une vérification rapide du fonctionnement, un tel générateur peut être d’une simplicité étonnante.

Il suffit d’avoir à sa disposition un signal sinusoïdal de l’ordre de 1 kHz et la distorsion qu’il peut présenter n’a pas la moindre importance. La compacité et la faible consommation sont les aspects les plus importants dont il faudra tenir compte. Et c’est très précisément le profil auquel répond le générateur décrit ici. Il se résume à quelques composants courants, génère un signal de test de 889 Hz sous une tension de 1 Veff et ne consomme que 20 mA !
- Cette dernière caractéristique se traduit, pour la pile compacte de 9 V utilisée, par une durée de vie de quelque 25 000 heures, ce qui est proche de la vie éternelle dans la présente application.

- Comme nous l’apprend un coup d’oeil au schéma, nous nous trouvons ici en présence d’un oscillateur à pont de Wien classique dont l’élément actif est un amplificateur opérationnel du type TLC271 monté en mode faible puissance (low power mode). Le pont de définition de la fréquence prend la forme de C1, C2 et des résistances R1 à R4.
Les résistances R3 à R6 fixent l’amplificateur opérationnel à la moitié de la tension d’alimentation, les résistances R5 et R6 faisant également partie de la contre-réaction. On fixe, par le biais de P1, le gain à un facteur de 3 approximativement. D1 et D2 limitent l’amplitude.

- Le principe de la limitation mise en oeuvre ici reposant sur la non-linéarité des diodes, l’existence d’une certaine distorsion est inévitable. À la tension de sortie nominale de 1 Veff la distorsion du générateur est de l’ordre de 10%. Cette caractéristique ne devrait pas constituer de problème pour la majorité des applications de « test rapide ». Si l’on ne peut se faire à ces 10% de distorsion, il est facile de diminuer cette valeur en mettant la broche 8 de IC1 à la masse.

- Ce faisant, la consommation du montage passe à 0,64 mA (valeur qui reste faible), mais la distorsion chute à quelque 0,7% à condition de bien régler le circuit. Il faudra, si l'on ne dispose pas d’un distorsiomètre ou d’un autre appareil permettant le réglage de cette caractéristique, vous résoudre à fixer la tension de sortie à 1 Veff et vous vous trouverez tout près de la valeur de distorsion minimale.

- Une remarque finale : il n’y a pas le moindre problème à utiliser, pour C1 et C2, des condensateurs céramique classique vu que l’on ne mesure pas la valeur de la distorsion au centième de pourcent.
© Elektor


ELECTRONIQUE 3D - Oscillateur à pont de Wien

Vu dans ... http://www.electronique-3d.fr/Oscillateur_a_pont_de_Wien.html

Oscillateur à pont de Wien

Oscillateur a pont de wien
- Voici une configuration qui s’apparente fort, à première vue, au classique oscillateur à pont de Wien. Une variante quelque peu différente, pourtant, puisque l’accord ne dépend ici que d’un seul composant, avec l’avantage considérable qu’il ne requiert pas de potentiomètre stéréo à tolérance étroite, mais qu’un potentiomètre simple ordinaire fait l’affaire. On se retrouve ainsi avec P1 comme réglage unique et dans le cas présent, la plage s’étend de 340 Hz à 3,4 kHz.
L’équivalent du pont de Wien se compose donc de R1 / C1 et R2 + P1 / C2. Mais comme le célèbre facteur 3 d’atténuation n’est plus de mise, le critère d’oscillation à satisfaire réside dans la valeur du courant de réaction dans R2+P1.
Un seul amplificateur opérationnel ne nous suffit plus, nous devons faire appel à un étage inverseur, IC1b, dans lequel D1 et D2 ont pour tâche la stabilisation d’amplitude. Au moment de déterminer les valeurs de chaque composant, on s’accordera à maintenir une certaine homogénéité entre R4 d’une part et R5, R6, R7, P2, D1 et D2 d’autre part. Le potentiomètre P2 est placé de manière à ce que la sortie ne soit pas soumise à la tension d’alimentation.
Une disposition qui fournit la distorsion minimale, d’ailleurs le prototype nous a permis de mesurer moins de 0,1 %. À la recherche des meilleurs résultats, il est payant d’expérimenter quelque peu avec les valeurs de R5, la résistance parallèle R6 et P2. Pour régler la fréquence, on peut choisir P1 aussi bien linéaire que logarithmique, ce dernier fournit même une échelle plus « linéaire ». En théorie, la fréquence est prescrite par la formule 1/(2π × R1 × C1 × √α), dans laquelle α remplace le rapport (R2+P1) / R1. En outre, R3 = R1 et C1 = C2.
L’honnêteté commande de mentionner que l’avantage de la simplicité de réglage s’accompagne d’un inconvénient. La fréquence d’oscillation présente une certaine dépendance à l’amplitude, que le dispositif de stabilisation mis en œuvre ici ne peut complètement corriger. Dans les applications critiques, le montage de stabilisation D1 / D2 doit céder la place à un vrai circuit de régulation d’amplitude.
La consommation de l’ensemble, sans charge, s’établit autour de 4 mA. Sous ±15 V d’alimentation, la tension de sortie maximale se monte environ à 9,4 Veff. Avec l’amplificateur opérationnel utilisé ici, un TL072, le circuit fonctionne dès ±5 V.

© Elektor


Electronique Pratique Mars_1990 Pont de Wien


electronique.aop.free.fr

Vu dans ... http://electronique.aop.free.fr/AOP_lineaire_NF/24_Wien.html

Oscillateur à pont de Wien

Ce circuit est un oscillateur sinusoidal à pont de Wien. Je ne ferais pas ici faire un cours détaillé sur les oscillateurs en électronique, c'est un sujet bien trop vaste et ce n'est pas le but de ce site, cependant je vous donne deux approches pour étudier de ce montage qui nécessitent, soit de maitriser les équations différentielles du second ordre, soit de connaitre la théorie des oscillateurs (conditions d'oscillation) et les impédances complexes.

Première approche : régime temporel

Ce montage fonctionne en régime linéaire par la présence d'une boucle de contre réaction négative. On peut écrire dans un premier temps :

Considerons à présent la boucle de contre-réaction positive constituée des ensembles série et parallèle R-C (ces ensembles forment ce que l'on nomme pont de Wien), avec I le courant circulant dans l'ensemble série :

Appliquons la loi des noeuds à l'entrée de l'ensemble parallèle R//C :

On voit tout de suite que si k=1/3 l'équation différentielle devient :

L'équation temporelle de la tension de sortie correspond bien à un signal sinusoidal de pulsation 1/RC. Les constantes A et B étant à déterminer à partir des conditions initiales du circuit .

Seconde approche : régime variable

Dans un premier temps, redéssinons le schéma tel que ci-dessous :

  • Partie A : amplificateur non inverseur.
  • Partie K : filtre passe-bande ou pont de Wien.
On obtient :

Si l'on suit les conditions d'oscillation, on trouve :

On retrouve la même condition sur R1 et R2 et une pulsation identique, ce qui est rassurant (!).

Oublions un instant les mathématiques et posons nous la question suivant : "Que se passe t'il physiquement dans ce montage ?" En réalité, ce sont les bruits propres aux composants et aux lignes qui vont amorcer l'oscillateur. Nous savons que le bruit est composé d'une multitude de composantes fréquentielles (on parle aussi d'harmoniques, merci M.Fourier). Or le pont de contre-réaction positive est un filtre passe-bande qui ne va laisser passer que la composante qui nous intéresse, en l'occurence la fréquence d'oscillation désirée. La réaction étant positive, cette composante va s'ajouter à la sortie pour que cette dernière devienne pure (au sens fréquenciel) petit à petit.

La stabilité en fréquence dépend principalement du coefficient de qualité du pont. Pour ceux qui sont intéressé par les oscillateurs, je vous conseille vivement le livre paru chez Publitronic : 300 oscillateurs.


Pont de Wien - Wikiwand

Vu dans ... https://www.wikiwand.com/fr/Pont_de_Wien

Pont de Wien

Un article de Wikipédia, l'encyclopédie libre.

Pont de Wien, Uwe- est la tension sinusoïdale d'alimentation, Uwy- la tension mesurée.
Pont de Wien, Uwe- est la tension sinusoïdale d'alimentation, Uwy- la tension mesurée.

Le pont de Wien est un type de montage en pont, développé en 1891 par le physicien Max Wien [ 1 ] .

Utilisation originale

À l'époque de sa création, le montage en pont était un mode de mesure d'un composant par comparaison avec ceux dont les caractéristiques étaient connues. La technique consistait alors à mettre le composant inconnu sur l'une des branches du pont, puis la tension centrale était réduite à zéro en ajustant les autres branches ou en changeant la fréquence de l'alimentation. Un autre exemple typique de cette technique est le pont de Wheatstone.

Le pont de Wien permet, lui, de mesurer avec précision la capacité CX d'un composant et sa résistance RX. Il est constitué de quatre branches, le composant inconnu étant placé sur l'une d'elles, les autres branches comprenant chacune une résistance (R2, R3, R4) connue, R2 étant en série avec un condensateur C2. On applique alors au montage (entre les sommets 1-3 et 2-4) une tension sinusoïdale de pulsation ω.

Le pont est alors équilibré quand [ 2 ] :

ω 2 = 1 R x R 2 C x C 2 {\displaystyle \omega ^{2}={1 \over R_{x}R_{2}C_{x}C_{2))} [image] et C x C 2 = R 4 R 3 − R 2 R x . {\displaystyle {C_{x} \over C_{2))={R_{4} \over R_{3))-{R_{2} \over R_{x))\,.}

cette équation se simplifie si on choisit R2 = Rx et C2 = Cx, et il en résulte alors R4 = 2R3.

Oscillateur à pont de Wien

Le schéma de l'oscillateur à pont de Wien

Il peut aussi être utilisé pour réaliser un oscillateur produisant des signaux sinusoïdaux avec une faible distorsion.

Rappelons qu'un oscillateur est composé de deux parties :

  • un amplificateur : selon les époques, celui-ci a été réalisé avec un tube à vide, ou avec un ou plusieurs transistors bipolaires ou à effet de champ ; de nos jours, on peut facilement utiliser un amplificateur intégré à une puce électronique;
  • un circuit de réaction, placé entre la sortie de l'amplificateur et son entrée ; ce circuit met en œuvre diverses impédances : résistances, condensateurs, bobines, quartz.

C'est le circuit de réaction qui détermine la fréquence d'oscillation. En effet, celle-ci se produit à une fréquence où la condition d'oscillation n.Go = 1 est satisfaite. Les termes n et Go, tous deux des nombres complexes, représentent le « gain » du circuit de réaction et le gain de l'amplificateur.

À la fréquence f = 1 2 π R 1 R 2 C 1 C 2 {\displaystyle f={\frac {1}{2\pi {\sqrt {R_{1}R_{2}C_{1}C_{2)))))) [image] soit f = 1 2 π R C {\displaystyle f={\frac {1}{2\pi {RC)))) [image] , le « gain » du filtre de Wien vaut 1/3 et le signal de sortie est en phase avec le signal d'entrée. En raccordant le filtre de Wien entre la sortie et l'entrée d'un amplificateur de gain 3 (un amplificateur opérationnel dans la figure), on obtient un oscillateur qui produit une sinusoïde à la fréquence indiquée.

En général, on prend R 1 = R 2 {\displaystyle R_{1}=R_{2)) [image] et C 1 = C 2 {\displaystyle C_{1}=C_{2)) [image] .

Stabilisation de l'amplitude des oscillations

Le gain de l'AOP dépend des résistances R3 et R4 ; pour avoir un gain de 3, on prendra R3 = 2 R4.

Mais les imprécisions des valeurs de R3 et R4 font que cette condition n'est jamais tout à fait remplie. Que se passe-t-il alors :

  • si R3 < 2 R4, l'oscillateur n'oscille pas ;
  • si R3 > 2 R4, l'oscillation démarre bien, l'amplitude croît jusqu'à la valeur limite, déterminée par la tension d'alimentation de l'AOP ; le problème, c'est que dans cette condition la forme d'onde est distordue, les sommets sont aplatis.

Pour remédier à ce problème, on remplace R3 ou R4 par une CTP ou une CTN (résistances dont la valeur croît ou décroît avec la température). L'amplitude se stabilisera à une valeur telle que R3 sera égale à 2 R4.

Cela fonctionne de la façon suivante : supposons que R4 soit une CTP. Si, pour une raison quelconque, l'amplitude croît légèrement, la puissance dissipée dans R4 augmente, ce qui fait croître sa valeur et donc réduit le gain de l'AOP, ce qui ramène l'amplitude à son niveau correct.

Bref historique

Le pont de Wien a été développé à l'origine par Max Wien en 1891. À cette époque, Wien n'avait pas les moyens de réaliser un circuit amplificateur et donc n'a pu construire un oscillateur. Le circuit moderne est dérivé de la thèse de maîtrise de William Hewlett en 1939. Hewlett, avec David Packard, cofonda Hewlett-Packard. Leur premier produit fut le HP 200A, un oscillateur basé sur le pont de Wien. Le 200A est un instrument classique connu pour la faible distorsion du signal de sortie.

La CTP utilisée était simplement un filament de lampe à incandescence. Les oscillateurs à pont de Wien modernes utilisent, à la place d'un filament d'ampoule, des transistors à effet de champ ou des cellules photoélectriques. Des taux de distorsion de l'ordre de quelques parties par million peuvent être obtenus en améliorant légèrement le circuit original de W. Hewlett.


Oscillateur à pont de WIEN

Vu dans ... http://dominique.richier.free.fr/fichtml/aoprk400.html

Oscillateur à pont de WIEN.

1. Le montage proposé.

1.1. Schéma du montage.

1.2. Les éléments du montage.

• L'oscillateur électrique est constitué, d'un amplificateur non inverseur bâti autour d'un amplificateur opérationnel muni des résistances R1 et R2 assurant une réaction négative ; et d'un réseau déphaseur (le pont de WIEN) constitué par la mise en série, d'un dipôle série R0, C0, et d'un dipôle parallèle R0, C0.
• On fait l'hypothèse que l'amplificateur opérationnel est quasiment idéal, il n'absorbe aucun courant sur ses entrées différentielles, sont gain différentiel est "très grand"...

1.3. Principe de fonctionnement.

• Le réseau déphaseur soumis au potentiel de sortie vs(t)vs(t) de l'amplificateur non inverseur, alimente sous le potentiel vr(t)vr(t) l'entrée de ce même amplificateur ; on dit alors que l'on a affaire à un système bouclé.
• Pour une fréquence fnfn caractéristique du réseau déphaseur, le potentiel vr(t)vr(t) est en phase avec le potentiel vs(t)vs(t) .
• Dans ces conditions, le potentiel vr(t)vr(t), image du potentiel vs(t)vs(t), est amplifié par l'amplificateur non inverseur, qui pour un réglage convenable des résistances R1 et R2 compense l'atténuation apportée par le réseau déphaseur.
• Ainsi peut-on (ici) créer et entretenir des oscillations électriques dont on maîtrise a priori la fréquence.

2. Analyse du fonctionnement du montage dans l'hypothèse du régime linéaire,
analyse en régime harmonique.

2.1. Hypothèses.

• On se place dans le cadre du fonctionnement décrit au paragraphe 1.3..
• On retient donc l'hypothèse du régime harmonique et on suppose que le système fonctionne en régime linéaire.
• On suppose également que l'amplificateur opérationnel a un comportement quasiment idéal.

2.2. Étude de l'amplificateur non inverseur.

L'amplificateur non inverseur.

• On suppose ici que l'amplificateur est soumis à un signal d'entrée ve(t)ve(t) (qui après bouclage s'identifiera à vr(t)vr(t)).
• Compte tenu des hypothèses du paragraphe 2.1., on peut écrire :
Vs−−=(1+R2R1)Ve−−Vs̲=(1+R 2R 1)Ve̲, où Vs−−Vs̲et Ve−−Ve̲sont les représentants complexes des potentiels vs(t)vs(t)et ve(t)ve(t), qui sont donc a priori, des fonctions sinusoïdales du temps.

2.3. Étude du réseau déphaseur.

Pont de WIEN.

• Ce réseau déphaseur constitue ce que l'on appelle un pont de WIEN.
• On peut écrire : Vr−−=Vs−−1+(R0+1jC0ω).(1R0+jC0ω)Vr̲=Vs̲1+(R 0+1 j C 0 ω).(1 R 0+j C 0 ω) .
- Où : Vr−−Vr̲et Vs−−Vs̲sont les représentants complexes des potentiels vr(t)vr(t)et vs(t)vs(t), qui sont a priori, des fonctions sinusoïdales du temps.
- La quantité : R0+1jC0ωR 0+1 j C 0 ω représente l'impédance complexe du circuit série R0, C0 .
- La quantité : 1R0+jC0ω1 R 0+j C 0 ω représente l'admittance complexe du circuit parallèle R0, C0 .
• Un développement élémentaire conduit à : Vr−−=jR0C0ωVs−−1−R20C20ω2+j3R0C0ωVr̲=j R 0C 0 ω Vs̲1-R 02C 02 ω 2+j 3 R 0C 0 ω.
- On pose : ωn=1R0C0⇔fn=12πR0C0ωn=1 R 0C 0⇔fn=1 2 π R 0C 0, alors il vient : Vr−−=jffn .Vs−−1−(ffn)2+j3ffnVr̲=j f fn .Vs̲1-(f fn)2+j 3 f fn.
- On observe que pour f=fnf=fn, Vr−−=Vs−−3Vr̲=Vs̲3.
- Alors vr(t)vr(t) et vs(t)vs(t)sont en phase, cependant l'amplitude Vr de vr(t)vr(t) n'est plus que le tiers de l'amplitude Vs de vs(t)vs(t) .
Note : Ici fn≈1kHzfn≈1 kHz.

2.4. Condition d'entretien des oscillations.

• Des oscillations électriques à la fréquence fnfn peuvent apparaître au sein du circuit bouclé, à condition que l'amplificateur ait un gain égal (ici) au minimum à trois, pour compenser l'atténuation apportée par le réseau déphaseur.
• On doit alors vérifier : 3≤(1+R2R1)⇒2R1≤R23≤(1+R 2R 1)⇒2 R 1≤R 2.
Note : Si R1=4,7 kΩR 1=4,7 k Ω, alors il faut choisir 9,4 kΩ≤R29,4 k Ω≤R 2, et dans la série E12, on choisira : R2=10 kΩR 2=10 k Ω.
• Nous venons de retrouver les conditions dites de BARKHAUSEN.

2.5. Quelques remarques.

Oscillation du montage à AOP.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.
• Sur la base des résultats précédents, on câble la structure et l'on obtient bien les oscillations prévues ; cependant nous ne sommes pas maître de l'amplitude des oscillations, et on observe même que le signal de sortie est quelque peu écrêté à la valeur des potentiels de saturation ±Vsat±V sat de l'amplificateur opérationnel.
• La fréquence d'oscillation est proche de 1 kHz.
• L'approche intuitive précédente, décrit de manière imparfaite le fonctionnement du montage ; ainsi sommes nous incapables de prédire l'amplitude des oscillations vs(t)vs(t) et vr(t)vr(t).
• Aussi dans les paragraphes qui suivent, allons nous prendre en compte une non linéarité qui apparaît lors du fonctionnement du montage et qui permet de décrire de manière intelligible son fonctionnement.

3. Analyse du fonctionnement du montage dans l'hypothèse de l'existence d'une non linéarité.

3.1. Origine de la non linéarité.

• À l'évidence c'est l'amplificateur non inverseur qui est à l'origine d'une non linéarité que nous allons modéliser sous la forme d'une saturation.

Ecrêtage de la tension de sortie de l'amplificateur.

Note : Nous faisons toujours l'hypothèse que l'amplificateur opérationnel a un comportement idéal, et les potentiels de saturation supposés symétriques sont notés ±Vsat±V sat.
• Tant que : |ve(t)|<Vsat1+R2R1|ve(t)|<V sat 1+R 2R 1 , l'amplificateur non inverseur a un comportement linéaire, et on peut écrire : vs(t)=(1+R2R1)ve(t)vs(t)=(1+R 2R 1)ve(t) .
• Dès que : Vsat1+R2R1≤|ve(t)|V sat 1+R 2R 1≤|ve(t)| , l'amplificateur non inverseur est saturé et vs(t)=±Vsatvs(t)=±V sat , du signe de ve(t)ve(t).

3.2. Étude du réseau déphaseur, équation différentielle liant vr(t)vr(t) et vs(t)vs(t).

Réseau dephaseur en régime transitoire.

• À chaque instant on peut écrire : i1=i2+i3i 1=i 2+i 3 , i3=vrR0i 3=vrR 0 , q1=C0(vs−R0.i1−vr)q 1=C 0(vs-R 0.i 1-vr) , i1=dq1dti 1=d q 1dt , et i2=C0dvrdti 2=C 0 d vrdt .
• Un développement élémentaire conduit à l'équation différentielle suivante :
R20C20d2vrdt2+3R0C0dvrdt+vr=R0C0dvsdtR 02C 02 d 2 vrdt 2+3 R 0C 0 d vrdt+vr=R 0C 0 d vsdt .

3.3. Équations décrivant le fonctionnement du système bouclé.

3.3.1. Remarque.

• Comme le système est maintenant bouclé, ve(t)ve(t) s'identifie à vr(t)vr(t).

3.3.2. Cas du fonctionnement en régime linéaire.

• Alors : |vr(t)|<Vsat1+R2R1|vr(t)|<V sat 1+R 2R 1 ; d'où vs(t)=(1+R2R1)vr(t)vs(t)=(1+R 2R 1)vr(t) , et dvs(t)dt=(1+R2R1)dvr(t)dtd vs(t)dt=(1+R 2R 1)d vr(t)dt .
• On a donc une équation de contrainte liant vs(t)vs(t) à vr(t)vr(t) ; aussi l'équation différentielle développée au paragraphe 3.2. s'écrit-elle :
R20C20d2vrdt2+3R0C0dvrdt+vr=R0C0(1+R2R1)dvr(t)dtR 02C 02 d 2 vrdt 2+3 R 0C 0 d vrdt+vr=R 0C 0(1+R 2R 1)d vr(t)dt .
- Soit encore : R20C20d2vrdt2+R0C0(3−(1+R2R1))dvrdt+vr=0R 02C 02 d 2 vrdt 2+R 0C 0(3-(1+R 2R 1))d vrdt+vr=0 .
- Ou plus simplement : R20C20d2vrdt2+R0C0(2−R2R1)dvrdt+vr=0R 02C 02 d 2 vrdt 2+R 0C 0(2-R 2R 1)d vrdt+vr=0.

3.3.3. Cas du fonctionnement en régime non linéaire.

• Alors : Vsat1+R2R1≤|vr(t)|V sat 1+R 2R 1≤|vr(t)| ; d'où vs(t)=±Vsatvs(t)=±V sat , du signe de vr(t)vr(t), et dvs(t)dt=0d vs(t)dt=0 .
• On a donc une nouvelle équation de contrainte liant vs(t)vs(t) à vr(t)vr(t) ; aussi l'équation différentielle développée au paragraphe 3.2. s'écrit-elle maintenant :
R20C20d2vrdt2+3R0C0dvrdt+vr=0R 02C 02 d 2 vrdt 2+3 R 0C 0 d vrdt+vr=0 .

3.3.4. Mise en forme des équations.

3.3.4.1. Généralités.

• Suivant les usages... nous allons mettre les équations sous forme canonique, c'est à dire :
1ω2nd2vrdt2+2zωndvrdt+vr=01 ωn 2d 2 vrdt 2+2 z ωnd vrdt+vr=0 .
- Où ωnωn désigne la pulsation naturelle du système physique (fn=ωn2πfn=ωn 2 π en est la fréquence naturelle) , et où zz désigne le facteur d'amortissement du système physique.

3.3.4.2. Mise en forme.

• Pour : |vr(t)|<Vsat1+R2R1|vr(t)|<V sat 1+R 2R 1 , on est en régime linéaire, et on écrit :
1ω2nd2vrdt2+2zLωndvrdt+vr=01 ωn 2d 2 vrdt 2+2 zLωnd vrdt+vr=0 .
- Avec : ωn=1R0C0ωn=1 R 0C 0 , fn=12πR0C0fn=1 2 π R 0C 0 , et zL=1−R22R1zL=1-R 2 2 R 1 .
• Pour : Vsat1+R2R1≤|vr(t)|V sat 1+R 2R 1≤|vr(t)| , on est en régime non linéaire, et on écrit :
1ω2nd2vrdt2+2zNLωndvrdt+vr=01 ωn 2d 2 vrdt 2+2 z NLωnd vrdt+vr=0 .
- Avec une fois encore : ωn=1R0C0ωn=1 R 0C 0 , fn=12πR0C0fn=1 2 π R 0C 0 , et zNL=32z NL=32 .

3.3.5. Faisons une application numérique et tirons en les conséquences.

• Avec R0 = 5,6 kΩ et C0 = 27 nF, il vient: fn≈1kHzfn≈1 kHz.
• Pour le régime linéaire, avec R2 = 10 kΩ et R1 = 4,7 kΩ, il vient: zL≈−0,064zL≈-0,064 ; alors zL<0zL<0 .
- Aussi les racines de l'équation caractéristique : p2ω2n+2zLpωn+1=0p 2 ωn 2+2 zL p ωn+1=0, sont-elles égales à :
p1/2=−ωnzL±jωn√1−z2Lp 1/2=-ωnzL±j ωn 1-zL 2.
- Comme zL<0zL<0 , ces racines sont à partie réelle positive (−ωnzL)(-ωnzL) , cela conduit à une solution fonction sinusoïdale du temps (présence du terme jωn√1−z2Lj ωn 1-zL 2 ), pondérée par le facteur e−ωnzL te-ωnzL t qui correspond à une croissance exponentielle dans le temps, ce qui entraîne inévitablement le dispositif vers une saturation !
• Pour le régime non linéaire, zNL=1,5z NL=1,5 ; alors 0<zNL0<z NL .
- Aussi les racines de l'équation caractéristique : p2ω2n+2zNLpωn+1=0p 2 ωn 2+2 z NL p ωn+1=0, sont-elles égales à :
p1/2=−ωnzNL ±ωn√z2NL−1p 1/2=-ωnz NL ±ωn z NL 2-1.
- Comme 0<zNL0<z NL , ces racines sont réelles et négatives, ce qui conduit à une solution contenant des exponentielles qui décroissent dans le temps, ce qui entraîne a priori le dispositif vers l'état de repos !
• Il est clair que la discussion relative à la description des oscillations électriques ne peut plus aller plus avant ; aussi "faut-il passer" à l'intégration des équations ; c'est ce que nous allons décrire dans les paragraphes qui suivent, en mettant en oeuvre une méthode d'intégration numérique, la méthode de RUNGE-KUTTA d'ordre quatre (RK4,4) .

4. Mise en œuvre de la méthode de RUNGE-KUTTA RK4,4,
pour déterminer numériquement (puis graphiquement),
l'allure des signaux générés par l'oscillateur à pont de WIEN.

4.1. La méthode de RUNGE-KUTTA RK4,4.

• La méthode de RUNGE-KUTTA RK4,4 est une méthode numérique permettant de résoudre dans le cas le plus général, un système d'équations différentielles ordinaires (EDO) du premier ordre par approximation. Cette méthode a été mise au point par les mathématiciens Carl RUNGE et Martin Wilhelm KUTTA.
- Rappelons qu'une équation différentielle ordinaire (EDO) de degré n, est de la forme :
F(x,y(x),.y(x),..y(x),...,y(n)(x))=0F(x,y(x),y.(x),y..(x),...,y(n)(x))=0, où y(n)(x)y(n)(x) est la derivée n-ième de y(x)y(x) par rapport à xx.
- Pour une équation différentielle ordinaire du premier ordre, on calcule la solution de l'équation différentielle par itération, le raffinement de la méthode conduit à une erreur d'ordre quatre.
- Lorsque l'on a affaire à une équation différentelle ordinaire d'ordre n supérieur ou égal à deux, on peut la décomposer en un système de n équations différentielles ordinaires du premier ordre. On constitue alors un espace vectoriel des solutions, de dimension fini ; on dit que l'équation différentielle ordinaire de degré n est une fonction à valeur vectorielle. Bien entendu, la méthode de RUNGE-KUTTA RK4,4 s'applique à chaque composante vectorielle.

4.2. Mise en œuvre pratique de la méthode de RUNGE-KUTTA RK4,4.

4.2.1. Écriture du système d'équations différentielles ordinaires du premier ordre.

• Partons de l'expression générale de l'équation de fonctionnement :
1ω2nd2vrdt2+2zωndvrdt+vr=01 ωn 2d 2 vrdt 2+2 z ωnd vrdt+vr=0 , où zz peut prendre la valeur zLzL ou zNLz NL ; aussi l'équation n'est-elle pas à coefficients constants ! Il y a une non linéarité...
• Nous pouvons écrire l'équation sous la forme : 1ω2n..vr+2zωn.vr+vr=01 ωn 2 v..r+2 z ωn v.r+vr=0 .
- Où : .vr=dvrdtv.r=d vrdt et ..vr=d.vrdtv..r=d v.rdt .
- On peut encore écrire : ..vr=−ωn(ωnvr+2z.vr)v..r=-ωn(ωnvr+2 z v.r) .
• Nous allons décomposer cette équation différentielle ordinaire du second ordre, en un système de deux équations différentielles ordinaires du premier ordre.
• Posons : vr=u0−−−−−−−vr=u 0̲, et du0dt=u1d u 0dt=u 1 ; on en déduit u1=dvrdtu 1=d vrdt, soit .vr=u1−−−−−−−v.r=u 1̲ et du1dt=d.vrdtd u 1dt=d v.rdt, soit ..vr=du1dt−−−−−−−−−v..r=d u 1dt̲.
• L'équation s'écrit alors : du1dt=−ωn(ωnu0+2zu1)d u 1dt=-ωn(ωnu 0+2 z u 1) .
• Nous devons donc résoudre le systèmes de deux équations différentielles ordinaires du premier ordre suivant :
du0dt=u1d u 0dt=u 1
du1dt=−ωn(ωnu0+2zu1)d u 1dt=-ωn(ωnu 0+2 z u 1)
• Où : u0=u0(t)u 0=u 0(t) et u1=u1(t)u 1=u 1(t) sont des fonctions du temps tt.
Remarque : On a affaire à un système d'équations couplées, où zz peut prendre la valeur zLzL ou zNLz NL !

4.2.2. Conditionnement du calcul.

• Dans la méthode de RUNGE-KUTTA RK4,4, on programme le système des deux équations différentielles ordinaires du premier ordre, et on précise les conditions initiales (ici au nombre de deux).
• À la date t=0 st=0 s ,vr(0)=0 V⇒u0(0)=0vr(0)=0 V⇒u 0(0)=0 , et dvr(0)dt=50d vr(0)dt=50 µV/µs ⇒u1(0)=50⇒u 1(0)=50 .
Remarque : On fait l'hypothèse que le "bruit de fond" fait fluctuer le potentiel vr(t)vr(t) ...
• tt prend ses valeurs dans l'intervalle [0,tMax][0,t Max], et varie au pas ΔtΔ t.
• On prendra en compte que :
- Si : |vr(t)|<Vsat1+R2R1⇒z=zL|vr(t)|<V sat 1+R 2R 1⇒z=zL .
- Si : Vsat1+R2R1≤|vr(t)|⇒z=zNLV sat 1+R 2R 1≤|vr(t)|⇒z=z NL .
• L'algorithme de la méthode de RUNGE-KUTTA RK4,4 élabore une "table de données" constituée de n lignes contenant chacune le triplet : {t,u0(t),u1(t)t,u 0(t),u 1(t)}.
- On résoud bien notre problème sous forme numérique, et l'exploitation de la "table de données" permet ici de donner l'évolution du signal vr(t)vr(t) .

4.3. Représentations graphiques.

4.3.1. Initialisation des calculs.

• On donne : ±Vsat = ±14 V, R0 = 5,6 kΩ, C0 = 27 nF, R1 = 4,7 kΩ, R2 = 10 kΩ ou R2 = 12 kΩ .
• Ici tt prend ses valeurs dans l'intervalle [0,tMax][0,t Max], et varie au pas ΔtΔ t , avec :
tMax=25t Max=25 ms , Δt=25Δ t=25 µs.
• À la date t=0t=0 s, u0(0)=0u 0(0)=0 , et u1(0)=50u 1(0)=50 .
• Nous obtiendrons une "table de données" formée de dix mille lignes contenant chacune le triplet : {t,u0(t),u1(t)t,u 0(t),u 1(t)}.

4.3.2. Évolution de vr(t).

4.3.2.1. Pour R2 = 10 kΩ.

vs(t) pour R2 = 10 kΩ.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.

4.3.2.2. Pour R2 = 12 kΩ.

vr(t) pour R2 = 12 kΩ.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.

4.3.3. Évolution de vs(t).

4.3.3.1. Pour R2 = 10 kΩ.

vs(t) pour R2=10 kΩ.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.

4.3.3.2. Pour R2 = 12 kΩ.

vs(t) pour R2 = 12 kΩ.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.

4.3.4. Étude dans le plan de phase ; c'est l'étude de .vr(t)v.r(t) en fonction de vr(t)vr(t).

4.3.4.1. Pour R2 = 10 kΩ.

Plan de phase pour R2 = 10 kΩ.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.

4.3.4.2. Pour R2 = 12 kΩ.

Plan de phase pour R2 = 12 kΩ.

Remarque : Ce graphe a été tracé à l'aide du logiciel gnuplot®.
• Le signal électrique est bien périodique, mais il n'est certainement pas sinusoïdal !

5. Intérêt pratique et remerciements.

5.1. Intérêt pratique.

• L'étude de vr(t) confirme bien l'analyse préparatoire. Sous l'effet du "bruit de fond", l'oscillation électrique s'amorce et croît de manière exponentielle (en effet l'enveloppe de vr(t) a l'allure d'une exponentielle), bientôt on atteint la saturation et on passe en régime non linéaire, alors le signal vr(t) est contraint à décroître, puis on passe à nouveau en régime linéaire .etc.
• Certes, on ne maîtrise pas l'amplitude de l'oscillation électrique, et la tension de sortie finit par être écrêtée à ±Vsat±V sat.
• La fréquence d'oscillation reste voisine de fn≈1 kHzfn≈1 kHz.
• A priori nous aurions pu intégrer les équations différentielles, mais nous aurions eu le plus grand mal à gérer le passage du mode de fonctionnement linéaire au mode de fonctionnement non linéaire.
• Grâce à la méthode de RUNGE-KUTTA RK4,4, nous accédons aux signaux électriques "facilement".
• Cependant, nous avons dû faire une analyse serrée, et donc "un peu de belle physique"...

5.2. Remerciements.

• J'adresse mes plus vifs remerciements à Monsieur John BURKARDT, Chercheur invité du Département Informatique Scientifique, Florida State University (FSU) : John BURKARDT.
• Monsieur John BURKARDT met à notre disposition, le code source écrit en C, de la méthode de RUNGE-KUTTA RK4,4, sous le vocable rk4.c, et un fichier d'en-tête rk4.h.
- Deux algorithmes sont développés :
• "RK4 takes one Runge-Kutta step for a scalar ODE", qui permet de résoudre une équation différentielle ordinaire du premier ordre.
• "RK4VEC takes one Runge-Kutta step for a vector ODE", qui permet de résoudre un système de n équations différentielles ordinaires du premier ordre, l'équation différentielle ordinaire d'ordre n à l'origine de ce système de n équations différentielles ordinaires du premier ordre, est "bien" une fonction à valeur vectorielle.
• Monsieur John BURKARDT met également à notre disposition, le code source écrit en C, de deux exemples permettant de tester les deux algorithmes proposés, sous le vocable rk4_prb.c.
- Les trois fichiers peuvent être téléchargés à l'URL : <https://people.sc.fsu.edu/~jburkardt/c_src/rk4/rk4.html>.
• Pour ma part, je vous propose de consulter un document html que j'ai rédigé à votre intention et qui traite de la "Mise en œuvre pratique de la méthode RK4,4 pour l'oscillateur à pont de WIEN", rendez-vous à la page "AOPRK4"...
• Cette page n'aurait pas pu être composée sans les "outils" fournis par AsciiMath, à l'URL : <http://asciimath.org/>.
• Cette page a pu être développée et affichée correctement grâce à l'utilisation du réseau de distribution de contenu MathJax (CDN). Toute la documentation relative à MathJax est accessible à l'URL : <http://docs.mathjax.org/en/latest/index.html>.
• Les graphes ont été tracés à l'aide du logiciel gnuplot®, dont la documentation est accessible à l'URL : <http://www.gnuplot.info/>.
Retour à la page principale...

Copyright© 2016-2017 [ DR ] Tous droits réservés.


Oscillateur à pont de Wien

Vu dans ... http://server.idemdito.org/electro/nique/wien.htm

L'oscillateur à pont de Wien est un type d'oscillateur très utilisé. Il produit des oscillations sinusoïdales avec une bonne linéarité. C'est un circuit de base que tout électronicien doit connaitre.

Le circuit oscillant à pont de Wien n'a aucun rapport avec un quelconque pont à Vienne, c'est le nom de l'inventeur de ce circuit, qui ne vivait pas en Autriche (c'était l'époque du petit moustachu).

William Hewlett et David Packard ont commercialisé le premier oscillateur, le HP200, fabriqué dans le garage de Packard en Californie (cela ne vous rapelle rien? C'est aussi ainsi qu'a démarré Apple). C'était le premier appareil de la marque Hewlett Packard. Pour faire plus sérieux et montrer qu'ils avaient déja de nombreux appareils, ils ont commencé leur numéroration à partir de 200. A l'époque c'était le haut de gamme de l'électronique.

Un oscillateur doit avoir le signal qui se mord la queue pour pouvoir fonctionner: le signal est amplifié et retourne à l'entrée où il est à nouveau amplifié, et ceci jusqu'à ce que l'amplificateur atteint les limites de fonctionnement (tension et/ou courant maximal).

A ce moment la distortion est maximale, et ce n'est pas ce que nous voulons. Comment stabiliser l'amplitude est décrit plus loin. Il est possible de transformer le générateur sinusoïdal en générateur en créneau en éliminant la limitation de l'amplitude des oscillations. Mais d'abord il nous faut un élément qui va déterminer la fréquence.

Pour réaliser un circuit oscillant, on peut utiliser une combinaison de résistances et de condensateurs, en fait un circuit passe haut et un circuit passe bas. Aux fréquences basses, le condensateur C1 agit comme une impédance élevée et limite la tension en sortie. Aux fréquences élevées, c'est le condensateur C2 qui a une basse impédance et limite à son tour le signal en sortie.

A une fréquence donnée, le "gain" du circuit est maximal.

La fréquence atteinte est approximative et ne tient pas compte des impédances parasites. Les condensateurs ont généralement une tolérance de 20% et les résistances une tolérance de 5%.

Si nous avons maintenant un amplificateur qui amplifie 3× nous pouvons entretenir les oscillations. Si le gain est plus faible, les oscillations sont amorties et disparaissent, si le gain est plus élevé, l'amplidude des oscillations augmente jusqu'au clipping. Il faut un gain minimal supérieur à 3 pour que l'oscillateur puisse se mettre en route.

Oscillateur à lampes Hewlett Packard

Passons maintenant à l'oscillateur de Hewlett Packard. Il se compose d'un circuit oscillant avec deux tubes, le second tube est nécessaire pour déphaser le signal de 180° pour avoir une boucle de réaction positive, qui entre dans la partie amplificateur via la grille de commande (g1) du premier tube, c'est la ligne verte sur le schéma.

La contre-réaction négative (qui va limiter l'amplitude du signal) est la partie violette qui se compose d'un pont diviseur avec deux résistances. La première résistance est normale, elle se compose d'une résistance fixe et d'une résistance ajustable qui permet de doser la contre réaction et donc d'entretenir les oscillations sans écrètage. L'oscillateur produit le meilleur signal quand les oscillations ont une amplitude de 18 à 20V rms (donc environ 50 à 55Vpp).

Dans la boucle négative on voit également une lampe témoin (lampe à filament). Une lampe à incandescence à un coëfficient de température positif, la résistance augmente avec la température. Quand l'amplitude des oscillations augmente, la tension alternative aux bornes de la lampe augmente également, la température du filament augmente et donc également sa résistance. Le gain de la partie contre-réaction négative augmente, et donc le gain de l'amplificateur diminue jusqu'à ce que l'oscillation se stabilise.

Le signal ainsi obtenu va vers un amplificateur classique qui se compose d'une pentode préamplificatrice et d'une pentode de puissance, un tube 6V6 bien connu. La sortie se fait via un transformateur qui permet une sortie symmétrique si nécessaire. C'est un amplificateur pour fréquences audio.

Pour avoir une stabilisation la plus optimale possible, il faut que la lampe fonctionne à 10% de sa tension nominale. C'est à cette tension que la variation de résistance est la plus importante. La lampe est égalemnt parcourue par le courant cathodique du tube, ce qui permet en plus une stabilisation du point de fonctionnement de la pentode.

Le système de stabilisation avec lampe incandescente a été utilisé dans tous les oscillateurs à pont de Wien jusque dans les années 1970. Il a comme inconvénient qu'il ne permet pas des oscillations basse fréquence, car l'inertie thermique du filament n'est pas assez importante: la résistance de la lampe varie avec l'oscillation, ce qui est défavorable, cela produit un sinus qui est applati d'un coté et étiré de l'autre. Ce sont des distortions harmoniques paires ou impaires selon que la lampe a une composante continue ou non. Une page où on vous parle d'harmoniques paires et impaires (et de distortion d'intermodulation).

Tous les systèmes de stabilisation ultérieurs qui utilisent des diodes zener, des thermistances ou des varistors ont un tel inconvénient. Le seul système qui fonctionne bien, c'est un système ou le signal de sortie est redressé et filtré et commande un transistor mosfet dont la résistance varie avec la tension appliquée sur le gate (voir plus bas pour un schéma de principe).

Schéma moderne avec a-op et lampe

Bon, mais maintenant nous voulons un circuit oscillant simple et performant, donc avec un ampli opérationnel et une lampe incandescente.
Les amplis opérationnels courants (du genre LM471) ne permettent par un courant suffisant pour alimenter une petite ampoule, même à 1/100 de sa puissance nominale. Les distortions deviennent trop importantes quand l'ampli travaille près de ces limites.

Mais nous avons un amplificateur qui peut nous aider: il s'agit d'un LM386, un petit amplificateur audio qui peut fournir une puissance de quelques centaines de mW, suffisant pour alimenter la lampe incandescente (on n'a rien trouvé de mieux qu'une telle ampoule...)

L'ampoule à utiliser est une ampoule de 6V, 50mA, ce sont les (anciennes) ampoules de lampe de vélo (lampe rouge arrière). Il faut parfois adapter la valeur de la résistance de contre réaction (390Ω) pour avoir un signal sinusoïdal de environ 1V rms (2.4Vpp), c'est à ce moment que le signal en sortie a le moins de déformations. Augmenter la résistance si l'amplitude est trop faible, la réduire si l'amplitude est trop élevée.

La résistance de 10Ω et le condensateur de 50nF (partie rouge) peuvent être nécessaires si l'ampli sert à commander un haut parleur. Ce circuit compense le déphasage causé par l'inductance du haut parleur. Mais commander directement un haut parleur n'est pas recommandé car cela augmente les distortions du circuit. Mais en fait le haut parleur produit des distortions harmoniques plus importantes que le LM386. Mais si le circuit est conçu pour fournir un signal de test, il ne faut pas connecter un haut parleur. L'impédance (résistance de charge) peut avoir une valeur de 50Ω ou plus et la tension d'alimentation est de 9V.

La partie bleue peut être ajoutée si l'ampli a du mal à démarrer automatiquement, ce condensateur n'est normalement pas nécessaire: il vaut mieux jouer avec la valeur de la résistance de feed back. Cet ampli a un gain de 20dB, alors qu'un a-op classique a un gain de 80 - 100dB.

J-FET comme résistance variable

Le circuit suivant se passe de lampe incandescente et utilise à la place un J-FET. Il s'agit d'un N-channel depletion, c.à.d. qu'il est conducteur avec une tension de gate nulle. La résistance augmente avec une tension négative (tout comme un tube électronique) pour devenir pratiquement infinie avec une tension de gate de -8V (que nous n'atteignons normelement pas).

Il est possible d'utiliser tous les types de transistors à effet de champ junction-fet. Si vous utilisez un MOSFET, il sera probablement à enhancement (non conducteur à tension de gate nulle). Le schéma nécessite alors une refonte pour avoir une tension positive sur le gate, qui se réduit quand le circuit oscille.

L'ampli utilisé est un LM324, un a-op quadruple, mais vous pouvez utiliser tout type d'a-op. La sortie ici est à impédance relativement élevée.

Le circuit contient en plus une amélioration qui va réduire les distortions de l'ampli opérationnel, notament un filtre passe bas. La résistance doir avoir une valeur de 2× la résistance de détermination de la fréquence (donc 47kΩ) et le condensateur une valeur de 5× la valeur de C2 et C3. Le filtre passe-bas élimine toutes les harmoniques (et donc les déformations). L'amplitude du signal est légèrement moindre, mais l'impédance est plus élevée et nécessite un ampli de sortie. Avec ce filtre supplémentaire, on obtient un signal avec une distortion de moins de 0.1%, même avec des composants génériques.

De toute façon, pour avoir un fonctionnement stable (fréquence et amplitude) il faut séparer la fonction d'osscillateur et d'amplificateur. Ainsi la charge n'influence pas sur le fonctionnement.

Un tel oscillateur est normalement utilisé pour mesurer la puissance d'un amplificateur. Quand la puissance maximale de l'ampli est atteinte, le taux de distortion augmente brusquement. Mais pour être fiable, il faut que la source ait une distortion très faible.

Il est possible de varier la fréquence dans un facteur de 1 à 10 en modifiant simultanément la valeur des deux résistance de controle de fréquence (utilisez un potentiomètre de volume stéréo de bonne qualité). Cette modification ne permet plus l'utilisation du filtre en sortie.

Remarquez sur le schéma ci-dessus la résistance de 4.7k vers le positif. Cette résistance force l'a-op à travailler en classe A. Sans résistance de charge vers le positif (ou le négatif), il y a une légère distortion quand le transistor dans la branche positive passe le flambeau au transistor dans la branche négative et inversément (crossover).

Les transistors de sortie n'ont en effet pas de bias, les deux bases sont reliées ensemble (ligne rouge). Avec la résistance en sortie connectée au positif, on force le transistor Q11 à être constamment en conduction.

Q9 est le transistor de commande, Q15 est une source de courant, Q14 est un amplificateur (la source de courant produit un courant très faible), Q12 est une protection qui réduit la commande des transistors de sortie en cas de cours circuit et Q11/Q13 sont les transistors de sortie.

Commande par led et cellule CdS

Il existe également des oscillateurs qui ont une stabilisation de la tension par une petite lampe led qui reçoit la tension redressée (et légèrement filtrée pour éliminer l'intermodulation). La lumière de la led est envoyée à une cellule CdS (sulphure de cadmium) sensible à la lumière. La résistance de la cellule diminue quand elle est éclairée, elle agit de façon inverse que la lampe incandescente dont la résistance diminue.


Vu dans ... Vu dans le PDF j3ea13002.pdf


Vu dans ... Vu dans Electronique pratique


Générateur Application

01

CAPACIMETRE

02

GENERATEUR TBF

03

GENERATEUR BF

04

GENERATEUR_BF_ECONOMIQUE

05

06

07

08

09

10

Oscillateur BF

THE END


Oscillateur BF CMOS

01

02

03

04

05

06

07

08

09

10

11

12

13

14

15

04
CLIGNOTANT_3Voies

05
SQUARE_WAVE

06
TOUCH LATCH

07

02

03

04
< br>
05


RC Multivibrateurs

MULTIVIBRATEUR avec Bouton APPEL

02

03

04

05

06

07

08

09

10

11

12

13

15

16

17

18

19

20

21
CLIGNOTANT SIX

22
CLIGNOTEUR TOURNANT

23

24

25

26

27
SIRENE_TYPE_AMERICAINE

THE END


RC Phase 180

MAGI EYE Oscillant

01

02

03

04

05

06

07

08

09

10

11

12

13

14

15

16

17

18

Oscillateur RC Jeu Philips EE 1977

19

Oscillateur audio pour Grip Dip Meter TELETESTEUR

21

22

24

22

23

23

22

23

23

22

23

THE END


ATTENUATEUR Radio-Constructeur 1968


ATTENUATEUR BF

Attenuateur ELEX 41

Sweep generators R.Johson 1953 d'usa

Voltage calibrator RCA ham tips 69-11 pdf "Schéma complet"

Atténuateur du 931

ATTENUATEUR Metrix Wobulateur

ATTENUATEUR en DB Elektor

Attenuateur ELEX 41

Attenuateur_1959_VHF


Vu dans RADIO Constructeur n°125 1957


Vu dans Electronique applications n°14


Vu dans radio-Pratique N°20 et N°21 1954